1. Gaiking's Avatar
    Well I've had my Lumia 900 a while now and wanted to comment about the battery life. I get just about 15 hours on average with moderate to heavy use with a lot of background tasks enabled.

    I have had my Microcell unplugged for a while now and battery life has been good. I decided to plug it back in two days ago and my battery life plummeted to about 9 hours with little use.
    Now the microcell is unplugged again and my battery life is back to normal.

    This is just some info for other Lumia 900 users that may have battery trouble and a microcell


    Sent from my Lumia 900 using Board Express
    05-06-2012 06:55 AM
  2. pderosa's Avatar
    An alternate solution to turning off the Microcell completely is to turn off your cellular data while at home and rely only on wifi. I found this helps to not drain the battery while allowing me to have a usable signal. The only downside is that email does not automatically check and you don't get toasts until you turn the screen on and wifi connects again.
    05-06-2012 08:22 AM
  3. rutvik19's Avatar
    This problem has been quite annoying at work for me. AT&T has put microcells through out my building, and it kills my battery life. I have to keep my charging cable near by.
    05-06-2012 12:24 PM
  4. riffraffy's Avatar
    I too, had battery issues with the micro cell. At least my Lumia gets a better signal than my old phone, so I don't really need the micro cell.

    On the plus side, I was able to sell the micro cell on ebay for $150...
    05-06-2012 03:01 PM
  5. milk242's Avatar
    For some reason my microcell is not showing the huge battery drain like it did before. The only difference between now and then is I did that procedure where you can choose your max data connection.

    I'm measuring battery drain using the diagnostic app. Before, my microcell with cell data on showed a Ma discharge of around 250. Now it shows only 90 (which is the Ma discharge with my microcell disconnected).
    05-06-2012 03:46 PM
  6. Gaiking's Avatar
    @milk242 how did you set the max data connection? Was it a phone setting or a microcell setting?

    Sent from my Lumia 900 using Board Express
    05-06-2012 10:24 PM
  7. milk242's Avatar
    @milk242 how did you set the max data connection? Was it a phone setting or a microcell setting?

    Sent from my Lumia 900 using Board Express
    It was in one of the threads here titled edge, 3g, 4g toggle.

    Here's a direct link to the relevant information:
    How to toggle LTE on/off on your Nokia Lumia 900 ~ Nokia For Us
    05-06-2012 10:58 PM
  8. invertme's Avatar
    It's not just the Lumia 900 that has issues with the Microcell. Many other phones have this exact same problem. AT&T knows it's an issue but hasn't fixed their MCELLS yet.
    05-07-2012 08:58 AM
LINK TO POST COPIED TO CLIPBOARD