1. bobosaur1's Avatar
    Do all L900's have the issue where the person receiving the call experiences echos? I've looked around and it seems like this issue isnt just me. I know keeping the volume below 7 can help, but there doesnt seem to be a solution.

    Do people have phones without this issue? I'm wondering if I should bother exchanging my phone to fix this... otherwise I'll have to sell mine off (its past its 30 days). I love all the L900 features but good call quality is a must in a phone..
    05-26-2012 01:23 PM
  2. ltyarbro42's Avatar
    People I have talked to say they hear an echo also, along with my voice sounding very muffled

    Sent from my Lumia 900 using Board Express
    05-26-2012 02:24 PM
  3. undisputed n00b's Avatar
    People say they hear an echo and I lower the volume and they no longer hear it. Try lowering your volume and see if that works. I usually have to lower mine to 6/10
    05-26-2012 04:30 PM
  4. jimski's Avatar
    I don't make/receive a lot of calls, but in the 15-20 I have had since getting my L900, I have not noticed any echo or anything else. Didn't ask the person at the other end, but they seemed to hear me clearly as I never had to repeat myself. One caller was a little garbled, bit she was using an iPhone.

    I also have not had a need to change the in-call volume so not sure where it is. I assume it is still at default, whatever that is. Guess I should call voice mail and take a look.

    Sent from my Lumia 900 using Board Express Pro
    05-26-2012 04:44 PM
  5. bobosaur1's Avatar
    People say they hear an echo and I lower the volume and they no longer hear it. Try lowering your volume and see if that works. I usually have to lower mine to 6/10
    this is what i do, but i dont want a phone that can never be put on a higher volume...
    05-26-2012 05:05 PM
LINK TO POST COPIED TO CLIPBOARD