1. joonbeams's Avatar
    I've had this WP7 phone for almost a week and have noticed that the exchange mail (at least exchange) is not pushing real time. As someone who also owns a Razr and iPhone (I know:blush:), I intended to use this phone purely for business. But the push/exchange email is not reliable at all (works flawless on Razr on same network, same settings). I've tried everything (proper settings, updated software, resets,e etc.)--sometimes it pushes, other times it does not. Anyone else experiencing? I want to love this phone but if I can't get exchange server to work on a Windows phone...
    05-30-2012 01:26 AM
  2. mworsham's Avatar
    I've had this WP7 phone for almost a week and have noticed that the exchange mail (at least exchange) is not pushing real time. As someone who also owns a Razr and iPhone (I know:blush:), I intended to use this phone purely for business. But the push/exchange email is not reliable at all (works flawless on Razr on same network, same settings). I've tried everything (proper settings, updated software, resets,e etc.)--sometimes it pushes, other times it does not. Anyone else experiencing? I want to love this phone but if I can't get exchange server to work on a Windows phone...
    I've used WP7 and Exchange in a corporate environment since WP7 was released. At my company WP7 is one of the phones that our IT department offers. I had a Samsung Focus, and moved to the Lumia 900 a few weeks ago. I use Exchange for e-mail, contacts and calendar, and have never had an issue with it not syncing real-time. I usually hear my phone alert before I see the new e-mail on my laptop.

    Maybe you are having an issue with the WiFi bug and it obviously won't sync whenever you are experiencing that problem?
    05-30-2012 08:53 AM
  3. joonbeams's Avatar
    Thanks mworsham. This is actually reassuring. I am on my second device and still with the same problem - I don't get my emails real time. I've tried data only with wifi off and vice versa and still the same. But I'm glad to hear that on a Lumia 900 this works for you. Gives me hope that there is something I have not yet factored in on my end.

    P.S. - not to start a fanboy war, but having had true experience with the three main OSs (and blackberry, and palm before that), I genuinely find WP7 the most refreshing and the most suited for business/personal use if I could get this to work. And I'm a Nokia fan, so I'm really rooting for this!!
    05-30-2012 11:56 AM
  4. mworsham's Avatar
    You do have your Exchange account set to "as items arrive" on the phone itself, correct? I'm not sure what else you could check; I just know that my e-mails definitely come in as they are received. I hope you can get it working correctly!
    05-30-2012 02:39 PM
  5. joonbeams's Avatar
    Been working on this all day. Still no luck. Seems that once phone goes idle, real time push stops. I then get emails in 10-15 min batches. I suspect the data connection (wifi or LTE makes no difference) goes idle in sleep mode and only periodically "wakes up" (e.g. to update facebook, etc.). When the phone is on and in use, I usually get my emails as they come in. This is very frustrating...

    And yes, I do have the email set to "as items arrive." Thanks for helping mworsham!
    05-30-2012 05:03 PM
  6. joonbeams's Avatar
    Just got off the phone with Nokia tech support (Level 3). They say that this behavior is "normal." I made sure to repeat it twice, but they say that for battery reasons, it is normal for the phone to go into an "idle" mode where the data signals shut down and reactivate every 10-15 minutes. WOW is all I can say, just wow. This puppy is going back - gonna try the HTC Titan.
    05-30-2012 05:25 PM
  7. mworsham's Avatar
    That is really strange, and not my experience at all. I don't think the tech support person knew what they were talking about. Regardless, I hope that if you go to the HTC that it'll work properly for you. I know how important it is to get Exchange e-mails in a timely manner! :)

    Sent from my Lumia 900 using Board Express
    05-30-2012 10:59 PM
LINK TO POST COPIED TO CLIPBOARD