1. invertme's Avatar
    The vibrator died on my L900. Luckily AT&T was right on it and shipped me a new one (should get today).

    I was just wondering if anyone else had their vibe die on them? The phone feels dead to me when I use it now. I didn't realize how much I expect to feel that vibrate when I use it. I never thought I would notice it if it were missing but I do.
    10-24-2012 08:35 AM
  2. palandri's Avatar
    Did you try a hard reset first? If you haven't you might as well try it now since you have a new phone coming.
    10-24-2012 08:50 AM
  3. invertme's Avatar
    Yeah I did. It's a mechanical defect so a reset wouldn't help it anyways. I just did it to make the AT&T support happy.
    palandri likes this.
    10-24-2012 09:27 AM
  4. invertme's Avatar
    Holy cow!

    I got my new phone (only took 1 day!) and it's better than my last one!

    The vibrate is "normal" now. No more raspy grind. Also the phone is faster - MUCH faster. It reminds me more of my focus now with how responsive it is. Hopefully it doesn't slow down as I load apps.

    Also the side buttons are more secure feeling. My original L900 has slighlty looser feeling buttons.


    Just took a picture now too and it focused much faster in lower light..

    crazy - I didn't expect any changes.
    palandri, Old_Cus and Laura Knotek like this.
    10-24-2012 12:16 PM
  5. Old_Cus's Avatar
    Good thing the hard reset didn't fix it :)
    Laura Knotek likes this.
    10-24-2012 01:44 PM
  6. invertme's Avatar
    Good thing the hard reset didn't fix it :)


    Totally!

    Two more good things.

    1) When I plug the phone in to charge it lights up right away and shows it's charging. Before it would take a few seconds (up to a minute) and if I hit the power button too early it would light up the screen then turn it back off immedietly. Not a big problem but it felt a little un polished.

    2) The light sensor works much better. Before when I went outside it could take a minute or two for the screen brightness to change so that I could read the screen in the sunlight. Now it does it within a few seconds. This was a major pain before - awesome now.


    I am very happy these things are fixed but now I am very nervous to get a 920 when they come out... I don't want to have the same thing happen. Get a early device that might not have all the bugs worked out. Not saying that will happen. The 920 could be near perfect one day one.

    Anyways - I'm happy that my new phone is working so well.
    10-24-2012 01:54 PM
LINK TO POST COPIED TO CLIPBOARD