1. furryantelope's Avatar
    Hello,

    I recently bought an unlocked Att Nokia Lumia 900. I use it with Tmobile and it was working just fine for weeks. I did plenty of research before I bought it to make sure many others have succesfully used it with Tmobile and many have said it works fine. But now for some reason I can't get any service to Tmobile. It just says "no service emergency calls only." I even went to Tmobile and replaced the sim card just in case it was a defective card but that did not change a thing! I'm sure many can share my frustration in not having their phone work. I use my phone to keep myself organized on meetings and events, as well as keeping in contact with clients. This sucks.

    Has anyone experienced this problem before? I would really appreciate a solution to this.

    Thanks :)
    04-14-2013 03:31 PM
  2. palandri's Avatar
    You could try resetting the phone.

    Maybe the SIM slot went bad.
    04-14-2013 03:44 PM
  3. Myles Sampey's Avatar
    I had the exact same thing happen with my Lumia 920. It died in middle of night and when I woke up and charged it there was no service. I tried resetting it, did a factory reset, took sim card in and out and even went to AT&T to get replacement SIM and still didn't recognize it. My warranty covered it though so I got a new one.
    04-14-2013 04:19 PM
  4. furryantelope's Avatar
    Unfortunately I bought this phone through 1saleaday.com and they do not accept returns and have a pretty strict product defective policy. Any other suggestions or solutions?
    04-14-2013 05:09 PM
  5. palandri's Avatar
    Try a reset and if that doesn't work call Nokia and see if they can do anything. Have you had it over a year? You said recently so?
    04-14-2013 05:14 PM
  6. furryantelope's Avatar
    I did already try a soft and a hard reset but that didn't change anything. I bought it no longer than 2 weeks ago.
    04-14-2013 08:01 PM
  7. annapajama's Avatar
    Me too! had the phone a couple of years then went to Hatteras Island where I had no service. Never got it back and OF COURSE I tried factory reset. Went to t mobile and on with techs for almost 2 hours. no luck no ideas Do not want to buy a new phone do not feel like I should have to There is SOMETHING off that someone is missing. The phone was FINE until I lost service on the island! Frustrating.
    10-20-2013 01:53 AM

Similar Threads

  1. No Service Bug?
    By dj9928 in forum Nokia Lumia 710
    Replies: 12
    Last Post: 05-25-2015, 03:55 PM
  2. No Service Bug
    By MattLFC in forum Nokia Lumia 710
    Replies: 13
    Last Post: 08-29-2014, 04:00 AM
  3. Always No Service! - HTC Radar
    By Guilherme Quelhos in forum HTC Radar
    Replies: 2
    Last Post: 12-01-2011, 07:19 AM
  4. No Service - HTC WP
    By Guilherme Quelhos in forum Windows Phone 7
    Replies: 0
    Last Post: 11-29-2011, 08:44 PM
LINK TO POST COPIED TO CLIPBOARD