1. Alteran195's Avatar
    So it's been a while since I used my 900, got an itch to use Windows Phone again, and when I plug it in, it just goes to a blank white screen, then goes black and shows a low battery indicator.

    I tried booting it, letting it get to the Nokia screen, then plugging it in but it just says goodbye after the windows phone screen and turns off and starts looping again.

    It's been plugged in for a good 30 minutes and it keeps doing the same thing. Any advice?

    Posted via the WPC App for Android!
    04-10-2014 08:55 PM
  2. Jazmac's Avatar
    Where was it stored? Can anyone in the house get their hands on it? Like some kids?
    04-11-2014 01:04 AM
  3. Loco5150's Avatar
    The battery is in a deep discharge stage. Plug it it to your computers usb post and leave it there, hours or even a full day if it needs to...

    You can also try to keep it very long time in your wallcharger, but computers usb does not have cutoff to power like wall chargers have.
    04-11-2014 01:35 AM
  4. Loco5150's Avatar
    Eventually it should come out of the loop and get enough power to properly boot. Then let it charge fully. Maybe do few good cycles also with it and dont put it back away directly.
    04-11-2014 01:37 AM
  5. Alteran195's Avatar
    So it's gotten past the boot loop, but now gets stuck at the rethink possible screen.

    Posted via the WPC App for Android!
    04-11-2014 05:16 PM
  6. Loco5150's Avatar
    Rethink possible?
    04-12-2014 08:54 AM
  7. colinkiama's Avatar
    Maybe its a sign that you should.....
    04-12-2014 09:10 AM
  8. Alteran195's Avatar
    It's been plugged into my computer for 2 daysish now and it either loops, gets stuck on the att screen, or on the low battery screen.

    I don't get how it can just die like this, it's only what 2 years old? I haven't even used it consistently for that time, I switched to my iPhone and back a couple times and now I have the Nexus 5. My iPhone 4 is double that and it still works fine if I wanted to use it.

    It's not like it's been dropped or exposed to anything that could harm it, since I moved to my new place in October its been sitting on a shelf.

    Posted via the WPC App for Android!
    04-12-2014 09:52 PM
  9. Loco5150's Avatar
    Might indicate that the battery really has died and wont take charge. It could be that there hasnt been any charge on it and then left for a long time. Thats the worst for battery you could do. If you get some power in to it, you can try button hard reset. Maybe that would get you past the ATT screen.
    Laura Knotek likes this.
    04-13-2014 01:05 AM
  10. Zulfigar's Avatar
    So it's been a while since I used my 900, got an itch to use Windows Phone again, and when I plug it in, it just goes to a blank white screen, then goes black and shows a low battery indicator.

    I tried booting it, letting it get to the Nokia screen, then plugging it in but it just says goodbye after the windows phone screen and turns off and starts looping again.

    It's been plugged in for a good 30 minutes and it keeps doing the same thing. Any advice?

    Posted via the WPC App for Android!
    Put it in your freezer over night and try giving it a charge in the morning.
    04-13-2014 01:41 AM
  11. Alteran195's Avatar
    Tried the freezer and no change.

    The buttons for resets also don't seem to work.

    Soft is volume down and power right? Im not sure which is hard reset.

    Posted via the WPC App for Android!
    04-15-2014 06:14 PM
  12. Alteran195's Avatar
    Contacted Nokia and did all of the steps they gave me and their suggestion is to send it into a service center, which im not gonna do because im sure itll cost money based on the phones age.

    I checked device manager and the phone shows up occasionally as an unknown device which means the driver isnt installed properly, does anyone know if theres a good place to download the 900s Windows driver?

    A bit disappointed this phones only lasted 2 years, I always thought Nokia was one of the best, if not the best hardware makers out there. I have an iPhone 3g that still boots perfectly fine if I wanted to use it.
    04-16-2014 05:00 PM
  13. Jad Saleh2's Avatar
    had the same problem .. did you find the fix?
    thx
    10-11-2014 08:26 PM

Similar Threads

  1. Breaking Up With Siri (funny)
    By Kronus24 in forum Cortana
    Replies: 7
    Last Post: 04-13-2014, 08:00 AM
  2. Titanfall picks up massive patch, introduces private matches and more
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 04-10-2014, 02:52 PM
  3. T-Mobile offers up LTE tablets for the price of Wi-Fi models, free data through 2014
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 6
    Last Post: 04-10-2014, 01:31 PM
  4. Are the Nokia lumia numbers jumping up a hundred?
    By Bogi Georgiev in forum Microsoft News & Rumors
    Replies: 2
    Last Post: 04-10-2014, 04:32 AM
  5. Replies: 1
    Last Post: 04-10-2014, 03:16 AM
LINK TO POST COPIED TO CLIPBOARD