1. dinkatoid's Avatar
    I just had an odd glitch with my 920. I had been playing with some apps and such, but then put it down to walk off off for a few. I had it sitting next to me and hit the power button to check to see if I had missed any messages. However, nothing happened. I figured maybe a bad app had drained my battery, so I borrowed a cord and charged it for a few mins, but nothing happened. However, the PC did recognize it and show me the data in it, so something was clearly working.

    I finally tried to hold down the volume down and power button, and the phone eventually vibrated and rebooted. However, it would just load up the ATT sign, then the Nokia logo and start over. This happened 4-5 times in a row before I did it again. Finally on the third time it worked and got into Windows.

    Has anyone experienced anything like this? Should I just return the phone for a new one in case it is defective, or give it a few more days and see what happens?
    11-14-2012 03:29 PM
  2. eagle628's Avatar
    This very same thing just happened to me, and the power+volume button brought it back to life. Very peculiar. I'm already planning on replacing the phone because the proximity sensor died, but still, not especially promising.
    01-30-2013 07:06 PM
  3. realwarder's Avatar
    My wife's phone when it locked up and rebooted during a call did exactly that. But her phone had previously locked up and reset about 4 times over a week.

    We replaced it and been perfect since.
    01-30-2013 07:29 PM
LINK TO POST COPIED TO CLIPBOARD