1. Guitarpik's Avatar
    Maybe I just haven't figured it out yet, but so far the browser on this phone is the worst I've ever used...

    When I type wireless.att.com/order_status/order_status directly into the address bar I get this...

    attsite.png


    Any time I search for something through google, I get a really hideous looking page like these with pretty much no functionality...

    gta5.jpg

    wikipedia.png


    Am I doing something wrong or is the browser really this worthless?
    11-18-2012 09:03 PM
  2. Reflexx's Avatar
    I don't know why you're getting that for the order page. Do you have your browser set to display pages as Mobile or Desktop view? I'd recommend using Desktop view.

    As for the Google pages... yeah. It's how Google chooses to display pages when it detects IE for WP. Kinda jacked up. You end up having to click "View Page Directly" in order to see the page you want sometimes.
    11-18-2012 09:11 PM
  3. Samvel87's Avatar
    Loads on mine just fine.
    11-18-2012 09:13 PM
  4. brmiller1976's Avatar
    The AT&T thing looks like a server-side problem.

    The Google thing is completely expected behavior for the Google spyware on non-Google platforms. It's best to use Bing, which renders pages properly on Windows Phone.
    11-18-2012 09:14 PM
  5. Darus214's Avatar
    Try switching between desktop/mobile versions under settings.
    11-18-2012 09:15 PM
  6. mjfadaway's Avatar
    Maybe I just haven't figured it out yet, but so far the browser on this phone is the worst I've ever used...

    When I type wireless.att.com/order_status/order_status directly into the address bar I get this...

    Click image for larger version. 

Name:	attsite.png 
Views:	24 
Size:	90.3 KB 
ID:	23079


    Any time I search for something through google, I get a really hideous looking page like these with pretty much no functionality...

    Click image for larger version. 

Name:	gta5.jpg 
Views:	17 
Size:	107.7 KB 
ID:	23080

    Click image for larger version. 

Name:	wikipedia.png 
Views:	14 
Size:	253.2 KB 
ID:	23081


    Am I doing something wrong or is the browser really this worthless?
    it has something to do with the way google renders pages, so if your search using google via desktop mode your gonna have to click "view page directly". Once you click view page directly, everything loads just fine proving there's nothing wrong with your phone. If you don't mind viewing pages in mobile format, u can go to settings and change it to mobile mode... Or u can bypass everything and search with Bing instead of google.
    11-18-2012 09:25 PM
  7. Guitarpik's Avatar
    I don't know why you're getting that for the order page. Do you have your browser set to display pages as Mobile or Desktop view? I'd recommend using Desktop view.

    As for the Google pages... yeah. It's how Google chooses to display pages when it detects IE for WP. Kinda jacked up. You end up having to click "View Page Directly" in order to see the page you want sometimes.
    I do have it set on desktop. The page just won't load for some reason :/
    11-18-2012 09:52 PM
  8. Guitarpik's Avatar
    Thanks for the answers about the google issue. Kinda sucks cuz I find Google to give me much better results than Bing.
    11-18-2012 09:54 PM
  9. brmiller1976's Avatar
    Google has taken active steps to ensure that content served to Windows Phones through Google services will always be garbage. They even blocked Microsoft's efforts to make YouTube function properly by closing the ports that MS was using for the app.
    11-18-2012 09:55 PM

Similar Threads

  1. Sorry, but I can't put up with this anymore
    By HeyCori in forum HTC TITAN
    Replies: 20
    Last Post: 01-03-2012, 01:37 PM
  2. This is what WP7 is up against....
    By thomasward00 in forum Windows Phone 7
    Replies: 4
    Last Post: 06-07-2011, 10:24 AM
LINK TO POST COPIED TO CLIPBOARD