1. WPer's Avatar
    My Lumia 920 can charge itself even if it runs out of battery and turns off automatically. Plugging the charger cable will first make the phone boot to the AT&T screen and the black charging-icon-only screen. About 5 secs later, it will reboot and show the start screen with charging icons at top right corner.

    However, today I was watching video with a Netflix-like software until the battery is empty. When I plug in the charging cable, the phone stuck at the charging-icon-only screen with one red bar showing in the battery. It won't boot to the start screen again! Anyone has had the same problem?
    12-22-2012 04:07 PM
  2. newfiend's Avatar
    Yes, Basically what has happened is that the battery does not have enough charge quite yet and will not boot the OS until the battery has enough charge... Plug it in and let it sit.. This is normal and even WP7 devices did this if the battery gets "too low".
    Plug it in and let it sit.. After awhile when the battery reaches enough charge it should boot.
    Good Luck.
    newfiend~
    WPer and Laura Knotek like this.
    12-22-2012 04:27 PM
  3. WPer's Avatar
    What you said is absolutely right. After 20-min wait, it now can boot to the start screen.
    newfiend likes this.
    12-22-2012 04:28 PM
  4. newfiend's Avatar
    I believe that the OS has to have a minimum charge in the battery to boot .. Once the battery is ran that low it takes a few minutes to charge before it will reboot. Glad it's now working for you.
    Take Care,
    newfiend~
    12-22-2012 04:41 PM
  5. Brandy Sweeney's Avatar
    Mine did the same thing but instead of booting after a bit it just gives me a little red bar a plug flashes then it goes to a quetion mark. I have had it on the charger for 4 hours. Any help?
    05-13-2013 01:53 AM
  6. pauline lalabelle6's Avatar
    The same thing is happening to me right now, do I need to do anything? Have you found out how to turn it on then?
    05-17-2013 07:25 AM
  7. Luis Carlos Diaz's Avatar
    I'm having the same issue with the Lumia 521. The phone went dead with abort 50% battery. I'ts been charging for more than 4 hours and it's still not able to turn on. All I get is the battery image with the red bar. Is it the ohone or the battery? The phone is not even three months old...
    07-15-2013 12:34 AM

Similar Threads

  1. Lumia 900 dead battery, won't turn on.
    By Ryistech in forum Nokia Lumia 900
    Replies: 16
    Last Post: 12-12-2016, 08:45 PM
  2. HD7 won't charge, blinking orange-green
    By rabit1 in forum HTC HD 7 / 7s
    Replies: 8
    Last Post: 10-18-2013, 08:56 AM
  3. Car stereo USB won't charge HD7
    By Swirlz in forum HTC HD 7 / 7s
    Replies: 9
    Last Post: 03-11-2012, 11:05 PM
  4. battery indicator showing charging when unplugged`
    By svtfmook in forum Samsung Focus S 4G
    Replies: 4
    Last Post: 02-27-2012, 10:18 PM
LINK TO POST COPIED TO CLIPBOARD