1. miki20021's Avatar
    Hi all.

    I tried connecting my L920 to nokia care suite, and it spit out this message: "not supported product identified RM-821".

    Any Idea of what can it mean? It is obviously supports Lumia 920 devices.

    Help appreciated.
    01-27-2013 02:38 PM
  2. MikeTheYid's Avatar
    You have an old version of the software and not the latest.
    01-27-2013 02:58 PM
  3. miki20021's Avatar
    Any idea where I can download the latest?
    01-28-2013 03:08 AM
  4. Pi Sin's Avatar
    nokia care suite is no longer require n thats why its been outdated for wp 8
    01-28-2013 03:11 AM
  5. miki20021's Avatar
    But if you want to flash portico, dont you need nokia care suite?
    01-28-2013 03:47 AM
  6. sutt359's Avatar
    You need to find Nokia Care Suite 2012.45.4.5 dont update it from there as it will ask you to login.

    But ye you do need the care suite to flash roms.
    01-28-2013 05:38 AM

Similar Threads

  1. Replies: 16
    Last Post: 12-27-2012, 08:29 PM
  2. Lumia 920 does not support T-Mobiles 1700 AWS band
    By Ploogle in forum Nokia Lumia 920
    Replies: 2
    Last Post: 10-12-2012, 06:40 PM
  3. Exchange server version not supported error
    By invisik in forum Windows Phone 7
    Replies: 5
    Last Post: 04-11-2012, 02:12 PM
  4. Slacker app does not support multitasking?
    By mapexvenus in forum Windows Phone 7
    Replies: 3
    Last Post: 09-28-2011, 07:15 PM
  5. A2DP? WP7/Focus not supporting it?
    By contento#WP in forum Windows Phone 7
    Replies: 7
    Last Post: 11-23-2010, 05:28 PM
LINK TO POST COPIED TO CLIPBOARD