1. xalasten's Avatar
    Hi Everyone, sorry if this has been asked but is there no way to get lte to work on Bell? I have it unlocked and mms,internet sharing etc work but I can only get 4G to show. In tests I am getting hspa+ speeds. Any help would be great!
    02-03-2013 08:37 PM
  2. Noob1ee's Avatar
    I have LTE with Virgin which uses Bell's network. Have you tried installing the access point app and selecting Bell?
    02-03-2013 10:31 PM
  3. WavingReds's Avatar
    yep not on bell, Roger uses the 700 band, Bell and Telus signed and agreement to use the 850 band so...yeah D=
    02-03-2013 10:40 PM
  4. xalasten's Avatar
    I do have access point installed and the Lumia 920 is supposed to be pentaband so should support all the frequencies I thought?
    02-03-2013 11:29 PM
  5. lipper2000's Avatar
    I never realized 4G was not LTE lol...ive not seen LTE symbol either...getting pretty quick speeds on Bell though with my unlocked Rogers 920
    02-03-2013 11:41 PM
  6. lipper2000's Avatar
    I read the Canadian manual and it only talks about 4g
    02-03-2013 11:49 PM
  7. WavingReds's Avatar
    oh sorry my mistake, bell does use the 700 band as well.

    the pentaband phone was only for I believe the 3G network and it was the first batch that came out.

    Do you have an LTE sim card?
    02-03-2013 11:57 PM
  8. xalasten's Avatar
    Yep using lte sim from my HTC 8x
    02-04-2013 12:00 AM
  9. WavingReds's Avatar
    Then sorry I don't know how to help you, I've seen the LTE symble...actually I've seen all the symbols like a car shifting into higher gears
    O > E > 3G > 4G > LTE
    xalasten likes this.
    02-04-2013 12:12 AM
  10. lipper2000's Avatar
    Then sorry I don't know how to help you, I've seen the LTE symble...actually I've seen all the symbols like a car shifting into higher gears
    O > E > 3G > 4G > LTE
    ive probably got a 3G sim....how can i tell the version of phone if some are not LTE?

    if i get a 4G SIM...will it work with 3G devices...didnt know there was a difference
    02-04-2013 09:44 AM
  11. VegaNovus's Avatar
    4The box should say 4G/LTE ready if it's 4G/LTE capable.

    4G sim cards work fine in 3G devices :)
    02-04-2013 10:11 AM
  12. slashd0t's Avatar
    I'm on Bell and LTE works for me..
    lipper2000 likes this.
    02-04-2013 10:15 AM
  13. xalasten's Avatar
    I seem to be getting an LTE signal now from time to time, I am not sure why but it seems to work somewhat. The speed difference is not really noticeable except when downloading something so I guess I will just deal with it. Thanks for all the tips everyone.
    02-04-2013 12:34 PM
  14. WavingReds's Avatar
    make sure it actually says LTE and not 4G. I work in a cell phone shop and we sell sims from bell that says 4G and LTE
    02-04-2013 12:54 PM
  15. lipper2000's Avatar
    so do I need to have a different SIM for LTE? I just took the SIM out of my old phone (3G), cut it down and it worked fine but I never see the LTE...just 4G..
    I'm getting close to 30mbps with speedtest
    02-04-2013 01:23 PM
  16. lipper2000's Avatar
    BTW- box says :
    WCDMA 850/900/1900/2100/1700_2100 : LTE 700/850/1900/1700_2100 GSMQUAD
    02-04-2013 01:24 PM
  17. Noob1ee's Avatar
    so do I need to have a different SIM for LTE? I just took the SIM out of my old phone (3G), cut it down and it worked fine but I never see the LTE...just 4G..
    I'm getting close to 30mbps with speedtest
    You will need an LTE sim, usually LTE sims will say LTE on the sim itself.
    lipper2000 likes this.
    02-04-2013 01:53 PM
  18. lipper2000's Avatar
    I'm on Bell and LTE works for me..
    Did you have to get a new LTE sim? When I look on the bell site the small sim's say they are for iphone5 only?!
    Perhaps I'm misunderstanding it...I thought the iphone4 and 5 had the same micro sim card...

    I cut down my regular sim to size and it works fine but would like LTE which I am seemingly not getting as it never states LTE

    Thanks.
    02-05-2013 07:29 PM
  19. slashd0t's Avatar
    Did you have to get a new LTE sim? When I look on the bell site the small sim's say they are for iphone5 only?!
    Perhaps I'm misunderstanding it...I thought the iphone4 and 5 had the same micro sim card...

    I cut down my regular sim to size and it works fine but would like LTE which I am seemingly not getting as it never states LTE

    Thanks.
    I do have an LTE sim yes.

    Sent from my Nexus 7 using Tapatalk HD
    02-06-2013 06:54 PM
  20. WavingReds's Avatar
    yes, you will need a micro bell sim that says LTE on it, not 3G, not 4G.

    the LTE sim has access to the LTE network and lower.

    the iPhone 5 will only take a nano sim, those only comes in LTE.

    To be honest, you're not missing much with LTE at all. the only thing you'll notice is a huge battery drain from LTE and 3G
    02-06-2013 09:48 PM

Similar Threads

  1. Replies: 7
    Last Post: 05-02-2015, 02:35 PM
  2. Replies: 14
    Last Post: 08-24-2014, 04:18 AM
  3. I just saw a yellow Lumia 920 - no LTE?
    By snaqvi91 in forum Nokia Lumia 920
    Replies: 7
    Last Post: 04-09-2013, 12:18 PM
  4. Rogers Lumia 920 on Bell no LTE?
    By xalasten in forum Nokia Lumia 920
    Replies: 0
    Last Post: 02-03-2013, 08:32 PM
  5. Rogers Lumia 920 price is $711 on the box?
    By garconcn in forum Nokia Lumia 920
    Replies: 5
    Last Post: 12-04-2012, 07:23 PM
LINK TO POST COPIED TO CLIPBOARD