1. nMIK-3's Avatar
    Its been some days now that I discovered another major flaw of the Mail App and applies to both Windows Phone and Windows 8 for all GMail or Google App users and I never saw anyone reporting it. Straight to the point. When you delete an email using these App, the app puts the email in the local deleted folder on an WP or Windows 8 device but the email never actually gets deleted from the Google servers, instead it gets mark as archived(!)

    So when you go to your "All Mail" folder on GMail or Google Apps mailbox you will see ALL YOUR EMAILS that you previously deleted using a the Microsoft Mail App. That's not enough? Now listen to this, since ALL MAIL displays ALL your emails including those in your Inbox and all other labels, ALONG with the archived messages, you cannot just "Select them All" to mass delete them, instead, in order to deleted these emails AGAIN you need to manually scan this list one by one and select the messages you previously deleted but never did and are now listed as archived emails.

    Try it yourself, I am sorry in advance, this will **** off a lot of people.

    I am using Windows 8 since the summer and Windows Phone 8 since last November and I am a heavy email user and I also used heavily the Microsoft Mail Apps across my devices, in my case I had some thousands of emails that I delete but never got deleted. Instead they were intact in the archived folder.

    This is just another weakness of the Mail App. In combination of its lack of ability to mail full resolution pictures and other major and minor issues, I now personally use the Mail App as a READ ONLY solution and nothing more.

    That's a MAJOR disappointment for me.
    Last edited by nMIK-3; 02-12-2013 at 09:06 AM.
    02-11-2013 09:05 AM
  2. Darkgift's Avatar
    When u click to the fat left of the email in the list, u'll see that there ate actually 2 copies of the same email, when the check boxes appear...one for inbox, one for All Mail. Make sure both are checked and then delete. Its annoying, but it works. I hate that Google All Mail Archive bull s**t.
    02-11-2013 09:24 AM
  3. Darkgift's Avatar
    If u delete from within an open email, then yes, the All Mail version will be archived.
    02-11-2013 09:25 AM
  4. nMIK-3's Avatar
    Darkgift, to summarize the first post in a sentence: You cannot delete an email using the Mail App, it gets marked as Archived.

    (All Mail on Google Mailbox is the only place you can see your archived emails)
    02-11-2013 09:29 AM
  5. ammarmalik2011's Avatar
    That doesn't happen to me. It could be because I've set it up as an Exchange account
    02-11-2013 09:40 AM
  6. nMIK-3's Avatar
    That doesn't happen to me. It could be because I've set it up as an Exchange account
    That's very weird. I have mine as an Exchange too. And I have verify the problem with other GMail users using Windows Phone and Windows 8 Mail App.
    02-11-2013 09:45 AM
  7. Black Helicopter Steve's Avatar
    This would happen if you used Thunderbird or Outlook on a PC, as well. Google thinks you should save every message. Similarly, if you move an item to a local folder in Thunderbird, it copies the message locally and archives the message in All Mail in gmail.
    02-11-2013 09:55 AM
  8. nMIK-3's Avatar
    Google has both Delete Option and Archive Option. They do offer both solutions and many other Apps with Google Mail support are following these standards including the Web Version of GMail and Google Apps, official Mobile Gmail Apps and many third party solutions are all offering both archive and delete options...

    If an App has a Delete option but is implementing it as an Archive, is not Google's fault.
    Last edited by nMIK-3; 02-11-2013 at 10:44 AM.
    02-11-2013 10:28 AM
  9. Darkgift's Avatar
    Sounds like u have an issue. In the mail app on WP, in my inbox when I receive a Gmail, I get 2 copies in a thread. If I expand the thread I can delete from inbox, all mail ir both. I'll try and post a screenshot.
    02-11-2013 11:04 AM
  10. Darkgift's Avatar
    Ok...I sent myself a test mail to my gmail account. Here is how it appears when I get it. One email, in two folders...Inbox and All Mail. In my Inbox it appears as a thread.


    From my inbox, if I tap all the way to the left, it will select the thread title, and the inbox version for deletion, but the All Mail version, by default will not be deleted. It will disappear from the inbox when the thread and inbox version is deleted, but will remain in the All Mail folder. You have to manually select that one for deletion as well.


    It's annoying, but not nearly as annoying as having to go back to my pc and do it all again from the All Mail folder.
    02-11-2013 11:28 AM
  11. rajkumr's Avatar
    Just go to the Gmail sync settings page (where you go to enable multiple google calendars), and check "enable delete email as trash for this device" and save.

    Now whatever you delete from the mail app will be properly deleted instead of being archived.

    Just follow the steps in this link,

    02-11-2013 12:05 PM
  12. nMIK-3's Avatar
    Thanks for the pics. From what I see we are talking about the same thing. You just delete the same email twice using your phone instead of cleaning app the archives from gmail.com. That does not change the fact that when you hit delete the email should go to the Trash folder, not archive.

    Your situation thought is a good workaround for people that want to cleanup archives from their phones. Me I can't stand seeing double copies of every single email.
    02-11-2013 12:11 PM
  13. Darkgift's Avatar
    Yeah I know. If I delete from with in an open email out if habit, its a pain to then have to go into All Mail and do it again. And its a pain for having to check 2 boxes instead of one in the lust view. Hence my very limited use of Google services.
    02-11-2013 12:53 PM
  14. Darkgift's Avatar
    Just go to the Gmail sync settings page (where you go to enable multiple google calendars), and check "enable delete email as trash for this device" and save.

    Now whatever you delete from the mail app will be properly deleted instead of being archived.

    Just follow the steps in this link,

    Was curious as to ur solution and can't seem to find what ur talking about. The steps in that linked forum are also not clear, or maybe I'm misunderstanding them.
    02-11-2013 12:56 PM
  15. Mystictrust's Avatar
    Try these settings on for size:

    Of course, that just kind of shifts everything from Gmail servers to whatever client you're using and then deletes it. As an alternative to that, you could always choose the option (when accessing via POP) to "Archive Gmail's copy" and then keep the IMAP settings as they are in the screenshot. The key is to turn auto-expunge "off" since when it is on, it defaults to archiving when you delete stuff.

    (or set up as exchange account and it should work)
    02-11-2013 01:07 PM
  16. nMIK-3's Avatar
    I will try these when I go home later today.

    But why the IMAP and POP settings have anything to do with this? We are using Exchange. If I remember correctly IMAP is turned off by default.
    02-11-2013 01:35 PM
  17. Mystictrust's Avatar
    Well, if you're using exchange it should delete itself... but if it's not then that's definitely an issue. IMAP and POP should work for those who set it up as a "gmail" account on the phone... not sure how W8 handles it.
    02-11-2013 01:49 PM
  18. nMIK-3's Avatar
    Problem solved. Here is what fixed the issue for me:

    For this to work, you need to have your Google Account setup as Microsoft Exchange (Not IMAP or POP) in your Windows Phone or Windows 8/RT device, it doesn't matter if you choose the Google Mail, or Outlook Exchange Icon from the Windows Phone Accounts and Emails setup as long as it has m.google.com on the Server setting.

    1. From your PC, in IE10, click on the Tools button (Alt+T)
    2. Go to Developer Tools F12 and then click on Tools
    3. Expand the "Change user agent string" tab and select "Apple Safari (iPAD)", we need to do this because the Google Exchange Settings are setup to be accessible from only iOS devices, in any other case the settings page is not going to get displayed. (After you done with this you can set it back to default.)
    4. Now while you are signed in to your Google Account, go to https://m.google.com/sync/settings/ if this doesn't work and don't get the settings page, try M.google.com/sync/settings/ (with capital M)
    5. Click on "WindowsPhone" or "WP8" or "Windows Mail" this will varies depending your device (for me I am using Windows Mail in three devices, a Lumia 920, a Surface and a Windows 8 PC, all my devices were listed there and I was able to enable the option to all of them)
    6. Finally select: Enable "Delete Email As Trash" for this device.

    7. Optional: Go to your Google Mail, on the left list choose "All Mail" and manually go over all your emails and clean up the archived emails that never got deleted from Windows Mail. Everything without a label next to them like "inbox" is very much an archived message.

    That's it! Now when you delete an email its actually gets deleted and go to the "Trash" folder, exactly as it should, exactly as the native reaction from Google Web and Mobile Apps is. Microsoft needs to update there Mail Apps and the delete action should act as delete, not archive, or at least set it up when you hit delete to act as a "move" the message to Trash folder.

    Thanks to rajkumr for the reference above regarding the Google Calendars.
    Also the official Google Guide for iOS, which this tutorial is based to is located here.
    Last edited by nMIK-3; 02-12-2013 at 10:28 AM.
    02-12-2013 09:02 AM
  19. rajkumr's Avatar
    No problem. I had the same issue b4 and found out that option when setting up the calendars.
    02-12-2013 10:11 AM
  20. deuxani's Avatar
    Perfect!! This works... also for Windows 8 :D
    02-12-2013 10:24 AM
  21. drankurn's Avatar
    similar issue with yahoo mail, all the deleted emails are collecting in Deleted items folder, Any solution for that ?
    02-12-2013 10:20 PM
  22. rajkumr's Avatar
    No idea, haven't used yahoo in ages!

    But check the options in your yahoo mail setting on the web.
    02-13-2013 07:52 AM

Similar Threads

  1. BEWARE of the CNN app!!!!!
    By Eric Ovadia in forum Nokia Lumia 920
    Replies: 33
    Last Post: 05-19-2013, 01:44 AM
  2. Quality of the Netflix app on WP8
    By VV75 in forum Windows Phone 8
    Replies: 2
    Last Post: 11-26-2012, 04:15 PM
  3. Replies: 14
    Last Post: 11-18-2012, 01:27 PM
  4. Is there anyway to close out of the Pandora apps
    By jrdatrackstar1223 in forum Applications
    Replies: 12
    Last Post: 12-28-2011, 03:55 AM
  5. Non of the Weather Apps work on my Arrive!
    By thomasanderson in forum HTC Arrive / 7 Pro
    Replies: 10
    Last Post: 08-06-2011, 01:29 AM