1. XBWillem's Avatar
    Does anyone know how I can reconnect my phone to 3G? After my first freeze of the phone, the 3G icon isn't displayed anymore. Turning my connection, connection speed or roaming on/off doesn't effect this in any way. The icon is NEVER showed and I'm NOT connected to 3G anymore, thus can't download anything when not on wi-fi.

    Secondly, after updating apps from the app store, the Nokia logo is displayed with a clear black background and freezes up. Have to soft reset.
    02-16-2013 07:13 AM
  2. WorzelGummage's Avatar
    All this sounds as though you have a faulty SIM card. Or, if it is a brand new SIM it could be that your phone number hasn't been registered properly (if at all) on the SIM. First thing to try then is to put your SIM into a non-Windows phone and test it's 3G functionality. This will ensure the phone number is registered and confirms whether the SIM is faulty. If 3G is working fine on the other phone, then pop it back into the 920 and check if you can now access 3G. Settings > Mobile network > Data connection ON > Highest connection speed 3G > Network selection AUTOMATIC
    02-16-2013 11:48 AM
  3. Jaripi's Avatar
    Did you check "Access point" - it is on the end of the settings list ... just thinking if the connect setting of your operator is se 4G there (active), instead of a proper 3G
    02-16-2013 11:57 AM
  4. XBWillem's Avatar
    All this sounds as though you have a faulty SIM card. Or, if it is a brand new SIM it could be that your phone number hasn't been registered properly (if at all) on the SIM. First thing to try then is to put your SIM into a non-Windows phone and test it's 3G functionality. This will ensure the phone number is registered and confirms whether the SIM is faulty. If 3G is working fine on the other phone, then pop it back into the 920 and check if you can now access 3G. Settings > Mobile network > Data connection ON > Highest connection speed 3G > Network selection AUTOMATIC
    It did work before, not it doesn't.

    Did you check "Access point" - it is on the end of the settings list ... just thinking if the connect setting of your operator is se 4G there (active), instead of a proper 3G
    Wooha dude, thanks! That's exactly the problem. Guess after the soft reset this setting was reset as well. Great!
    02-18-2013 03:55 PM

Similar Threads

  1. phone can't connect to wifi since update
    By sos710m in forum HTC HD 7 / 7s
    Replies: 32
    Last Post: 02-16-2015, 09:30 AM
  2. Replies: 5
    Last Post: 02-27-2014, 09:33 AM
  3. Phone is not connecting to wifi
    By Bartdog in forum Nokia Lumia 900
    Replies: 2
    Last Post: 10-03-2012, 04:39 PM
  4. Nokia Lumia 710 won't connect to 3g
    By Gammans in forum Windows Phone 7
    Replies: 4
    Last Post: 06-16-2012, 08:11 AM
  5. My phone isn't connecting to Zune.
    By Winterfang in forum Windows Phone 7
    Replies: 14
    Last Post: 01-21-2012, 08:17 PM
LINK TO POST COPIED TO CLIPBOARD