1. Elvis7's Avatar
    Ive tried google and still cannot figure out what or why it happened, any insight would be great.

    Ok, so im on my second 920 and things were going well until this morning at about 3am, my 920 just restarted its self and when it came on ,it was in flight mode, no matter what i did ,it would not stop flight mode. The wifi was on and connected but it would say no connection if i tried to access online stuff, and the network remained ,no network. After calling rogers support and spending 2. Hours, we tried a factory reset but at this point, when id go into settings or any apps, the screen would go black and return to the start menu. So we tried the key combo but when turning of the phone, it would just stay stuck on the goodbye screen , tried every option to reset but nothing. So the tech gave me a support number and i am going to exchange it for another red 920 for the last time. Before bed i plugged it in the charger while its on the goodbye screen, this morning at 8am, the phone restated i guess and went off flight mode, it seems to be working fine now but i am not risking it and am within my 15days, i just have to wait for my local store to get red920 in stock


    my first 920 kept locking up and required a soft reset every time, twice a day after day 4. Also, no skype,nokia drive or facebook....



    ALSO NOTE,the manufacturing date on my current 920's box is 4/2013 .. Time travel?i am in canada.
    Last edited by Elvis7; 02-25-2013 at 12:25 PM.
    02-25-2013 12:10 PM
  2. Nakazul's Avatar
    My phone is doing random restarts, but always landing on its feet. Guess I should be happy its only semi bad :-/
    02-25-2013 03:48 PM
  3. Elvis7's Avatar
    Anyone know why my 920 did that?

    and is it hardware or software?
    02-26-2013 02:37 PM

Similar Threads

  1. Having issues with my new 8X...
    By iPwnza in forum Windows Phone 8
    Replies: 4
    Last Post: 11-15-2012, 02:45 PM
  2. Issues with my new Lumia 800
    By z33dev33l in forum Nokia Lumia 800
    Replies: 4
    Last Post: 04-14-2012, 10:34 AM
  3. New Lumia 900 owner issues with Zune Software
    By Ulairi in forum Windows Phone 7
    Replies: 4
    Last Post: 04-09-2012, 03:48 PM
LINK TO POST COPIED TO CLIPBOARD