1. peacefulberry's Avatar
    I am wondering if anyone has ever gotten their factory unlocked or pentaband 920 to work with T mobile's 4G plans? Please share any information you have. Thank you.
    03-05-2013 10:48 AM
  2. Dinky89484's Avatar
    I am wondering if anyone has ever gotten their factory unlocked or pentaband 920 to work with T mobile's 4G plans? Please share any information you have. Thank you.
    Are you talking about LTE 4G or HSPA+ "4G"?
    03-05-2013 12:42 PM
  3. peacefulberry's Avatar
    Any of those is fine
    03-05-2013 01:06 PM
  4. yukit's Avatar
    I have an original developer BUILD phone with T-Mobile USA service.

    The label used to show H, but I needed to flash ATT firmware after bricking it.
    Now it shows 4G, but it is probably HSPA+ since the download speed is about 8mbp.

    I really didn't do anything special after I flashed the firmware & restore the backup from skydrive. The data connection was initially showing E, but after I got wifi connected & restored apps it was 4G. May be I made a phone call to make sure the phone still worked. That was about it.
    03-06-2013 12:33 AM

Similar Threads

  1. Anyone get MMS to work with Nokia 920 on FIDO?
    By kittshelby in forum Nokia Lumia 920
    Replies: 21
    Last Post: 12-13-2014, 11:22 PM
  2. Is anyone able to view maps.google.com using their WP8?
    By aelesiaa in forum Windows Phone 8
    Replies: 9
    Last Post: 12-17-2012, 11:57 AM
  3. Replies: 3
    Last Post: 11-24-2012, 09:13 PM
  4. Website Re-designed To Work With Mobile Devices
    By jeffa00 in forum Windows Phone 7
    Replies: 1
    Last Post: 12-11-2010, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD