1. Elton Jothi's Avatar
    Hello,
    my lumia 920 touch is not responding properly at all, when i have a charger connected, it doesnt respond.
    even with headphones touch doesnt work.
    it works only if i am unwired.
    03-12-2013 06:53 AM
  2. RushilPa's Avatar
    Mine lags like a bullock cart
    03-12-2013 07:14 AM
  3. Vikram Dinesh's Avatar
    Are you using the cable that came with the phone or some other cable. I have this problem only when I use my old Motorola Micro-USB cable. Don't have any problems with the cable that came with the phone.
    03-12-2013 08:04 AM
  4. Elton Jothi's Avatar
    i use the original nokia cable which came with 920
    P.S my frnd used my 920 charger to charge his 710
    Last edited by Elton Jothi; 03-12-2013 at 08:56 AM.
    03-12-2013 08:45 AM
  5. Narse77's Avatar
    Have you tried a soft reset?
    Sent from my Nokia Lumia 920 using Board Express
    03-12-2013 08:56 AM
  6. Elton Jothi's Avatar
    i did soft reset and also hard reset, still the same :(
    03-12-2013 09:20 AM
  7. robertre's Avatar
    I suggest a different charger. I had a similar issue with my Zune HD. A bad charger can cause this. I know you tried your charger with a friend's 720, but did you try your phone with his charger?
    03-12-2013 09:25 AM
  8. Elton Jothi's Avatar
    no i never tried with a 720 charger,i have mine only charged with a original nokia 920 charger.
    03-12-2013 09:44 AM
  9. LazySunday's Avatar
    Probably you are using a bad charger or you got one... Or the plug point you are using is not properly grounded... Capacitive screens are touch based and improper grounding affects the function of touch screen. I had the same problems using any other USB charger with L 920
    03-12-2013 10:36 AM
  10. Elton Jothi's Avatar
    this issue also happens, when i sometimes plug in my nokia head phones
    03-12-2013 10:41 AM
  11. LazySunday's Avatar
    Well, I guess somewhere the phone is shorting... take it to Nokia Care, that would be the best bet....
    03-12-2013 11:01 AM
  12. Nabkawe5's Avatar
    the charger is bad , replace it . (I have intensive experience with this issue back to N8 days.)
    03-12-2013 07:51 PM
  13. ttxzee's Avatar
    the charger probably isn't supplying a constant voltage or current, or it has a bad ground loop. try a different charger.
    03-13-2013 11:45 AM

Similar Threads

  1. Lumia 920 Bricked - not responding at all.
    By jwinch2 in forum Nokia Lumia 920
    Replies: 27
    Last Post: 12-31-2012, 11:29 AM
  2. Lumia 920 text not as crisp as iPhone 4?
    By Masterz1337 in forum Nokia Lumia 920
    Replies: 30
    Last Post: 11-24-2012, 02:04 PM
  3. Lumia 920 will not support AWS
    By brmiller1976 in forum Upcoming & Rumored Phones
    Replies: 23
    Last Post: 10-17-2012, 12:55 PM
  4. Lumia 920 does not support T-Mobiles 1700 AWS band
    By Ploogle in forum Nokia Lumia 920
    Replies: 2
    Last Post: 10-12-2012, 06:40 PM
  5. Replies: 8
    Last Post: 09-15-2012, 09:17 PM
LINK TO POST COPIED TO CLIPBOARD