The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Tan Dao's Avatar
    Using Speedtest, after at&t 1308 firmware update, LTE download and upload speed is very slow. I am getting only about 4+- up and down. I used to get 20+/10+ in South Florida.
    and on Wifi I am only getting 4-10 down, where I get 50+ down using PC.

    Do anyone has similar speed issue?

    I tried at&t LTE1 and LTE2 in the setting make no different.
    Sugarnotch and rdubmu like this.
    03-30-2013 05:57 PM
  2. Sugarnotch's Avatar
    Yes same problem, sometimes works better if I have the WiFi radio turned on, sometimes no different. 4G signal works fine, is fast and reliable. LTE is showing alot of lag no matter what other radios I have on, BT, NFC, WiFi. I jumped on nokias twitter and they had me try to remove/reinsert sim, no help. Soft reset no help either.
    03-30-2013 06:12 PM
  3. unstoppablekem's Avatar
    It is slower now too. But before this update on cellular, it would sometimes only show the bars and no 4G/LTE symbol next to it. Doesn't she this anymore.
    03-30-2013 06:16 PM
  4. gargross's Avatar
    I don't have numbers to show what it was before the update, but ever since applying 1308 my phone's network connections have just been painfully slow. It's taking minutes to render simple mobile websites. Here are my speedtest numbers
    Via Wifi (sitting 8 ft from AP)
    DL:2.49
    UL:0.65
    Ping:79

    Turned off wifi so LTE
    DL:2.89
    UL:1.00
    Ping:313
    Miserable!
    04-03-2013 11:35 PM
  5. twodice1's Avatar
    Same problem. My iphone 4s on AT7T would have full signal and my 920 would have nothing when side by side. Have to reboot to get signal back.
    04-04-2013 11:06 AM
  6. xrs22's Avatar
    I'm hard resetting mine now. I usually screen shoot the before firmware/OS and after so i can see that it had updated. I never though of the speed test app although i did have it. I have the Hardware Test app and you can do testing on all the aspects of the phone. It also keeps a log of the OS/firmware updates by date and how many packages and a detailed list of them, a real must have app i think.
    04-04-2013 11:10 AM
  7. rdubmu's Avatar
    Same issue

    At&t Seattle
    Sent from my Nokia Lumia 920 using Board Express
    04-04-2013 02:41 PM
  8. MS_SURVEYOR's Avatar
    I'm hard resetting mine now. I usually screen shoot the before firmware/OS and after so i can see that it had updated. I never though of the speed test app although i did have it. I have the Hardware Test app and you can do testing on all the aspects of the phone. It also keeps a log of the OS/firmware updates by date and how many packages and a detailed list of them, a real must have app i think.
    Where can I get the Hardware Test app? Tried looking for one months ago with no luck.
    04-04-2013 02:50 PM
  9. xrs22's Avatar
    Where can I get the Hardware Test app? Tried looking for one months ago with no luck.
    not sure when It came out. Did you find it after all?
    Last edited by xrs22; 04-09-2013 at 02:17 PM.
    04-09-2013 02:03 PM
  10. MS_SURVEYOR's Avatar
    not sure when It came out. Did you find it after all?
    No! I can't find it. A link would be nice.

    Thanks!
    04-09-2013 02:39 PM
  11. xrs22's Avatar
    No! I can't find it. A link would be nice.

    Thanks!
    its in the marketplace. It has a circuit board on the app pic.
    04-09-2013 02:50 PM
  12. Jaripi's Avatar
    04-09-2013 02:53 PM
  13. MS_SURVEYOR's Avatar
    Thank You!
    04-09-2013 03:12 PM
  14. xrs22's Avatar
    Its in the marketplace and the app pics is a circuit board.
    04-09-2013 05:14 PM
  15. ktl88's Avatar
    Updated mine yesterday. Realized this morning that I'm also facing slow WiFi speeds here in India after the update.
    I don't use data connection so can't comment on that. But this wifi speed thing sucks.
    04-09-2013 09:21 PM
  16. paulxxwall's Avatar
    Same issues here SW florida
    04-10-2013 04:56 PM
  17. Chand Darling's Avatar
    Same issue with wifi after updating 1308 firware :(
    04-11-2013 12:38 AM
  18. xacious's Avatar
    I have constant connectivity issues ever since the 1308 update, i often have to reboot my phone or put it in airplane mode for a moment and then turn it off to get signals and text messages, in some cases after the reboot or airplane mode I get signal long enough to receive my messages/email/voice mail all at once, then im right back to no signal. Also my phone isnt keeping a charge through the day any more, I guess that's because it spends all damn day searching for a signal.
    04-11-2013 12:51 AM
  19. Osama204's Avatar
    Same WIFI issues in Saudi Arabia after the update, I notice it the most with Youtube clips, it keeps cutting and buffering ALL THE TIME, which wasn't the case before the update, and the same clips works very smoothly on the laptop so it's not my DSL /Wifi router connection issue.
    05-03-2013 02:33 AM

Similar Threads

  1. Replies: 677
    Last Post: 07-05-2013, 08:29 PM
  2. After 1308 firmware update, camera doesn't work properly?
    By aaronchow in forum Nokia Lumia 920
    Replies: 2
    Last Post: 03-30-2013, 04:14 AM
  3. wifi problem after firmware update
    By maphisto_2000 in forum HTC Trophy
    Replies: 1
    Last Post: 12-05-2011, 01:22 PM
  4. Replies: 12
    Last Post: 12-04-2011, 05:42 PM
  5. Crash after firmware update
    By victor#WP in forum Samsung Focus
    Replies: 0
    Last Post: 06-10-2011, 11:17 PM
LINK TO POST COPIED TO CLIPBOARD