1. Daniel Ratcliffe's Avatar
    So, I've just got my Nokia Lumia 920 back from repair (Nokia Care Store). But there's a new problem. Same SIM card, same position, etc. HTC gets full 3G signal. Nokia thinks there's no signal available (the HTC can get online, the Nokia can't). Does anyone know what's happened? Before the repair, my HTC and Nokia would get similar levels of signal, but now there's this huge discrepancy. Anything I can do to fix it? I've done flight mode toggle, reboots, etc.
    04-08-2013 01:51 PM
  2. rockstarzzz's Avatar
    So, I've just got my Nokia Lumia 920 back from repair (Nokia Care Store). But there's a new problem. Same SIM card, same position, etc. HTC gets full 3G signal. Nokia thinks there's no signal available (the HTC can get online, the Nokia can't). Does anyone know what's happened? Before the repair, my HTC and Nokia would get similar levels of signal, but now there's this huge discrepancy. Anything I can do to fix it? I've done flight mode toggle, reboots, etc.
    Welcome to the dark side of firmware update. Could you quickly check and see if you've been given a 1308.x update? ;)
    04-08-2013 02:05 PM
  3. pkcable's Avatar
    You've reseated the SIM card right?
    04-08-2013 02:08 PM
  4. Daniel Ratcliffe's Avatar
    Welcome to the dark side of firmware update. Could you quickly check and see if you've been given a 1308.x update? ;)
    1232.5951.1249.1018

    You've reseated the SIM card right?
    I'm presuming I sometimes get signal with the Nokia that would be a yes? Could you elaborate further please?
    04-08-2013 02:14 PM
  5. unstoppablekem's Avatar
    Did you have new new update before you sent it in?
    04-08-2013 02:16 PM
  6. Daniel Ratcliffe's Avatar
    Did you have new new update before you sent it in?
    I don't think so... using whatever EE have given me.
    04-08-2013 02:18 PM
  7. pkcable's Avatar
    1232.5951.1249.1018



    I'm presuming I sometimes get signal with the Nokia that would be a yes? Could you elaborate further please?

    What I mean is, take the card out of the slot and put it back in. Make sure it's making good contact with the contacts in the slot, make sure it's seated in there correctly.
    04-08-2013 02:19 PM
  8. unstoppablekem's Avatar
    I don't think so... using whatever EE have given me.
    Maybe if it wasn't on the newest update (the one before, I think that was Portico), you wouldn't have this problem. But I don't know.
    04-08-2013 02:20 PM
  9. rockstarzzz's Avatar
    ugh! Just when I thought we had another user who can support 1308 connectivity issue! :P
    04-08-2013 02:23 PM
  10. Daniel Ratcliffe's Avatar
    What I mean is, take the card out of the slot and put it back in. Make sure it's making good contact with the contacts in the slot, make sure it's seated in there correctly.
    I've done that. Nada. It's not showing SIM error though.
    04-08-2013 02:26 PM
  11. palandri's Avatar
    Sounds like the antenna is disconnected.
    04-08-2013 02:28 PM
  12. Daniel Ratcliffe's Avatar
    Sounds like the antenna is disconnected.
    It sometimes gets signal. Could it be a fuzzy connection between the antenna and the main motherboard? Although let's be clear, the Nokia doesn't get signal in places it used to.
    04-08-2013 02:33 PM
  13. unstoppablekem's Avatar
    It sometimes gets signal. Could it be a fuzzy connection between the antenna and the main motherboard? Although let's be clear, the Nokia doesn't get signal in places it used to.
    I know you don't want to hear this, but maybe contact Nokia and have them repair it again? And try and ask them if they can give you a brand new phone, like what AT&T does with warranty/insurance replacements.
    Laura Knotek likes this.
    04-08-2013 11:49 PM
  14. Daniel Ratcliffe's Avatar
    I know you don't want to hear this, but maybe contact Nokia and have them repair it again? And try and ask them if they can give you a brand new phone, like what AT&T does with warranty/insurance replacements.
    Yeah, I think I'm going to do that. Tried the signal again after charging the phone.
    HTC: 3 bars HSDPA
    Nokia: 3 bars GPRS

    Genius me thought a phone reset would fix it... I've only gone and bricked it X_X back to Nokia it goes...
    04-09-2013 06:52 AM
  15. Daniel Ratcliffe's Avatar
    So, managed to unbrick the phone (thank goodness) but my signal woes remain... Looks like Nokia Care Store is the only way to go :(

    Edit: spoke with Phones4U and Nokia. It's gone back for repair.
    Last edited by Paladinleeds; 04-11-2013 at 10:21 AM.
    04-09-2013 06:44 PM

Similar Threads

  1. got phone back after repair how to restore?
    By paul3200 in forum HTC HD 7 / 7s
    Replies: 2
    Last Post: 03-15-2012, 03:16 PM
  2. Confirmed: HTC repair center is garbage.
    By Stryfeno1 in forum Windows Phone 7
    Replies: 15
    Last Post: 02-27-2012, 10:27 AM
  3. Question re: phone repairs
    By mkr10001 in forum Windows Phone 7
    Replies: 3
    Last Post: 02-20-2012, 02:31 PM
  4. cell phone repair
    By sos710m in forum The "Off Topic" Lounge
    Replies: 1
    Last Post: 12-09-2011, 06:57 AM
  5. Dell Venue Pro repair
    By RichardAZ in forum Dell Venue Pro
    Replies: 3
    Last Post: 10-09-2011, 10:31 PM
LINK TO POST COPIED TO CLIPBOARD