1. Brian Reynolds's Avatar
    I have tried two Nokia Lumia 920 phones that will not connect to my Motorola Netopia DSL router. All other devices (IPAD, IPHONE, etc.) connects but the Lumia 920 will not. It picks up my WIFI but when I put in the password it says it is the wrong password. I know it is the correct password because I have disconnected the other devices and then reconnected them using the same password and it works. Why am I having this problem with the 920?
    05-18-2013 03:59 PM
  2. palandri's Avatar
    Is DHCP is enabled? Also set the channels to auto.
    05-18-2013 04:51 PM
  3. Ray Adams's Avatar
    What are the settings on router? As I know WP has no support for WPA2 Enterprise (Every smartphone on the world have it, but now Windows Phones! )
    05-18-2013 05:07 PM
  4. Brian Reynolds's Avatar
    It is setup for WEP not WPA. The dhcp is enabled also.
    Last edited by Brian Reynolds; 05-18-2013 at 09:16 PM.
    05-18-2013 09:04 PM
  5. Ray Adams's Avatar
    All I can suggest, play more with WiFi settings on router. Change it from wep to wpa/wpa2.
    05-19-2013 05:30 AM
  6. Joe Fife's Avatar
    My phone is also having this problem. 2 months ago I could connect to my WPA protected Motorola router. However, now I cannot. I have reset the router multiple times to no avail. I still get the message incorrect password although it is correct. I have even tried removing all security from my wireless network (going open). Even then my phone could see the network, but failed to connect.

    My phone can connect just fine to the wifi at work and at various other places, but is failing hard at home. Any thoughts?
    06-06-2013 11:32 AM
  7. xratola's Avatar
    Have you tried doing a hard reset perhaps?
    06-06-2013 12:14 PM
  8. Ian Too's Avatar
    Are you using MAC address filtering and have forgotten to add the 920 to the white list?
    WP8fan likes this.
    06-07-2013 12:53 PM
  9. scholesz's Avatar
    do this simple trick, delete evry wifi connected devices from the router make the router look as if its new and as never been connected. on ur lumia, make sure any wifi connection with the router is deleted, turn off ur lumia and switch on then try to connect. If u follows this as instructed its going to work
    WP8fan likes this.
    06-07-2013 01:52 PM

Similar Threads

  1. Nokia Lumia 710 won't connect to 3g
    By Gammans in forum Windows Phone 7
    Replies: 4
    Last Post: 06-16-2012, 08:11 AM
  2. HTC Arrive will not connect to wifi
    By Starlifter in forum Windows Phone 7
    Replies: 20
    Last Post: 11-25-2011, 05:41 AM
  3. Replies: 21
    Last Post: 05-12-2011, 02:49 PM
  4. Focus won't connect to PC
    By musicman1091 in forum Samsung Focus
    Replies: 1
    Last Post: 04-22-2011, 05:45 AM
  5. Unable to connect to Wifi?
    By jalb in forum Windows Phone 7
    Replies: 16
    Last Post: 04-17-2011, 06:36 PM
LINK TO POST COPIED TO CLIPBOARD