1. Nemanja Pavlovic's Avatar
    Hello,

    After more than a month of using my 920 with no particular problems, I recently started having some issues with certain built in "apps".
    Sometimes, opening Messaging or Settings would blackscreen for a few seconds and then jump back to the start screen. Other apps would work, but not as smooth as normally, also the gyroscope would bug and not rotate the screen. Up to today, a soft reset would fix the issue, sometimes even leaving it on idle for a few minutes would make it work again.

    However, after the bug re-occurring today, the phone seems to be stuck on the Nokia logo after a reset, for about an hour now.

    Did anyone experience something similar? After reading the sticky above and searching the forum a bit, couldn't find anything too helpful. Especially since i would like to avoid the factory reset right now, since i have some important data on the phone i can't afford to lose.

    What are the chances of the phone booting up normally now? I should also note that a similar thing happened last night, but didnt last more than 10-15mins.

    Thanks.
    05-28-2013 08:40 AM
  2. chezm's Avatar
    i have had this in the past.

    Plug it into the charger

    Soft Reboot while stuck in Gears (Volume down + power for 15 seconds)

    Let it sit for 20-25 mins

    If it hasn't booted, try it a few more times. The last time this happened to me it took 4 soft resets, a total of 2 hours.
    05-28-2013 09:16 AM
  3. Nemanja Pavlovic's Avatar
    After about 10 hours on the Nokia logo, the phone turned itself off as the battery seems to be emptied. Turned it back on, and it booted without a problem lol

    Making a backup of my stuff now, gonna see tomorrow if i'm gonna try to flash it myself or ask for a new one (since this one has the screen flickering issue sometimes)

    Thanks!

    Edit:
    By the way, does anyone have an idea what might be causing the issue i described in the first post? Is it possible that some app or game is causing the bugs?
    Last edited by Nemanja Pavlovic; 05-28-2013 at 07:06 PM.
    05-28-2013 06:21 PM

Similar Threads

  1. 920 "Bricked" after reset
    By gregatkins68 in forum Nokia Lumia 920
    Replies: 0
    Last Post: 02-09-2013, 10:09 AM
  2. 920 Died after soft reset. Any ideas?
    By liamjanin in forum Nokia Lumia 920
    Replies: 1
    Last Post: 01-11-2013, 03:50 AM
  3. soft reset bricks the phone? L920
    By alikokce in forum Nokia Lumia 920
    Replies: 6
    Last Post: 12-19-2012, 06:42 AM
  4. Lost Data Connection after soft reset
    By gudnuf4u in forum Nokia Lumia 920
    Replies: 3
    Last Post: 11-28-2012, 10:29 AM
  5. 920 bricked after hard reset
    By Hunter Skipworth in forum Nokia Lumia 920
    Replies: 6
    Last Post: 11-14-2012, 10:51 PM
LINK TO POST COPIED TO CLIPBOARD