Live

Black Friday deal team is live right now!

Check out the hottest Black Friday Deals!

Expand Minimize
  1. pmich's Avatar
    In the last week or so, my phone has experienced some really weird behavior. It seems to have a mind of its own. When i open an app, it freezes for a bit and then starts switching apps and goes into the calender and email changing panes all on its own. It continues jittering around for a few minutes on different screens. As soon as i turn off the screen and back on, it goes back to normal for a while before it happens again. It's like the phone's possessed. I've done some research and wondering if it has anything to do with wireless charging? Anyone else have a similar experience?
    07-11-2013 09:44 AM
  2. stmav's Avatar
    I've been charging mine by wireless since I got and and have had nothing like this happen. Does this happen when you open any app or a particular app? Also when it's going crazy, do you notice the back of the phone getting warm?
    07-11-2013 09:49 AM
  3. pmich's Avatar
    It's not related to any specific app. After i use it for a while, it just starts going bezerk. It doesn't normally get warm as far as i know but i'll have to check that out.
    07-11-2013 10:01 AM
  4. Darren Walsh's Avatar
    Mine sometimes freezes when plugged into a wall charger when I press the back button, locking/unlocking the screen sorts it, but it's defo charger related, what firmware are you running? Mine is still 1249
    07-11-2013 10:15 AM
  5. metalchick719's Avatar
    Couldn't be wireless charging. I haven't charged my 920 wirelessly that much, but I've never experienced this issue at all. Are you sure it's not some app that's running in the background, like a calendar app? It sounds like your phone is haunted! lol
    07-11-2013 10:28 AM
  6. pmich's Avatar
    i'm using firmware 1314.

    Dont think it's apps running in the background. I usually close everything. The only tasks that run are Battery monitor and my stocks portfolio. Wonder if it's Lockslider+...
    07-11-2013 11:12 AM
  7. Cheyenne Fletcher's Avatar
    I don't charge mine wirelessly. But lately it has had a problem with this as well as when I try texting it starts typing gibberish on its own. I thought maybe it was the screen dirty, but even after cleaning the screen it continues to act up. I try turning the phone off and resetting, but that only works for a little while.
    07-14-2013 10:53 AM
  8. Dadstar0410's Avatar
    I don't charge mine wirelessly. But lately it has had a problem with this as well as when I try texting it starts typing gibberish on its own. I thought maybe it was the screen dirty, but even after cleaning the screen it continues to act up. I try turning the phone off and resetting, but that only works for a little while.
    I have this problem with my 8X where starting a new message causes the phone to randomly type stuff in. Then it'll switch to Bing, and everytime I back out it goes back in a types stuff.
    07-14-2013 11:03 AM
  9. pmich's Avatar
    Here's a quick video i took of the phone acting up. It's getting even worse lately as it happens 70% of the time i have the phone on.

    http://sdrv.ms/13vavcw
    07-17-2013 08:45 AM
  10. Aku MC's Avatar
    yeah mine too... i dont have nokia;s phone but i have same lag :/ i have been searching for a answer for lag but nothing found yet...
    09-22-2013 02:22 PM
  11. Aku MC's Avatar
    its like someone would control your phone by other phone or computer.. :/
    09-22-2013 02:25 PM
  12. Lakshmi Thangadurai's Avatar
    has any1 sloved dis problem.. am facing the same in my lumia 720 now ... plzz suggest some remedy.... am not using wireless charging either.....
    Last edited by Lakshmi Thangadurai; 04-10-2014 at 04:38 AM.
    04-07-2014 09:36 PM
  13. seewhyy's Avatar
    Changing touch sensitivity in my Nokia 820 to 'normal' seem to have fix it for me so far.

    Under Settings > touch
    04-28-2014 09:54 PM
  14. paras chugh's Avatar
    yeah i have the same issue and went to nokia care for it (lumia 720).....they told me its because water or moisture went into my phone so they have to change the lcd and digitizer but then i went to a local mobile repair shop and they saidonly digitizer replacement is required so i am going to get that done after a while.
    04-28-2014 10:08 PM
  15. arkhale's Avatar
    This happens occasionally with my Lumia 920, especially when I connect my phone to my PC. I really don't know what's causing it. A quick remedy is to lock or turn off display when this happens, then unlock the phone and it's back to normal. It's annoying but does not really affect the way I use my phone, just a small quirk IMO. If it's what they say is true that a digitizer replacement is necessary to fix it I think I'll hold off for now.
    04-29-2014 06:24 AM
  16. irtiza_fayaz's Avatar
    Hmmm... It's probably Skynet, but I could be wrong.
    04-29-2014 06:57 AM
  17. moonshine63's Avatar
    Sounds to me like a hard reset is in order it should fix everything
    04-29-2014 07:05 AM
  18. Sujit Sahasrabudhe's Avatar
    hi, me for the same too. Mine is nokia lumia 720. have you fixed it? pls help me how to fix it. thanks

    sujit
    07-15-2014 05:20 PM
  19. Sujit Sahasrabudhe's Avatar
    mine too. did you solve it? pls help me how to fix. thanks. i use lumia 720
    07-15-2014 05:22 PM
  20. BboyFlash's Avatar
    Looks like it could be a bad digitizer; try ordering a new one and installing it and see if that helps. Same thing happened with my Lumia. Swapped the part out and now it works like a charm.


    ...be sure to order OEM though...
    07-16-2014 01:54 AM

Similar Threads

  1. I dont know about you, but im pronouncing it as Ten Twenty
    By Jason De Castro in forum Nokia Lumia 1020
    Replies: 10
    Last Post: 07-11-2013, 07:23 PM
  2. Blue SoD - sort of...
    By Niclas Aarestrup in forum Nokia Lumia 520
    Replies: 2
    Last Post: 07-11-2013, 05:37 PM
  3. "Does it come in black?"
    By ShaunKL in forum Nokia Lumia 925
    Replies: 8
    Last Post: 07-11-2013, 10:59 AM
  4. Replies: 5
    Last Post: 07-11-2013, 07:29 AM
  5. Replies: 4
    Last Post: 07-10-2013, 09:55 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.