1. Michael Kerametlian's Avatar
    Good afternoon folks,

    I've had my Lumia 920 for months and have made due lacking some important aspects of a phone such as:

    1) Not being able to RECEIVE MMS texts, but can send.
    2) Not being able to send group texts.
    3) Internet sharing.

    I've unlocked the phone and am currently using it on Videotron's network in Montreal.
    I've added the necessary Internet and mms APN settings, but I still can't get those three to work whatsoever...


    Can anybody help me?
    -Mike
    07-21-2013 06:26 PM
  2. pankaj981's Avatar
    First off all, all 3 issues mentioned above works great on my 920. To fix issues i would suggest you to download Nokia Access Point from this link:
    http://www.windowsphone.com/s?appid=...3-25c10463942d

    Check if it actually shows your carrier in the list, if it does not then create one manually.
    Set the internet APN as: media.videotron

    Set the MMS APN as: media.videotron
    MMSC: http://media.videotron.com
    MMS Proxy : 10.208.89.17
    MMS Port : 8080

    Save the APN, select it, send MMS to yourself to test MMS
    07-21-2013 06:41 PM
  3. Michael Kerametlian's Avatar
    I have access point and it does show Videotron and everything looks perfect on paper but they don't work.

    Could you post screenshots so I can compare? I really would love to get these working.

    Thanks in advance,
    -Mike
    07-22-2013 12:07 PM
  4. Michael Kerametlian's Avatar
    These are what I have
    Edit: first one is internet APN, second being MMS


    wp_ss_20130722_0001.png
    wp_ss_20130722_0002.png
    07-22-2013 12:12 PM
  5. pankaj981's Avatar
    Your settings look correct, not sure why its not working though. Are you able to browse data?
    07-22-2013 01:49 PM
  6. Keegan Pinto's Avatar
    Hey man, I'm using an unlocked 920 on Bell right now. The LTE is disabled because bell doesn't support the LTE bands that the 920 does. Its well within the realm of possibility that Videotron's network doesn't support the phone in that way? I'm not entirely sure.

    For the MMS part, I had the same issue on my old 8X. Delete your threads and restart the phone. When you have a lot of texts, the phone stops receiving pictures because they take up too much space and it tries to save all of your messages.
    07-22-2013 02:50 PM
  7. pankaj981's Avatar
    Yeah try turning off LTE, i currently have issues with MMS when turning on LTE on my unlocked Rogers 920 on T-Mobile US
    07-22-2013 05:25 PM
  8. Michael Kerametlian's Avatar
    That's just it, I have LTE turned off and have it set to 3G instead in my cellular settings...
    I tried deleting all my threads because they had piled up over the past 6 months I've had it, restarted the phone and didn't resolve it.

    I mean...the only thing I can think of is making a new listing Under access point? But I don't see how that would help.
    Should I maybe try deleting my internet and mms APN lists Under cellular and just stick with access point? I'm pretty sure I've done that in the past also.


    This is just upsetting in all honesty and I'm really considering picking up the 1020 if Google doesn't announce some awesome phone on Wednesday, but it's upsetting going through all this garbage.
    Although, Vidotron did sign a contract for 20 years to share Rogers' LTE connection as of (I BELIEVE) Jan 1st 2014? That could be a changer, but I don't see why it would have anything to do with MMS texts >_>



    Anybody else have any suggestions?
    Nokia support couldn't figure it out and those French **itheads at Vidotron are clueless and wouldn't help me probably because I'm English-speaking...
    -Mike
    07-22-2013 07:01 PM
  9. backfat1's Avatar
    Not sure if this will help you out, but recently went through the same problem with an unlocked HTC 8x on Net10 (using AT&T's network) in the US. I had the same issues that you did, couldn't figure out how to get it working even with the correct APN settings loaded in. However, I installed the app Handcent and the native messaging started working. Once again, not sure what exactly this did but now I'm good with data, MMS and SMS.
    07-22-2013 07:11 PM
  10. Michael Kerametlian's Avatar
    Doesn`t look like that helped but thanks for the suggestion.
    I registered to Handcent also just to be certain, but how exactly did it work? Did you add people to your friends list or did it just start working right after the install?
    07-22-2013 08:21 PM
  11. backfat1's Avatar
    All I did was download the app, register for an account and link my number to the account itself (I think they call it number binding). I don't even use the Handcent app to text, send MMS - right after I installed the app I could get MMS messages in the native messaging component since previously I had only been able to send them.
    07-23-2013 11:45 AM
  12. hoovermac's Avatar
    Hi Michael - I have an unlocked Lumia 920 and to get the mms working, I had to delete the manual settings I put into the internet sharing app before I installed the access point app. Deleted the settings, rebooted and ran access point and all was fine after that. Give that a try and see if it works. It was suggested in another thread that without the full reboot, the access point app may not configure things correctly.

    Hope it helps.
    07-23-2013 12:44 PM
  13. Michael Kerametlian's Avatar
    Could you elaborate a bit on what you mean by delete the manual settings in the internet sharing app?
    I don't quite understand XD
    07-23-2013 06:14 PM
  14. hoovermac's Avatar
    Hi Michael - check out post number 50 in this thread. This is what I did and it worked fine right after that, and is still working now.

    Good luck!

    http://forums.windowscentral.com/nok...0/211644-2.htm
    07-23-2013 07:07 PM
  15. Michael Kerametlian's Avatar
    Hi Michael - check out post number 50 in this thread. This is what I did and it worked fine right after that, and is still working now.

    Good luck!

    http://forums.windowscentral.com/nok...0/211644-2.htm
    But is this for internet sharing or MMS?
    I got my internet sharing to work finally.
    07-23-2013 08:42 PM
  16. hoovermac's Avatar
    Yes - the access point app should give you the correct settings, as long as you select the right carrier. If you still find the MMS isn't working, you can input its settings manually in the cellular settings app.
    Last edited by hoovermac; 07-24-2013 at 02:11 PM.
    07-24-2013 01:53 PM
  17. Michael Kerametlian's Avatar
    Definitely not working no matter what I do...

    Anybody whatsoever running the 920 on Videotron's network?
    07-26-2013 01:57 AM
  18. Michael Kerametlian's Avatar
    Still nothing 2 months later >_>
    If Rogers wasn't so damned expensive I'd switch in a hearbeat.
    09-25-2013 10:20 PM
  19. khunhorm's Avatar
    Sorry but have you considered factory reset the phone? One more question, you said you have your phone unlocked, does that mean you bought your phone from different carrier? Are you sure that your 920 model support your carrier frequency band?
    09-25-2013 10:48 PM
  20. Michael Kerametlian's Avatar
    Factory reset was the first thing I tried.
    The phone was originally Rogers and was unlocked. The 920 is pentaband, it supports Videotron's frequency.
    09-26-2013 12:53 AM
  21. Calydus's Avatar
    I seem to be in the same situation as you, I can send mms but can't receive them...
    Last edited by Calydus; 02-03-2014 at 07:55 AM.
    01-31-2014 12:19 PM
  22. Calydus's Avatar
    was your phone rogers branded and then unlocked.... based on a few things I've read, the phones branded by rogers and then unlocked have often mms issues.
    I am in the same situation, I can't receive mms...
    02-01-2014 01:31 PM
  23. MrWhiteman's Avatar
    I seem tone in the same situation as you, I can send mms but can't receive them...
    Old thread dude.
    02-03-2014 04:29 AM
  24. Calydus's Avatar
    wow Mr Whiteman, that was VERY helpful! Thanks for the help!
    02-03-2014 07:54 AM

Similar Threads

  1. Nokia Lumia 928 screen cracked! Looking for any advice...
    By Christian Nunes in forum Nokia Lumia 928
    Replies: 30
    Last Post: 10-26-2015, 05:21 PM
  2. Lumia 920 discharging while plugged in
    By GeekTieGuy in forum Nokia Lumia 920
    Replies: 8
    Last Post: 10-18-2014, 12:47 AM
  3. Sale 920, where to post?
    By AbsoluteZerow in forum Site Feedback & Help
    Replies: 6
    Last Post: 08-04-2013, 11:02 PM
  4. Where can i buy a FACTORY UNLOCKED T889M?
    By mrwinkle13 in forum Samsung ATIV S
    Replies: 3
    Last Post: 07-23-2013, 03:23 AM
  5. DragManArds Nokia 920 problems starting
    By Martin Spilovsky in forum Games
    Replies: 2
    Last Post: 07-22-2013, 02:51 AM
LINK TO POST COPIED TO CLIPBOARD