1. abhishek8605's Avatar
    So I just moved to Singapore, signed up for an LTE SIM with Singtel. They said it will take a maximum of 6 hours for it to be activated, it is now 18 hours and still no LTE. I have an unlocked Lumia 920 bought from Thailand, and flashed it a while back with the Singapore ROM.

    1. There is no 4G option under highest speed rate in the mobile network settings.
    2. ##3282# doesn't work, it gives a random message saying something happened and we couldn't complete the action.
    3. I have taken the SIM out and put it back in, restarted my phone, even did the soft battery pull volume down + lock button reset.
    4. Under access point I am connected to Singtel, and when I view the settings it shows the network type as IPv4.

    Can anyone help? I am sure these phones have 4G capability it's just about finding out how to get it to work. I have read other topics about this and none of them seemed to help.
    07-25-2013 09:49 PM
  2. palandri's Avatar
    Where did you get the Singapore ROM?
    07-26-2013 01:17 AM
  3. abhishek8605's Avatar
    Nokia Care Suite.
    07-26-2013 02:28 AM
  4. abhishek8605's Avatar
    Help?
    07-29-2013 11:21 PM
  5. pankaj981's Avatar
    Flash to GB unbranded ROM, Singtel LTE uses band 3 and 7 which the GB ROM supports as well so it should work unless something is really wrong with your phone h/w.
    07-29-2013 11:33 PM
  6. abhishek8605's Avatar
    Flash to GB unbranded ROM, Singtel LTE uses band 3 and 7 which the GB ROM supports as well so it should work unless something is really wrong with your phone h/w.
    Well I actually flashed to tthe unbranded Singapore ROM so why isn't it working?
    07-30-2013 12:00 AM
  7. pankaj981's Avatar
    Do you have access point installed? If yes then you might want to check the apn settings
    07-30-2013 12:40 AM
  8. abhishek8605's Avatar
    Do you have access point installed? If yes then you might want to check the apn settings
    Yes access point is installed it just says SingTel and if I tap and hold and click view there's something with IPv4 in it and PAP.
    07-30-2013 02:43 AM
  9. pankaj981's Avatar
    Create a new setting manually and try to use that
    07-30-2013 09:23 AM
  10. tomdjp's Avatar
    Just do ##3282 then "call", without the final "#". (This is different for WP8 compared with WP7).
    Then go into settings (three dots) of the field test app and make sure automatic is set. It may (I'm not sure) help to look at the LTE related tests in this app. You should then be able to go back to home screen, and after a short time (if not already) LTE should start working.

    It'd probably be better if you had a firmware where you can actually select 4G in the main settings, but hopefully this will work.
    07-30-2013 09:32 AM
  11. Mark Everingham's Avatar
    Not sure if you still have access to nokia care suite but try downloading the Singtel ROM or the GB EE UK ROM.
    I say this because I know that unbranded lumia 920 in GB don't/didn't have the 4G option for some reason, might change with next update, this could be the same for Singapore providers.
    07-30-2013 09:36 AM
  12. pankaj981's Avatar
    Just do ##3282 then "call", without the final "#". (This is different for WP8 compared with WP7).
    Then go into settings (three dots) of the field test app and make sure automatic is set. It may (I'm not sure) help to look at the LTE related tests in this app. You should then be able to go back to home screen, and after a short time (if not already) LTE should start working.

    It'd probably be better if you had a firmware where you can actually select 4G in the main settings, but hopefully this will work.
    He mentioned that in his earlier post that he has already tried it
    07-30-2013 10:13 AM
  13. pankaj981's Avatar
    ..or you can either try the Rogers CA ROM or the Euro Developer ROM which is carrier unbranded. I use the Rogers version on TMOUS and it lets me use LTE
    07-30-2013 10:15 AM
  14. abhishek8605's Avatar
    Just do ##3282 then "call", without the final "#". (This is different for WP8 compared with WP7).
    Then go into settings (three dots) of the field test app and make sure automatic is set. It may (I'm not sure) help to look at the LTE related tests in this app. You should then be able to go back to home screen, and after a short time (if not already) LTE should start working.

    It'd probably be better if you had a firmware where you can actually select 4G in the main settings, but hopefully this will work.
    ##3283 worked, but I was under the impression that we had to use ##3282#. Anyway, once I get to the field test app, it shows a bunch of connections, when I tap on any of the LTE related options all the results are either "NA" or "0." I did go into settings and it was already set on automatic. So couldn't really do much there. What exactly am I supposed to do?
    07-30-2013 11:09 PM
  15. abhishek8605's Avatar
    Not sure if you still have access to nokia care suite but try downloading the Singtel ROM or the GB EE UK ROM.
    I say this because I know that unbranded lumia 920 in GB don't/didn't have the 4G option for some reason, might change with next update, this could be the same for Singapore providers.
    But if I download the SingTel ROM, that's branded, wouldn't that brick my phone? I thought that any branded ROM would brick an unbranded/unlocked phone.
    07-30-2013 11:11 PM
  16. abhishek8605's Avatar
    One more question, how do I find the product code for the SingTel ROM? Right now I'm using the product support tool from Nokia to download the firmware.
    07-30-2013 11:24 PM
  17. pankaj981's Avatar
    But if I download the SingTel ROM, that's branded, wouldn't that brick my phone? I thought that any branded ROM would brick an unbranded/unlocked phone.
    no it doesn't brick your phone if flashed correctly
    07-31-2013 12:17 AM
  18. abhishek8605's Avatar
    After doing some more research just found out that the latest unlocked Thailand ROM (the updated version of the ROM that shipped with my phone) has an option for 4G in the mobile network settings. What the hell! I might as well have stuck to it instead of switching to the SG ROM. Anyway, downloading the Thailand ROM now and will let you guys know if anything changes.
    07-31-2013 12:26 AM
  19. abhishek8605's Avatar
    Okay, 4G is working, I guess the unbranded SG ROM has 4G disabled which is very weird.
    07-31-2013 01:08 AM
  20. tai4de2's Avatar
    I have a Thai 920 and when I put an old TrueMove SIM in there, I see 4G as an option for the max connection speed.

    In Thailand, TrueMove actually advertises the 920 in conjunction with their new LTE service.
    08-13-2013 02:52 AM
  21. kurtd's Avatar
    Anybody know how to compare specs of a particular phone to make sure it has the required frequencies for a certain carrier? I have a T-Mobile US branded lumia 925 and need to make sure 3g/4g/LTE will work on either TrueMove or AIS in Thailand. I find sites like phonearena useless since they just list all the possible frequencies for a device instead of the frequencies each branded phone has.
    08-12-2014 10:08 AM

Similar Threads

  1. Lumia 1020 launching in India on August 19
    By Amran Nagal in forum Nokia Lumia 1020
    Replies: 3
    Last Post: 10-08-2013, 07:51 AM
  2. 1020 AT&T Pre-Order, got it with Sim Card error
    By ehuna in forum Nokia Lumia 1020
    Replies: 6
    Last Post: 10-02-2013, 06:08 PM
  3. Any way to backup SMS / text messages from HTC Titan?
    By xscess in forum Windows Phone 7
    Replies: 11
    Last Post: 08-06-2013, 10:10 AM
  4. Unlocked T-Mobile 925 in Black?
    By metalchick719 in forum Nokia Lumia 925
    Replies: 16
    Last Post: 07-27-2013, 07:47 AM
  5. No Cobalt Theme Color?
    By HM02 in forum Nokia Lumia 1020
    Replies: 15
    Last Post: 07-27-2013, 01:17 AM
LINK TO POST COPIED TO CLIPBOARD