1. boshkop's Avatar
    I love CIV and I had no problem playing it on Trial, but after I bought the game I can't play for more than 10 minutes. My phone freezes and I have to soft reset it. :/

    Is it only me (Lumia 920 AT&T) or this version of CIV (1.1.0.0) is buggy?
    07-28-2013 03:57 AM
  2. WanderingTraveler's Avatar
    Okay, try reinstalling the game. Also, the game is a direct port from iOS, so there's bound to be quite a few bugs.
    07-28-2013 04:15 AM
  3. Snowy Nokia's Avatar
    Hmm, never had problems on my 810, except once in a while it would exit so I do recommend occasional saves
    07-28-2013 05:18 AM
  4. boshkop's Avatar
    Reinstalling the game fixed the problem. Thanks! :)
    07-29-2013 12:11 PM

Similar Threads

  1. no wifi direct on windows phone 8
    By Neeraj Mathur in forum Windows Phone 8
    Replies: 7
    Last Post: 02-23-2014, 06:06 AM
  2. My Ativ gps takes a long time to locate me.
    By dw852 in forum Samsung ATIV S
    Replies: 6
    Last Post: 07-31-2013, 09:34 AM
  3. my thoughts about WP8 as an OS and the Lumia 520 as a phone
    By faceless_el in forum Nokia Lumia 520
    Replies: 10
    Last Post: 07-30-2013, 08:12 PM
  4. problems with posting with Windows Phone 8's internet explorer
    By qudahamohammad in forum Site Feedback & Help
    Replies: 6
    Last Post: 07-28-2013, 09:53 PM
  5. windows phone store ratings needs to be more like ebay
    By Fred P in forum Windows Phone 8
    Replies: 1
    Last Post: 07-27-2013, 04:56 PM
LINK TO POST COPIED TO CLIPBOARD