1. scalpetti's Avatar
    Hi,

    My 920 is having problems with the signal. After the Amber update i barely get 2 lines, and from time to time there is no signal at all. I have heard about this problem with other software versions (1308 i guess), but i thought that it will get fixed. Before the Amber update the phone was working just fine.

    Is anyone else out there that encountered this problem?
    09-26-2013 05:05 AM
  2. rianash's Avatar
    Aye. Similar problem here but with 620. After amber update, my phone lost signal easily and oftenly when set to 3G (calls always dropped, no internet connection though showing E). Although, signal was quite constant when set to 2G (no dropped calls, Edge internet connection running).

    It's not carrier network related, as when I put the SIM card in wife's 720 (unupdated with amber), 3G signal was fine including internet connection (showing H, H+), no dropped calls.

    But then, after 3-4 days 3G signal is back. I did nothing but cursing and several soft restart.

    BUT, BUT, BUT, now it gives off a lot of heat when in 3G, and drains the battery very fast. It has been 1 day like that. But this afternoon, the phone seems to be cooler (to be confirmed for the following days).

    Hard reset is recommended elsewhere. But I'm too lazy to reinstall apps, maps, etc. So, I will continue cursing and soft resetting, until I'm bored.

    Well, that's not helping you, eh? Well, at least you know you're not alone..

    If anyone else having similar situation, please share here. With or without solution. At least we know if the problem is limited to a small bunch of people, or in a larger scale.

    Amber, amber.. you take my slumber..

    Update: Now, the 3G heat and sick-fast battery drain problems seems to be gone. That is after I let the battery phone discharged until it is off on itself (0%). Then charged back until full (100%). Not bad. Although, not so smart update method (amber)..
    Last edited by rianash; 09-26-2013 at 10:32 PM. Reason: update
    scalpetti likes this.
    09-26-2013 06:27 AM
  3. scalpetti's Avatar
    On 3G and 4G the signal comes and goes. On 2G it won't even work.
    I know that it's not carrier related as i transferred the sim into my old lumia 800 and works perfect.

    Well, I did both soft and hard reset and nothing changed. With the 920 still in the warranty period i took it today to the retailer from which i bought it. It will go into service, and i'm waiting an answer from them.
    09-26-2013 07:24 AM
  4. MrWhiteman's Avatar
    I had the same problem and was convinced that update 1308 caused it, but after sending it away 3 times it turned out that the aerial was faulty. I could get a full signal in town/city centres but anywhere that didn't have close masts (outside of town) I had no signal at all. But the 3G signal would pop up every couple of days again and then go again.
    09-26-2013 07:47 AM
  5. scalpetti's Avatar
    I had the same problem and was convinced that update 1308 caused it, but after sending it away 3 times it turned out that the aerial was faulty. I could get a full signal in town/city centres but anywhere that didn't have close masts (outside of town) I had no signal at all. But the 3G signal would pop up every couple of days again and then go again.
    I could be next to a carrier antenna and still won't get more than 3 bars on the signal. Since the phone was working just fine before the update, i suspect that the update did screw something up.
    09-26-2013 08:13 AM
  6. Xethluna's Avatar
    The same thing is happening on my Lumia 720 after the Amber Update. H+ signal comes and goes intermittently. I did soft reset and hard reset but none of them worked. If i'm in my office on the 7th floor, the H+ signal appears for a few minutes then goes away after 20 minutes or so.

    Please post if there's a fix. I'm so close to throwing my phone out the window. XD
    10-08-2013 09:15 AM

Similar Threads

  1. nokia lumia 520 amber update problem
    By aashishzr in forum Windows Phone 8
    Replies: 33
    Last Post: 01-17-2014, 04:23 AM
  2. 520 - Amber Update WALLPAPERS Request
    By Adnan Javed in forum Nokia Lumia 520
    Replies: 5
    Last Post: 12-28-2013, 03:16 AM
  3. GDR2+AMBER update issue.(Indian users)
    By Nikhilteja in forum Nokia Lumia 520
    Replies: 24
    Last Post: 10-17-2013, 12:45 AM
  4. Whatsapp notification icon for Lumia 920
    By ghousuddin a in forum Nokia Lumia 920
    Replies: 5
    Last Post: 09-28-2013, 01:22 AM
  5. Nokia Amber
    By Brian Galeas in forum Windows Phone 8
    Replies: 1
    Last Post: 09-25-2013, 11:01 PM
LINK TO POST COPIED TO CLIPBOARD