1. Bombfetish's Avatar
    Hello all,

    Hoping you can help, as I found similar problems researching, but no exact comparisons.

    I've been having an issue recently, where my screen rotation will stop working. The only thing that has made it work is a soft reset. It will work for about 2 mins and then it stops working again.

    When the screen rotation stops, it makes the accelerometer stop and the gyros too, I can verify these sensors stop working in my Nokia Diagnostics Toolset app. Also, oddly, the games hub stops responding when this happens, resulting in a 5 second "loading" screen, followed by a crash back to the dashboard.

    I finally broke down, did a hard reset, bricked it, and fixed it, and tried to see if the problem was still there after a hard reset. Screen worked for minutes, then failed again without installing any apps. What I DID do is connect to WiFi, and after reading some posts, it appears that simply being connected to WiFi is making many people's phones freeze. Could this be what's happening to my phone? I'm going to try to run it for a while without WiFi but my phone is currently restoring apps from the hard reset.

    Does anyone know why this is happening or what can fix it? Seems like software since the sensors will consistently work for a while, then shut off. Any thoughts?

    Thanks in advance,
    Derek
    11-23-2013 12:44 PM
  2. ttsoldier's Avatar
    Have you updated your nokia apps? display + touch, extras +info etc.
    11-23-2013 02:03 PM
  3. Bombfetish's Avatar
    How exactly does one go about doing that? I checked under "phone update" and the OS is up to date. Also there's no more apps to download from the store. I appreciate your help. Noticed today, I have the following off and it's still having the same symptoms: WiFi, Bluetooth, Tap to send (NFC).

    Again, it just recently started happening (after my phone was repaired BTW. Broken screen, but I used it for weeks broken and the sensors all worked fine so it's not damaged.). It doesn't make much sense for it to be hardware, as a soft reset fixes it for minutes (sometimes 2 sometimes 10-20). But then it doesn't make much sense that it's a software thing if a hard reset back to factory settings didn't fix it.

    Thanks for your help, and keep the ideas coming.
    11-23-2013 07:52 PM
  4. ttsoldier's Avatar
    Download the app called sysapp pusher and update them.
    11-25-2013 11:22 AM
  5. Bombfetish's Avatar
    Thanks for the tip. I did look for any missing updates with that app, but it didn't fix anything. I'm starting to notice now, that the vibration is weak. Certain times a text goes off, the normal vibration that would happen is just weak as if it dies off.

    So many weird things all at once! Starting to think hardware.... Either the CPU dying, or maybe moisture in there (never been in water, but from the washroom shower steam or something)

    Please help, I just don't know what I should do, normally in great at narrowing down what the symptoms point to, and fixing it.
    11-26-2013 11:05 PM
  6. huevobatido's Avatar
    Am a 920 owner and I have experienced the same problem lately.... At first I thought it was an app that was causing the bugs and glitches, but I uninstalled apps and it kept doing it. But in addition to my screen not rotating properly my screen would dim down drastically,and my lock screen would start acting up too. The only way to fix such a problems was a soft reset but the problem kept coming back. So I decided to perform a hard reset, which to be honest I didn't , I tried but for some reason I could never perform it properly but my phone stop crashing for a day or two and then it came back, it was so annoying that I almost made a claim for the one year warranty but then an update came for extras+info and my phone started working properly again. Its been about 3 or four days now and unfortunately the problem came back but just once, so am still debating on what to do. I have been trying to work my phone to the fullest this past days trying trigger the bug again but with no luck. I blame all this problems on gdr2 since everything started after the update.... What I will recommend you to do is go thru your settings and try to set everything to default settings see if it keeps it from crashing, turned off glance and double tap and it kind of helped and also try to keep up with the system updates.
    11-27-2013 12:11 AM
  7. Bombfetish's Avatar
    As an update, a hard reset did nothing for me other than annoying me by losing a bunch of my app data. The other day, the phone randomly started working perfectly for about 8 hours... I thought it fixed itself! But then it stopped working again, with no rhyme or reason... Didn't update any apps or anything. Another weird thing, when the rotation stops, Facebook and UC Browser take approx 10 seconds to load. But when rotation works its instant. Same with games hub, crashes when no rotation, works fine when the rotation works. I'm ready to give up and just ditch the phone... I'm on vacation so trying to take panorama photos with broken gyros just doesn't work. It still seems like a weird software glitch somehow... Does anyone have any other ideas?
    12-08-2013 11:52 AM
  8. Bombfetish's Avatar
    Sorry, and to answer the last posts question. I have glance off, double tap to wake off. All of that. Screen is set to medium brightness (not auto) touch set to medium, no NFC no Bluetooth, I tried turning WiFi off and resetting, but that didn't work either... I can't seem to make it work without soft resetting (then it breaks after 1-3 mins). When it worked for 8 hours, I tried to break it by opening lots of apps, rotating, taking pictures, playing games that use the gyros, but it kept working and then eventually just stopped. Le sigh. Thanks in advance for any help!
    12-08-2013 11:56 AM
  9. Bombfetish's Avatar
    Brought my phone to a cell repair shop. Said my accelerometer is toast, so I suppose I need a whole new logic board! Guess the phone is staying how it is, not worth the money to fix that. So surprised this just started happening randomly.
    01-08-2014 08:00 AM
  10. orbitrus's Avatar
    Thought I'd add my two cents - same issue here, started in the last week-and-a-half, sometime after updating to Lumia Black. Soft reset didn't fix it. Hard reset worked - for about 2 minutes, then broke again. Called Nokia, they got me to do a factory reset and wiped all data back to defaults. No luck - still no rotation, and 3 out of 4 sensors aren't reporting in. Seems this issue is popping up quite a bit lately across the boards.

    It's only been 9 months since I purchased the phone, so I asked Nokia to repair it under their 1-year warranty. However, Nokia threw me for a surprise, and refused to cover it because I bought an unlocked international model. I don't like the carrier they made an exclusive with up here in Canada, so apparently they don't like me as a customer. Shame.

    I've also decided it's not worth the cost to fix. I'm starting to think the entire 920 line was a bunch of lemons, after having read tales of (and experienced) spontaneous battery drain cycles with no background apps, and now this - all problems which seem to be limited almost exclusively to the 920. Shame.
    02-11-2014 06:39 PM
  11. Bombfetish's Avatar
    Ugh sorry to hear that man. Mine has been like this for months now. Waiting to get the black update to see if it miraculously fixes it, but I think not. I don't think id buy a windows phone again, even though I like the layout of things and wish the platform well. Thanks for letting me know I'm not the only one dealing with this
    02-13-2014 08:17 AM
  12. Bombfetish's Avatar
    Black update didn't fix it. I'm convinced its either moisture on the motherboard, or damaged sensors/ribbon cable. I've ordered the main flex cable on ebay and I'm going to heat it up to remove it from the PCB and then stick the new one on with 3M Conductive tape. I'll post results for those who are having this problem.
    02-21-2014 10:09 PM
  13. Makxi's Avatar
    aand did it stop with the freezing when you replaced flex cable?? my only hope is again with the update and I mean on wp 8.1 update and flex cable :/

    edit: I can see now that lots of them are having this problem on lumia 920, after the black update, so it's system software causing the problem, I hope that will someone listen from nokia or microsoft about these problems
    04-01-2014 01:31 PM
  14. BeingBoston121's Avatar
    The accelerometer for the 920 is on the flex cable that has the side buttons. You just need to replace that and you should be all set.

    Pretty easy fix if you have the time.

    ​Tim
    04-01-2014 04:35 PM
  15. saurabhsdwivedi's Avatar
    hey I had te same issue with My Lumia 920 , Screen rotation was locked,Camera was locked to potrait mode,Proximity Sensor was not working,the games depending on Accelerometer were crashing ..I read up on few sites and came accross a interesting fact that these Lumia phone sensors are much more prone to Dust and the sensors need to be kept clean. I removed the dust of the top of the sensors using any a thin hard paper..And believe me everyting is working back as normal..I just fixed this so it could be a total fluke , but after cleaning everything worked it couldn be a co incidence..Try it once maybe this would work! PS: will post again if my phone is still working after a week. :P
    08-03-2014 03:30 PM
  16. Sam034SF's Avatar
    Hello,

    The same happened to me like a year ago. I tried everything; Soft reset that only works for a few minutes; Hard reset that bricked the phone and then reinstall the firmware using NSU for Retail that only works for some minutes as well.

    I surf for the web searching for a solution. And I found it, you might think that it is something stupid but, here you go:

    You have to drop your phone from about 15 and 20 centimeters.

    When I did that, I put my phone inside a soft sock and then I proceed dropping it three times on a wood table.

    Well if you do this remember that is over your own risk. It worked for me and the guy in the post I read (I do not have the link).

    If you do it, let us know what happened.
    masuta likes this.
    08-04-2014 01:35 AM
  17. Rferretselectric's Avatar
    My 920 just had a stuck accelerometer too (gyro was fine). Dropping it in its PU case from 20cm onto my desk fixed it instantly. Try at your own risk, but it worked for me!
    masuta likes this.
    08-21-2014 01:15 AM
  18. masuta's Avatar
    I joined just to say thanks to the 2 people that made the suggestion of dropping the phone. I dropped it from about 20 cm in its soft case and the accelerometer instantly reset! Now everything is working again.
    02-19-2015 10:41 PM
  19. Milos Jovanovic2's Avatar
    OMG!!!!!!!!! THANKSSSSSSS!!!!!!!!!
    04-20-2015 01:12 AM
  20. Sawyer D's Avatar
    Hello everyone, I too signed up just to say that I accidentally dropped my phone with a soft casing as well and it worked.. miraculously... FYI, I am currently developing a windows game with gyroscope capability and it is bothering me that now I have to inform my users to do this crazy stunt if the app is not working.. HAHA! Really have to dig deep to understand this issue.
    05-19-2015 08:32 AM
  21. Keith Rowe's Avatar
    This may sound crazy, but there is actually a setting for this in 8.1. Go to Settings...System...Screen Rotation and make sure this is Unlocked. My phone flipped this setting on its own about a month ago which really surprised me because I did not know this setting existed. It works! Try it.
    06-04-2015 09:15 AM

Similar Threads

  1. screen dimming...
    By jmerrey in forum Nokia Lumia 1520
    Replies: 85
    Last Post: 01-16-2017, 08:23 AM
  2. Lock screen timeout issue
    By michail71 in forum Nokia Lumia 1520
    Replies: 16
    Last Post: 01-03-2014, 07:01 AM
  3. Glance Screen
    By Reflekt0r in forum Nokia Lumia 1520
    Replies: 18
    Last Post: 11-24-2013, 05:00 PM
  4. Replies: 1
    Last Post: 11-23-2013, 11:54 AM
LINK TO POST COPIED TO CLIPBOARD