1. Rosey777's Avatar
    I've had my phone since June and lately it's been doing this thing where it isn't plugged in and it will say it's charging..the icon will go and everything. When I go to settings screen and scroll to the battery saver part: usually it says battery saver: will turn on when battery is low, 98% left. (or whatever % is left). When the icon says it's charging and I go to the settings, instead of saying what it normally says..it will NOT have the % left. If I click on it, it will say on that screen I have 100% left which is usually wrong.

    I do have an app that does a live tile thing of how much battey I have left. I don't know if it's causing issues now but it wasn't before.

    I don't think I have water damage to it and I'm just out of ideas. A reboot will do it....but yesterday it did it 4 times. Today, already twice. I've done the hold the power button and volume down button...doesn't help..still did it.

    Any ideas?
    12-10-2013 12:02 PM
  2. DBDev's Avatar
    If you don't get any other advice you could try a hard reset. That will probably help, but it will delete all data on your phone.
    12-10-2013 12:54 PM
  3. Rosey777's Avatar
    That would really suck....but might be worth a shot. How would I do that?
    12-10-2013 01:02 PM
  4. Fryykk's Avatar
    Hi, I have the same problem too recently... Would glad to hear a solution for that... Should I change my battery or its only OS problem?
    12-11-2013 09:29 AM
  5. MrWoldo's Avatar
    I got the same issue, battery says it is charging when it is not being charged. The problem is that it will show a full battery while it is actually on power save mode. This way Im not getting messages without knowing it, because I think my battery is still full!
    01-17-2014 03:07 PM
  6. borasar's Avatar
    were you at Fukushima or Chernobyl recently?
    I've had my phone since June and lately it's been doing this thing where it isn't plugged in and it will say it's charging..the icon will go and everything. When I go to settings screen and scroll to the battery saver part: usually it says battery saver: will turn on when battery is low, 98% left. (or whatever % is left). When the icon says it's charging and I go to the settings, instead of saying what it normally says..it will NOT have the % left. If I click on it, it will say on that screen I have 100% left which is usually wrong.

    I do have an app that does a live tile thing of how much battey I have left. I don't know if it's causing issues now but it wasn't before.

    I don't think I have water damage to it and I'm just out of ideas. A reboot will do it....but yesterday it did it 4 times. Today, already twice. I've done the hold the power button and volume down button...doesn't help..still did it.

    Any ideas?
    01-17-2014 03:11 PM
  7. AndrewL920's Avatar
    Real wireless charging technology?
    01-19-2014 01:22 PM
  8. Lord Chabelo's Avatar
    Anyone else have this issue or has a solution been found?
    09-25-2014 04:11 PM
  9. tatotiburon's Avatar
    i have the same problem and after that the touch screen is a mess when the phone is blocked and the buttons (camera, volume, power) doesn't work...i did various hard reset, didn't work i even changed the firmware with the cyan update and didn't work...everytime i restart the phone it show me the charging icon (NOT PLUGGED IN) and battery 0% i have to do several restarts to fix this but the buttons still gone
    09-26-2014 03:27 PM
  10. Sandun Dassanayake's Avatar
    my lumia 925 has the same issue
    11-14-2014 03:23 AM
  11. Zbyna's Avatar
    I faced the same issues. Hard reset did not resolve it either. Only in service they have exchanged the mainboard to fix the issue.
    11-14-2014 05:15 PM
  12. Robert Njane's Avatar
    I had the same problem with lumia 520, a reboot worked for me
    02-07-2015 12:59 AM
  13. dellboy67's Avatar
    I have this same issue with a Nokia 520. Tried hard reset several times as well as many soft resets. Even tried a new battery which appeared to work for about a week then started playing up again. Will probably have to send it back fro a warranty repair...
    03-14-2015 07:51 AM

Similar Threads

  1. Lumia 920 post GDR3 update
    By pankaj981 in forum Nokia Lumia 920
    Replies: 109
    Last Post: 12-18-2013, 05:10 AM
  2. Creaking in casing
    By dayoungtx in forum Nokia Lumia 928
    Replies: 2
    Last Post: 12-16-2013, 03:54 PM
  3. Make signal battery bt wifi icon alive stable in gdr3
    By geoghotas in forum Nokia Lumia 820
    Replies: 5
    Last Post: 12-12-2013, 04:33 AM
LINK TO POST COPIED TO CLIPBOARD