1. SoullessOnyx's Avatar
    Hey... I got a lumia 920 a few months ago and sent it in for repair for battery drain... I got a new one from the repair place and it worked fine.
    I have had it for around 2 months now and everything was great... My phone was on 50% about 20 minutes ago when I last check and it won't turn on... I have plugged it into the charger and nothing happens. I have never dropped it or nothing... What on earth is going on thanks...
    04-18-2014 01:17 PM
  2. SoullessOnyx's Avatar
    Never mind... Someone told me to hold down the power/lock button and volume button to fix it and it did!

    Though this problem has happened two times now, can someone tell me what caused this?
    04-18-2014 01:27 PM
  3. Titaniumgiant's Avatar
    Sounds like the flux capacitors are malfunctioning due the friction loss of the Johnson rods not lubed up to spec. I would do a software reset to factory default and that should take care of it.
    04-18-2014 02:52 PM
  4. MrWhiteman's Avatar
    The phone has a dodgy plutonium connection
    04-18-2014 06:14 PM

Similar Threads

  1. After reset, phone goes to Start Screen and not to Lock Screen
    By AlwaysColtron in forum Windows Phone 8.1 Preview for Developers
    Replies: 2
    Last Post: 04-18-2014, 02:48 PM
  2. Output to Xbox one from Xbox Music App on Phone
    By ttop in forum Groove Music
    Replies: 1
    Last Post: 04-18-2014, 12:57 PM
  3. Uber Racer now at the Windows Phone Store after spending time with iOS
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-18-2014, 12:40 PM
LINK TO POST COPIED TO CLIPBOARD