1. udupa1982's Avatar
    So, i installed update 1 few days back and since then i have noticed some things and would like to know who else is facing them.
    1) My battery life is just horrible. My phone loses charge in few hours and soft reset didn't even help
    2) Incognito more doesn't work in IE, instead search directly goes into cortana from IE.
    3) Home screen scrolling feels laggy
    4) Closing Animation feels laggy
    5) Phone gets extremely hot whenever i use here drive.
    6) Phone gets extremely hot and shuts down when i use here drive and stream music over bluetooth. I suspects it's shutting down to protect itself from heat. So phone heating up is becoming a regular problem.

    7) phone heats up even when i use mytube or play any video.

    I have tried soft reset and it didn't help, so thinking of uninstalling all apps and using hard reset option.
    So if anyone has done hard reset then please let me know..

    Phone dropped 10% while i wrote this..

    Live to hear other L920 user experiences.
    Sent from Nokia Lumia 920
    Attached Thumbnails wp_ss_20140810_0006.png   wp_ss_20140810_0008.png  
    08-10-2014 02:26 PM
  2. aikidaves's Avatar
    Yeah, something's wrong on your phone. Hard reset should fix it, although you may want to check Battery Saver first to see if you can pinpoint a specific app(s) to uninstall/reinstall. Losing 29.5% per hour, though, that's pretty horrible. I was lucky with update 1, it didn't cause any problems on my 920, but I did have issues with the 8.1 Preview that took me some time to work through. In the list below, I went as far as step 4, although that didn't really improve much over the results of step 3, where I did some reinstalls and turned off some stuff I didn't need (NFC and, ironically, Battery Saver made the biggest differences).

    My list of steps to correct battery problems:

    1. Reboot.
    2. If not better, soft reset, maybe a few times.
    3. If not better, go into Battery Saver, Usage, and see if it's one or a few apps. Uninstall/reinstall may fix. Also, check what you're allowing to run in background, check your settings and turn off background things you don't need, uninstall apps you don't use, etc.
    4. If not better, hard reset with restore.
    5. If not better, hard reset with setup from scratch.
    6. If not better, Nokia Recovery Tool to go back to 8.0 and start over.
    7. If not better, might be a hardware issue.


    Good luck!
    08-10-2014 03:19 PM
  3. denzilla's Avatar
    I'm thinking of flashing my phone back to 8.0 and just waiting for ATT to get off their *** and push 8.1+Cyan. My 920 ran fine on plain 8.1, but Update one has made it glitchy. Website scrolling "sticks" a lot when browsing now and I've has issues with my brightness settings not working till after reboot.

    Sure as ****, as soon as I flash, they'll release a patch to fix all my problems.
    08-10-2014 09:11 PM
  4. maclancer's Avatar
    Wait for AT&T to release Cyan.
    08-10-2014 09:21 PM
  5. L Beezy's Avatar
    Sorry to hear you're having problems with your L920. Other than a slight battery drain--I suspect it's on my end having more apps running in the background due to live folders--I'm having no issues with Update 1 on my L920. The only issue I've seen is my phone crashing when using live folders...only happened twice since I've had Update 1 and can't seem to replicate it.

    Sounds like a bad update install or a rogue app/apps. I don't want to say this, but... I would just do a restore; first with backup. If all the issues are still plaguing you, then I would suggest a restore with a fresh start--no backup.
    08-10-2014 09:57 PM
  6. Visa Declined's Avatar
    Threads like this are exactly why I'm not installing the DP until I get Cyan. My 920 is my work phone, and I really need it to work correctly. C'mon Cyan!
    08-10-2014 10:28 PM
  7. emark858's Avatar
    To be honest, my battery life has actually gotten better with update 1. I also don't have to soft reset every couple of days now.
    08-10-2014 10:30 PM
  8. worldspy99's Avatar
    On my 925 and 810 the battery life is quite good :-)
    08-10-2014 10:32 PM
  9. Chris_Kez's Avatar
    I'm on AT&T so I still haven't officially gotten 8.1 + Cyan, but using the developer preview version I've noticed a lot of laggy scrolling on the Start screen and the App list. Sometimes I just see blank tiles for a few seconds as the screen is redrawn. I've also noticed a slowdown in IE loading sites and swiping forward/back while browsing. Calendar actually crashed last night, and things just feel a bit slow overall. OTOH, battery life has not been affected as far as I can tell. The overall experience just reminds me of when I had an iPhone and I would put the latest version of iOS on it; everything would just slow down. I'm wondering if I'd benefit from clearing out some memory (I'm always around 31GB). Once AT&T officially rolls out Cyan I may just bite the bullet and do a hard reset/clean install. Ugh.
    08-18-2014 12:24 PM
  10. aikidaves's Avatar
    I'm on AT&T so I still haven't officially gotten 8.1 + Cyan, but using the developer preview version I've noticed a lot of laggy scrolling on the Start screen and the App list. Sometimes I just see blank tiles for a few seconds as the screen is redrawn. I've also noticed a slowdown in IE loading sites and swiping forward/back while browsing. Calendar actually crashed last night, and things just feel a bit slow overall. OTOH, battery life has not been affected as far as I can tell. The overall experience just reminds me of when I had an iPhone and I would put the latest version of iOS on it; everything would just slow down. I'm wondering if I'd benefit from clearing out some memory (I'm always around 31GB). Once AT&T officially rolls out Cyan I may just bite the bullet and do a hard reset/clean install. Ugh.
    Have you tried a soft reset? Has fixed my 920 both times it's gotten laggy (happened last night and about a week ago).
    08-18-2014 12:40 PM
  11. beachedwhale42's Avatar
    My 920 gets warm when using Here Drive and plugged in, but that might be because it's summer and it sits in the windshield while driving. Aside from that, I don't have any of the other issues. My 920 only drops about 5% of battery after idling for 5.5 hours. I don't know if the home screen is laggy compared to WP 8 because I never really used 8. I got my 920 off Ebay about two months ago and started fresh with a factory reset, then did all DP updates directly to 8.1 before installing any apps or doing anything at all. I am currently on 8.1 Update DP with Lumia Black.
    08-18-2014 01:15 PM

Similar Threads

  1. Biggest Problem With Windows Phone & Windows 8/RT - Xbox Music & Video
    By missionsparta in forum Microsoft News & Rumors
    Replies: 22
    Last Post: 08-16-2014, 01:56 PM
  2. Customizing windows phone tiles individually?
    By Unregistered in forum Ask a Question
    Replies: 2
    Last Post: 08-10-2014, 02:25 PM
  3. No Nokia Cyan Update for 925
    By Ripon Borah in forum Ask a Question
    Replies: 3
    Last Post: 08-10-2014, 01:55 PM
  4. Replies: 1
    Last Post: 08-10-2014, 01:39 PM
  5. lost pin/password, can't use my phone
    By Anissa Harrell in forum Windows Phone 7
    Replies: 1
    Last Post: 08-10-2014, 12:48 PM
LINK TO POST COPIED TO CLIPBOARD