Galaxy Note 10 Deal: BOGO at Verizon!
  1. Stian Alexander's Avatar
    I got a problem with my 920 that I have tried to work out by my self, but it wasn't as easy as I tought. I got the 920 from a friend of mine when my androidphone turned completely mad, after several months of barely working as a phone. He gave me the phone because the digitizer where shattered and the cover was a bit damaged on the top right corner from when he dropped it onto a concrete floor. But it was working fine. I used the phone for a couple of months before I finally found out that it was about time to order new parts; new digitizer, screen adhesive, back cover and key flex for volume, power and camera.
    After about one month of use the Volume up and Camera button stopped working, did a bit of searching online and found out that it could be a easy-fix when I allready had to open up the phone to change the digitizer and the back cover.
    Changing the parts went well, all parts fitted in the right place and working nicely, but not the buttons. (Volume up and Camera)
    I am now wondering if anyone have experienced this or know what I should do to sort out this problem?
    11-18-2014 03:52 PM
  2. Viracocha's Avatar
    I replaced one of these (shamefully using super glue, it was an emergency...don't judge) after replacing the digitizer and it all worked fine. I'm pretty sure I got very lucky. But, now I have to replace another one on a different phone and I'm trying to find a better adhesive. I bought two replacement parts, just in case, but I haven't done it yet. What did you use as adhesive? Some were saying to use conductive adhesive for iPads? It's hard to find information on it.

    Are you sure it's making direct contact with all the important points? Your power button works? At least you have that. My power button and camera buttons don't work. The power button is killing me. Maybe these are just crappy parts?
    11-18-2014 05:08 PM
  3. Deanig_12's Avatar
    I got a problem with my 920 that I have tried to work out by my self, but it wasn't as easy as I tought. I got the 920 from a friend of mine when my androidphone turned completely mad, after several months of barely working as a phone. He gave me the phone because the digitizer where shattered and the cover was a bit damaged on the top right corner from when he dropped it onto a concrete floor. But it was working fine. I used the phone for a couple of months before I finally found out that it was about time to order new parts; new digitizer, screen adhesive, back cover and key flex for volume, power and camera.
    After about one month of use the Volume up and Camera button stopped working, did a bit of searching online and found out that it could be a easy-fix when I allready had to open up the phone to change the digitizer and the back cover.
    Changing the parts went well, all parts fitted in the right place and working nicely, but not the buttons. (Volume up and Camera)
    I am now wondering if anyone have experienced this or know what I should do to sort out this problem?
    can you not but thew old buttons in with the new case see if that helps??
    11-18-2014 05:09 PM
  4. Stian Alexander's Avatar
    I replaced one of these (shamefully using super glue, it was an emergency...don't judge) after replacing the digitizer and it all worked fine. I'm pretty sure I got very lucky. But, now I have to replace another one on a different phone and I'm trying to find a better adhesive. I bought two replacement parts, just in case, but I haven't done it yet. What did you use as adhesive? Some were saying to use conductive adhesive for iPads? It's hard to find information on it.

    Are you sure it's making direct contact with all the important points? Your power button works? At least you have that. My power button and camera buttons don't work. The power button is killing me. Maybe these are just crappy parts?
    After I figured out that it didn't work I took it apart again to make sure that it was in the right position, same thing happened.
    As I live in Norway, the nearest place for me to order the parts I needed were at replacebase.co.uk .
    They have original adhesive for the digitizer (precut and ready to use). I haven't heard of conductive adhesive until now. Will have to se if I can find out anything about it. ๐Ÿ˜‹

    I have no problem understanding how annoying it must be when the power-button isn't working. The good thing is that you can set the phone to wakeup if you doubletap on the screen ๐Ÿ˜‰
    11-19-2014 03:22 AM
  5. Stian Alexander's Avatar
    The buttons are making a click when I push them. If that's what you mean? ๐Ÿ˜œ
    11-19-2014 03:25 AM
  6. Viracocha's Avatar
    Yeah. Double tap has saved me a bit. But, I have to wait until it goes to sleep before I put it in my pocket so it doesn't accidentally dial anybody. And now I'm getting SIM error, so I have to wait for the battery to drain to reset.

    What about the adhesive for the volume/power/camera strip? Did they have that as well? I didn't see it on their website. I got my volume strips on ebay. 3 so far. The first one worked with superglue, but I think I got lucky.
    11-19-2014 02:55 PM
  7. Stian Alexander's Avatar
    What about the adhesive for the volume/power/camera strip? Did they have that as well? I didn't see it on their website. I got my volume strips on ebay. 3 so far. The first one worked with superglue, but I think I got lucky.
    The buttonstrip i ordered from replacebase were ready with adhesive. There are two guideholes in the strip that have to align to two holes on the phone. I used two of my torxdrives to pierce through the thin adhesive on the strip and put them in the holes on the phone ๐Ÿ˜Š is it a problem with the SIM-card, or do you think it is the phone?
    Viracocha likes this.
    11-20-2014 10:50 AM
  8. Viracocha's Avatar
    is it a problem with the SIM-card, or do you think it is the phone?
    I think it's the phone. First the flash went, then the button strips and now the SIM. I'm pretty sure I was given a re-furb when I exchanged my first one. I've read on a few posts that these symptoms are common when one is not careful opening up the phone. But, I might try to get a new SIM after I replace the button strip.

    So the thin adhesive was a separate piece that came with the button strip? Was it kind of like the adhesive that came with the digitizer? I ended up ordering a small strip of conductive adhesive used for ipads. As soon as I get it, I'll install the button strip and let you know how it worked out.
    11-21-2014 12:34 PM
  9. Viracocha's Avatar
    The two flex cables I ordered have slight differences. One has the green color for the connector part and middle node, the other does not. Also, for the one without the green, the ribbon seems more opaque. It's probably not relevant, but I just thought I'd make note of it.

    Because the original flex cable had the green, I decided to use the replacement cable with the green. I used the conductive tape I mentioned earlier. Although now, after more searching, I think it's only necessary for replacing the motherboard flex cable (especially, considering super glue worked the first time). Anyways, I re-assembled everything, plugged it in to charge and waited. As soon as it powered up, all three buttons were working! But, after about 10 seconds, sadly, it reverted back to only the volume button working. It almost seemed as if it shorted out. This is the first time I opened up this phone. I doubt I could've damaged the connector. Oh well. Maybe I'll try the other cable since I have everything out.
    12-04-2014 01:03 PM
  10. Jay T3's Avatar
    Try
    Yeah. Double tap has saved me a bit. But, I have to wait until it goes to sleep before I put it in my pocket so it doesn't accidentally dial anybody. And now I'm getting SIM error, so I have to wait for the battery to drain to reset.

    What about the adhesive for the volume/power/camera strip? Did they have that as well? I didn't see it on their website. I got my volume strips on ebay. 3 so far. The first one worked with superglue, but I think I got lucky.
    Look for an app called, one touch lock screen. It saved me when my power & volume didn't work on my 920. You can lock with the app & set double tap to wake.
    Keep blessed
    Last edited by xandros9; 11-25-2016 at 11:29 AM.
    11-21-2016 12:09 PM
  11. gordonfink's Avatar
    3M two-sided tape

    I replaced one of these (shamefully using super glue, it was an emergency...don't judge) after replacing the digitizer and it all worked fine. I'm pretty sure I got very lucky. But, now I have to replace another one on a different phone and I'm trying to find a better adhesive. I bought two replacement parts, just in case, but I haven't done it yet. What did you use as adhesive? Some were saying to use conductive adhesive for iPads? It's hard to find information on it.

    Are you sure it's making direct contact with all the important points? Your power button works? At least you have that. My power button and camera buttons don't work. The power button is killing me. Maybe these are just crappy parts?
    Sim reader failures on the 920 are a real pain. It's easier to replace the whole motherboard than just the sim reader. You can buy just the board, or a phone with a broken screen.
    Last edited by xandros9; 11-25-2016 at 11:29 AM.
    11-25-2016 09:21 AM

Similar Threads

  1. How do I get my BBM that is stuck at SETTING UP PAGE fixed?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-25-2014, 02:35 PM
  2. Lumia 535 now available for pre-order on Amazon Germany
    By luisfarelo in forum Microsoft Lumia 535
    Replies: 5
    Last Post: 11-22-2014, 05:17 PM
  3. Why isn't my Nokia Lumia 520 working?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-18-2014, 03:53 PM
  4. nokia lumia 1520 speakers don't respond
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 11-18-2014, 03:47 PM
  5. How do I get my that is locked up fixed?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-18-2014, 02:51 PM
LINK TO POST COPIED TO CLIPBOARD