1. uninvitedguest's Avatar
    There has been no change to my sim card- the tray hasn't been removed since I first bought the phone in December of 2012.

    About two weeks ago I started receiving the Invalid Sim error at random intervals and can't think of any event that would have changed the status of the phone. No drops on the floor, no updates to the software. Has anyone else been experiencing this?

    OS Version: 8.10.14203.306
    Firmware: 3051.500009.1424.0000
    Lumia Cyan

    Edit: Wow, no ability for me to add follow up info? Huh.

    It is a Rogers Lumia 920 and I am running the developer preview. I'm on Fido as a carrier and have been since I got the phone. The first batch of 920's didn't need unlocking to swap between the two carriers as Rogers owns Fido.

    I'll try cleaning the SIM tray and applying some tape as suggested.
    Last edited by uninvitedguest; 11-26-2014 at 03:54 PM. Reason: Additional Information
    11-26-2014 02:03 PM
  2. Therealeinn's Avatar
    I also have been experiencing the "No SIM Card" intermittently recently. I thought it had to do with me exchanging out my prior regular SIM card to the new encrypted SIM card from AT&T (to use Microsoft Wallet), but if you are having the same issue and haven't changed it since 2012 I am thinking it has to do with WP 8.1 or Cyan.

    OS Version: 8.10.12393.890
    Firmware: 3051.500009.1425.2001
    Lumia Cyan

    I am on AT&T US, which carrier do you have? I also see that your OS version is slightly newer than mine, are you on Developer Preview?
    11-26-2014 03:22 PM
  3. Scienceguy Labs's Avatar
    Try sliding a small piece of paper behind the SIM card to keep it pressed against the connections better. This happened to my 920 a while back, and wedging something behind the SIM worked for me.
    11-26-2014 03:43 PM
  4. AndyFZ1S's Avatar
    Take sim out and clean it, also check all the sim contacts are in place, You may need to put a thin bit of tape behind sim card so it makes better contact.
    11-26-2014 03:44 PM
  5. uninvitedguest's Avatar
    I also have been experiencing the "No SIM Card" intermittently recently. I thought it had to do with me exchanging out my prior regular SIM card to the new encrypted SIM card from AT&T (to use Microsoft Wallet), but if you are having the same issue and haven't changed it since 2012 I am thinking it has to do with WP 8.1 or Cyan.

    OS Version: 8.10.12393.890
    Firmware: 3051.500009.1425.2001
    Lumia Cyan

    I am on AT&T US, which carrier do you have? I also see that your OS version is slightly newer than mine, are you on Developer Preview?
    That was silly, it only let me reply to you after I edited the main post. as you can see the info is now in there. It is a Rogers Lumia 920 and I am running the developer preview. I'm on Fido as a carrier and have been since I got the phone. The first batch of 920's didn't need unlocking to swap between the two carriers as Rogers owns Fido.
    11-26-2014 03:55 PM
  6. anon(9057135)'s Avatar
    Have you cleaned the SIM slot?
    11-28-2014 01:48 PM
  7. Laura Knotek's Avatar
    You might want to ask your carrier for a new SIM.
    Sent from my Nokia Lumia 920 via Tapatalk
    11-28-2014 02:32 PM
  8. GerOrBa's Avatar
    Happened to me as well just after I updated to Cyan and WP8.1... I thought it was related to that.

    I got the NO SIM error message every other day

    It turns out that just removing and doing a quick clean of the sim card terminals solved the problem.

    I lived with this issue for a couple of months before realizing the problem was not related to the software update at all :(
    11-28-2014 03:15 PM
  9. anthonyng's Avatar
    samething was happening to my friends Rogers 920. My 920 was fine... seems pretty common though!
    11-28-2014 05:48 PM

Similar Threads

  1. Errors with new phone and re-subbed Music Pass
    By jasqid in forum Groove Music
    Replies: 5
    Last Post: 11-29-2015, 07:31 AM
  2. Replies: 1
    Last Post: 01-24-2015, 02:45 AM
  3. Error when downloading songs from Xbox music 8000ffff
    By alejoseed in forum Windows Phone 8.1
    Replies: 9
    Last Post: 12-10-2014, 12:43 PM
  4. Why am I getting a Google Error Code when I refresh?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-25-2014, 11:10 AM
  5. Replies: 1
    Last Post: 11-25-2014, 10:00 AM
LINK TO POST COPIED TO CLIPBOARD