1. Aditya Khandkar's Avatar
    I use a 920 and recently my windows keys' lights turn off someone after I switch on the phone. I want the lights to be on all the time. How do I do that?
    12-15-2014 02:41 AM
  2. Conan143's Avatar
    I use a 920 and recently my windows keys' lights turn off someone after I switch on the phone. I want the lights to be on all the time. How do I do that?
    Hi guys, this issue is related to Device Hub. Yes, weird but true exactly!

    So, -the only one- solution is:

    1) Reset your phone (required)
    2) When resetting is completed, complete your installation steps
    3) When the phone is ready to use, quickly go to Settings > Date+Time
    4) Set the year like 2150 or more
    5) Go to Settings, tap the Device Hub
    6) Uninstall it
    7) Set the date as auto again

    Problem will be solved.

    Never open Device Hub even once! Uninstall it and don't install again.

    p.s. If you open Device Hub even once, battery saver crashes and your issue comes over again. Then you must reset your phone to solve it.
    If you open Device Hub once, uninstalling it will not solve this issue. You will have to reset your phones...
  3. Laura Knotek's Avatar
    What OS version and firmware version are you running on your 920?
    12-15-2014 03:26 AM
  4. Aditya Khandkar's Avatar
    Os version is 8.10.12393.890
    And firmware version is 3051.50009.1424.0003
    12-15-2014 04:09 AM
  5. slysy's Avatar
    I think the lights only turn on if the room is dark (by design). Try it out in both a light and dark room and see what happens
    Aditya Khandkar likes this.
    12-15-2014 04:21 AM
  6. Aditya Khandkar's Avatar
    Hmm. Lights did turn on in a dark room. But in a well lit room, they toggle on and off quite randomly.
    12-15-2014 04:29 AM
  7. Conan143's Avatar
    I use a 920 and recently my windows keys' lights turn off someone after I switch on the phone. I want the lights to be on all the time. How do I do that?
    Hi guys, this issue is related to Device Hub. Yes, weird but true exactly!

    So, -the only one- solution is:

    1) Reset your phone (required)
    2) When resetting is completed, complete your installation steps
    3) When the phone is ready to use, quickly go to Settings > Date+Time
    4) Set the year like 2150 or more
    5) Go to Settings, tap the Device Hub
    6) Uninstall it
    7) Set the date as auto again

    Problem will be solved.

    Never open Device Hub even once! Uninstall it and don't install again.

    p.s. If you open Device Hub even once, battery saver crashes and your issue comes over again. Then you must reset your phone to solve it.
    If you open Device Hub once, uninstalling it will not solve this issue. You will have to reset your phones...
    Aditya Khandkar likes this.
    12-15-2014 04:30 AM
  8. Aditya Khandkar's Avatar
    Also is it so that 920 consumes more battery than other phones due to its high resolution and ips LCD display?
    12-15-2014 04:37 AM

Similar Threads

  1. Replies: 61
    Last Post: 02-07-2015, 09:36 PM
  2. Windows Central app can't login
    By trekgraham in forum Windows Central for Windows Phone - App Support
    Replies: 10
    Last Post: 12-17-2014, 06:33 AM
  3. My Bingo Star app is taking to long to load up why?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 12-15-2014, 01:21 AM
  4. Why does my camera light on my computer keep coming on?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-14-2014, 11:36 PM
LINK TO POST COPIED TO CLIPBOARD