1. sampeterson18's Avatar
    I've got a Lumia 920. After replacing the battery, it won't read my (or any) SIM card.

    The battery life was starting to get bad, so I ordered a replacement. Popped the phone open, followed the instructions on ifixit, and was done in about 5 minutes. No big deal, and definitely not the biggest undertaking I've ever done inside a phone.

    But now, no matter what I do, it won't recognize the SIM. I get the "SIM card missing or invalid" message every time I turn the phone on. I tried a different (known good) SIM - no luck. I tried my SIM in another phone - it worked perfectly. I've blown out the SIM card slot, tried the old battery again, restarted, soft reset, hard reset, restored from backup, everything. No luck.

    I know I didn't do anything while I had the phone apart that could have caused this problem, but apparently I must have. Does anybody have any clue what I could have possibly done, or what I can try to fix it? I'm out of ideas here.

    The phone is completely stock, not jailbroken/developer unlocked/anything like that. The only semi-unusual thing about it is that it's an AT&T phone, but I had it carrier unlocked about a year ago. Other than that, it's just running whatever the latest version of 8.1 that AT&T has pushed out is.
    04-22-2015 03:41 PM

Similar Threads

  1. How to make a full backup of a Windows 10 or Windows 8.1 PC
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 05-12-2015, 06:01 AM
  2. Completely Dead Lumia 520
    By karthiksanjeev in forum Nokia Lumia 520
    Replies: 6
    Last Post: 05-06-2015, 05:54 PM
  3. Replies: 1
    Last Post: 04-25-2015, 01:28 PM
  4. Replies: 4
    Last Post: 04-23-2015, 04:31 PM
  5. Which is the best paid MOBILE Antivirus Software for Lumia 535?
    By WPCentral Question in forum Ask a Question
    Replies: 3
    Last Post: 04-22-2015, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD