1. spawnhead's Avatar
    The power button has stopped working on my Lumia 920, and it's very very annoying. Drains the battery because I can't lock the screen, instead I have to wait 30 seconds every time I use the phone.
    I've tried a bunch of fixes, but I've run out of ideas.

    • I Live in Minsk (Belarus), and there is no Nokia Care.
    • I tried removing the phone's shell, and pressing on the little nubs on the flex connector - the piece of hardware with the actual buttons (nubs) on it - with my fingernail. They 'click', like they should, but the power button does nothing. The other buttons all function properly when I use my fingernail like this, and they all function properly when the phone is assembled.
    • I tried just rebooting the phone (Settings -> region, changing region gives me a 'reboot' button, since I can't hold the power button).
    • Given that my tinkering has probably rendered my warranty worthless, I tried ordering a new flex connector and replacing the old one. This didn't fix it either, though the buttons feel 'like new'!
    • I thought it must be a software issue then, if completely replacing the hardware didn't fix anything. Factory reset my phone through the settings menu, and... The button still doesn't work.
    • Hmm. Maybe the firmware then? I used the Nokia Software Recovery Tool to install NEW version of OS. But it also doesn't work.


    Maybe someone help me to solve this problem? I have no idea what to do.
    06-19-2015 02:52 AM
  2. jonahtrav's Avatar
    Download quick tiles from the store and you can put a Lock tile on the screen and never have to use the power button...I almost never use the power button, give it a try... It works great.
    06-19-2015 03:15 AM
  3. N_LaRUE's Avatar
    [*]I tried removing the phone's shell, and pressing on the little nubs on the flex connector - the piece of hardware with the actual buttons (nubs) on it - with my fingernail. They 'click', like they should, but the power button does nothing. The other buttons all function properly when I use my fingernail like this, and they all function properly when the phone is assembled.
    This point here should give you the clearest indication of what's wrong. Obviously the power button is no longer functioning. Nothing to do with software or firmware. It's completely hardware.

    It would appear that either 1 - you pressed the button past it's functional life span or 2 - it was faulty

    I'm more inclined to go with 2.
    06-19-2015 03:22 AM
  4. spawnhead's Avatar
    This point here should give you the clearest indication of what's wrong. Obviously the power button is no longer functioning. Nothing to do with software or firmware. It's completely hardware.

    It would appear that either 1 - you pressed the button past it's functional life span or 2 - it was faulty

    I'm more inclined to go with 2.
    I changed the flexible cable with buttons , replaced by new ones! And it did not help.
    Last edited by spawnhead; 06-19-2015 at 03:58 AM. Reason: additional
    06-19-2015 03:57 AM
  5. spawnhead's Avatar
    But if you need to restart phone How i do that? Or if my phone do not respond? How I can do soft reset without power button ?
    06-19-2015 04:02 AM
  6. N_LaRUE's Avatar
    I changed the flexible cable with buttons , replaced by new ones! And it did not help.
    Bit odd that you replaced the hardware and it still didn't work. That's very strange.

    If you did a hard reset and used the Lumia Recovery Tool and it still doesn't work after all that then there's something else wrong with the phone.

    Could be anything.

    Time for a new phone?
    06-19-2015 05:03 AM
  7. spawnhead's Avatar
    Bit odd that you replaced the hardware and it still didn't work. That's very strange.

    If you did a hard reset and used the Lumia Recovery Tool and it still doesn't work after all that then there's something else wrong with the phone.

    Could be anything.

    Time for a new phone?
    Maybe time for a new phone)). If i solve this problem i will write about approach.
    06-19-2015 05:06 AM
  8. spawnhead's Avatar
    So, I have news about my problem! I think problem was in Z1300 chip on main mother board, he has some chipping and i will try to replace it.
    Last edited by spawnhead; 06-23-2015 at 05:13 AM.
    06-23-2015 04:23 AM
  9. RichardMalone's Avatar
    Hey spawnhead,

    Any luck with solving the issue. I my power, volume down and camera buttons are all dead (vol up still works). I don't want to get a new phone until release of new lumias.

    Thanks.
    09-16-2015 04:14 AM
  10. spawnhead's Avatar
    Hey Richard, the problem is malfunction of chip near the flash. Need to replace this chip! Chip is not expansive but operation may cost about 15-20$! If you need some additional information write me.
    this information can help you!
    Part number: 4129016

    LCD filter 4129016 Nokia - ASIP 7-CH LCD EMI/ESD LRC
    Nokia N97 Z4402
    Nokia 925 Z4400
    Nokia N97mini Z4403
    Nokia 820 Z4404
    Nokia N97 Z4403
    Nokia E7-00 Z2500
    Nokia 1020 Z4400
    Nokia N97mini Z4402
    Nokia 920 Z1300

    Hope I helped you!
    Last edited by spawnhead; 09-16-2015 at 05:10 AM. Reason: Additional
    09-16-2015 05:08 AM
  11. poit57's Avatar
    I've had issues with this flex cable on two separate Lumia 920's. The first, I replaced a broken digitizer, and after reassembly, the volume up button acted like it was stuck even though the physical button clicked in and out as normal. On the second phone, the power and camera buttons stopped working after opening the housing to realign the rear flash contact points. In both cases, replacing the flex cable itself made no difference.

    Hey Richard, the problem is malfunction of chip near the flash. Need to replace this chip!
    Spawnhead, do my issues sound like they would be caused by the same issue? Do you have any idea how I might have damaged this chip in opening the phone, or where to get a replacement? I've repaired quite a few different types of phones starting with the iPhone 3G, but so far, I'm 0 for 2 in successfully repairing a Lumia 920. Fortunately, both of these mess-ups were my personal phones instead of a repair for someone else.
    09-17-2015 12:36 PM
  12. spawnhead's Avatar
    Dear man. i have few ideas about your problem you asked me.
    First: Maybe you damaged your flex cable when you not careful open the phone.
    Second: This chip we talking about can damaged without your touch, cuz flash light can heat this chip and it can damaged.
    Third: Check the flex cable and be sure that is work normal.
    Forth: If chip damaged you will see it. Just try to see careful. Can you give me photo of this chip and your flex cable? And I hope we can figure out in you problem.
    In any occasion plz write me to PM.

    p.s. what you mean broken digitizer?
    09-18-2015 06:06 PM
  13. poit57's Avatar
    First: Maybe you damaged your flex cable when you not careful open the phone...
    Third: Check the flex cable and be sure that is work normal.
    I thought the flex cable was the issue. In both cases, I replaced the flex cable and the same buttons had issues on each phone (first phone had issues with Volume Up and second phone had issues with power and camera buttons).

    Forth: If chip damaged you will see it. Just try to see careful. Can you give me photo of this chip and your flex cable? And I hope we can figure out in you problem.
    I ended up selling the first phone for parts almost 2 years ago because I couldn't figure out how to fix the problem. The most recent one, I just had repaired by Nokia/Microsoft's authorized repair center in the United States to get it working again. I would have preferred to do the repair myself, but I am cautious about opening up a Lumia 920 again because I'm still not sure how I might have accidentally caused this damage.
    p.s. what you mean broken digitizer?
    I was referring to the touch screen glass. On my first 920, the glass was shattered after a drop.
    09-23-2015 09:47 AM
  14. spawnhead's Avatar
    Do not be afraid to open your phone! Open youtube and find the video "Nokia lumia 920 how to open"
    (first phone had issues with Volume Up and second phone had issues with power and camera buttons).
    Definitely problem is not in flex cable because you have same issues in each phones!
    It seem like a problem in chip.
    09-23-2015 10:06 AM
  15. god_forbids's Avatar
    How did you determine this was the chip to replace? Here's my issue

    • Camera button and power button broken
    • Flex cable replaced, same problem
    • Hard reset, same problem


    This chip you mentioned is identified in this picture here and the place that has the chip for sale says it is "IC for Wifi, Bluetooth signal regulation." not anything to do with the keys. A picture of
    my chip is included and the numbers are different ... how can I safely get it off the PCB?

    chip.jpg
    03-19-2016 10:38 PM
  16. spawnhead's Avatar
    Yes you right, this is exactly my problem! Probably a mistake in the description on the website that sells this chip.
    03-20-2016 02:38 AM
  17. god_forbids's Avatar
    So you weren't able to fix your phone? I just tried another flex cable, this time a different 920's factory original cable, and it still didn't work. Definitely not a flex cable problem at this point.
    03-23-2016 06:41 PM
  18. Mohammed Hamad1's Avatar
    spawnhead, First, thank you for your hint. Maybe this is a late response, I just had the same problem, stucked in the apps corner while power button is not working.
    I did not find this chip in the market here, I disassempled my phone and tried the following:
    There are few pins next to the chip you mentioned, using a tweezer (tiny wire works too) I made a contact between the pins and the chip, that changed the phone volum, I kept trying to move the tweezer on the pins while the other side is touching the chip, till I cought the pin responsible for power button, hold the contact till you get the power off options and there you are.
    hope its clear, please anyone needs help contact me
    09-23-2016 05:11 PM

Similar Threads

  1. Lumia 640 T-Mobile
    By Alex Smith21 in forum Microsoft Lumia 640
    Replies: 14
    Last Post: 06-21-2015, 03:10 PM
  2. Lumia 640 T-Mobile
    By Alex Smith21 in forum Microsoft Lumia 640
    Replies: 5
    Last Post: 06-19-2015, 09:33 AM
  3. Lumia 535 Display dead after Update
    By BaqerNaqvi in forum Microsoft Lumia 535
    Replies: 3
    Last Post: 06-19-2015, 03:50 AM
  4. Why are some of my mp4s not being recognized?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-19-2015, 12:10 AM
  5. Replies: 1
    Last Post: 06-18-2015, 11:20 PM
LINK TO POST COPIED TO CLIPBOARD