10-14-2015 08:39 PM
545 1234 ...
tools
  1. lankylad's Avatar
    This may be a Windows 8 issue, but I cant switch to hands free mode once a call has started
    07-04-2013 02:09 PM
  2. Firenze89's Avatar
    I've noticed a bit of ghosting - if you switch to a blank screen/area after looking at some menus there is sometimes the tell-tale 'echo' of the previous screen.

    Also, this is perhaps not a defect but my sim card tray feels a bit loose - you can push it up/down and around with your finger when closed. ANyone else have this?
    My sim card tray doesn't have any looseness but I read this was the case with some review units.

    No on screen ghosting either on mine.
    07-04-2013 03:11 PM
  3. husam2277's Avatar
    I got black Lumia 925 unlocked from Vodafone Germany 32 GB... I noticed from the first moment that the brightness for the touch buttons is very very low compared to 920 and the light is not uniformly distributed over each button... also the color of the light look like yellow/orange/red combination, sorry its hard to describe the color precisely...
    I have a Lumia 920 also and it has much much better brightness even though my 920 button has the yellow tint problem... My 925 button are yellow to orange color... The brightness very very low...

    Another problem the right side of screen a little bit yellow compared to the left side when looking at the keyboard.. Also another issue which known for most Samsung AMOLED screens, if you go to completely dark room and open a black photo on the screen (you can use app called pixel doctor to check) you will notice black annoying dots darker than the rest of the screen... Mine has 7 main dots..

    Is this normal? How yours looks like? Just wondering how many people has these problems...

    UPDATE: I have another problem described below... Blurry text while scrolling....
    Noticed that my lumia 925 has a blurry text while scrolling, specially when scrolling white text over black background or black text over white background... also noticed some blurry when scrolling tiles on the home screen, this blurry occurred around the black horizontal lines separating the tiles.... compared the scrolling with the 920 and there is a huge difference...
    I read that some of the galaxy S4 units has this problem and that this problem related to Samsung AMOLED screens, and you know the lumia 925 has a Samsung AMOLED screen.
    Any one has these issues? let me know in comments please..
    Last edited by husam2277; 07-07-2013 at 02:24 AM.
    07-06-2013 09:31 AM
  4. Musicman247's Avatar
    We are getting some mixed reports on the manufacturer of the AMOLED screen. Some are claiming they are made by Samsung, some have said they have contacted Nokia who say the screens are made in-house.

    Can we get a consensus, please?
    07-07-2013 04:25 PM
  5. husam2277's Avatar
    We are getting some mixed reports on the manufacturer of the AMOLED screen. Some are claiming they are made by Samsung, some have said they have contacted Nokia who say the screens are made in-house.

    Can we get a consensus, please?
    i dont think nokia made it, what i know is that nokia has no history manufacturing screens, specially amoled ones, nokia will never admit from where they get their screens, companies like to let the customer feel that the whole device is done by them...
    07-07-2013 04:40 PM
  6. Musicman247's Avatar
    Nokia used to be a paper company, too...
    07-07-2013 04:59 PM
  7. mprice86's Avatar
    Lot of heavy use today (new user) no issues at all apart from the aforementioned backplate fit for engineer access which isn't something I'm likely to remember or be bothered by.
    07-09-2013 06:10 PM
  8. boxa72's Avatar
    Oh well I've made up my mind and I'm getting 1 next week so I hope I don't have any of these problems. I have noticed that coz Aussie is one of the last places to get products that by the time they do get here all those little issues are usually ironed out, which is a plus I guess. I'll know in a week anyway ;)
    07-09-2013 09:17 PM
  9. michael1782's Avatar
    had the phone for nearly a month now and its been sent away to be fixed. problem being the plastic on the back begin to come lose from the aluminium at the top and when pressed began clicking loud. also I compressed the camera lens in and it went that far in you could actually see in under the plastic. SO CHECK ;)
    07-10-2013 06:55 PM
  10. wpguy's Avatar
    Have same issue with posting on the web forum at times. Easier to use the WPCentral app :)
    FWIW, I frequently have issues with posting article comments and to the forums (but especially article comments) on my HD7 running WP7.5. I also sometimes run into issues on desktop and app versions of IE on my Surface (Win8) and work machine (Win7). I almost always have to switch to the plain text editor in the articles just to post anything from my phone. In both articles and forums, the text cursor freezes and I end up having to guess where newly typed text will appear in my posts.
    07-11-2013 12:31 PM
  11. paddylaz's Avatar
    had the phone for nearly a month now and its been sent away to be fixed. problem being the plastic on the back begin to come lose from the aluminium at the top and when pressed began clicking loud. also I compressed the camera lens in and it went that far in you could actually see in under the plastic. SO CHECK ;)
    what do you mean, you pushed the lens in so it recessed into the body of the phone?!
    07-11-2013 12:40 PM
  12. theroyboy44's Avatar
    I'm seriously considering buying tha 925 (currently use 820) n all I really wanna know is, has the "other" memory been rectified with the OS n Amber updates??? I really love my Lumia but missing GB's of memory is seriously pissin me off!!!
    Nokia has an app I think its called storage check and it allows u to delete the 'other storage' I know its available on the 920 series but as i dont have a Lumia I couldn't tell you which other device
    07-11-2013 05:49 PM
  13. keysersoze#CB's Avatar
    Does anyone have the problem where, on occasion, it seems that some of the 3rd party apps are not saving their settings?
    07-12-2013 03:02 AM
  14. boxa72's Avatar
    Nokia has an app I think its called storage check and it allows u to delete the 'other storage' I know its available on the 920 series but as i dont have a Lumia I couldn't tell you which other device
    I've got it on my 820 n if u think that's a solution then I want some of whatever ur on lol with storage check ur lucky if u can delete 50mb!! Nokia made that app as a short term solution but it does f#@k all!!! Its MS' responsibility not Nokia's as it's a software problem.
    07-12-2013 08:24 AM
  15. wpguy's Avatar
    My one week old L925 has about 500 MB "other" storage memory used.
    Do you have auto-backup of photos turned on? Somewhere (can't find the source) I read the issue is caused by the JPEG file save API not deleting its temporary files.
    Last edited by wpguy; 07-17-2013 at 12:04 AM.
    07-16-2013 11:54 PM
  16. lwhitmarsh's Avatar
    I've got a T-Mobile 925 and I live an area where there is excellent LTE coverage but my 925 will not connect to it. All the phone settings are correct and everything on the T-Mobile side is A-OK but for some reason it won't connect. Also if you go into cellular settings and hit network selection T-Mobile has LTE,4G,2G below it. Anyone else having this problem and/or know how to fix it?
    07-17-2013 09:49 PM
  17. nightryder21's Avatar
    I got my 925 this morning and tonight it has 1.95 GB in "Other" Storage. I have pictures to auto upload but I have only taken about 10-15 pictures. This is ridiculous. Other than that O noticed that I can not bill T-Mobile for apps when it is on Wi-Fi Calling mode.
    Ivan Mag-isa likes this.
    07-17-2013 10:46 PM
  18. dmulley's Avatar
    i got my phone today 925....when i take a picture with the camera hard ware hey the volume bar displays, also if i hit the down volume key the camera activates.....?
    07-18-2013 01:49 PM
  19. JohnnyFEZ's Avatar
    Got my Lumia 925 last night.

    Currently, I have about 1.35 gigs of "other" storage, though Storage Check says that it is only 737mb of "other" storage.

    Also, I've discovered that I cannot download MMS messages while connected to Wi-Fi. My wife has an iPhone and I receive every picture she sends via MMS as a link that says "Get Media Content," but when I click on it nothing happens. If I turn off Wi-Fi, I can then download the media content via my data plan. I didn't have this problem on my old HD7.
    07-18-2013 03:09 PM
  20. anon(5324511)'s Avatar
    I am having an odd issue, although not deal breaking. When I do a shutdown and then start my phone back up...no matter what volume setting that had it on when I shut it down, on restart, it is always set to 13/30. anyone else?
    07-18-2013 07:17 PM
  21. zukirin's Avatar
    I got my 925 this morning and tonight it has 1.95 GB in "Other" Storage. I have pictures to auto upload but I have only taken about 10-15 pictures. This is ridiculous. Other than that O noticed that I can not bill T-Mobile for apps when it is on Wi-Fi Calling mode.
    Having the same problem here. I have yet to find a solution.
    07-18-2013 08:48 PM
  22. Paedin's Avatar
    Facebook chat not working with Messaging? Dont' see the arrows to swap between FB chat and Messaging. Is there some setup I need to do?

    EDIT : Forgot to set my chat status to available. Everything click right on after that. ./facepalm
    Last edited by Paedin; 07-19-2013 at 12:57 AM.
    07-18-2013 09:19 PM
  23. mnika's Avatar
    Not necessarily a bug, but the glance screen text is red on my phone, and doesn't change when I change the theme colors on my phone. I thought the glance screen had white text? The red doesn't look so good to me
    07-18-2013 09:35 PM
  24. jgbstetson's Avatar
    Is anyone else noticing a defect where the glass is raised higher in the body at the top right side of the device? On the first unit I had the glass was coming off completely, now I'm noticing this.

    Will T-Mobile exchange this?
    07-18-2013 09:45 PM
  25. pankaj981's Avatar
    I am having an odd issue, although not deal breaking. When I do a shutdown and then start my phone back up...no matter what volume setting that had it on when I shut it down, on restart, it is always set to 13/30. anyone else?
    that's normal
    07-18-2013 09:46 PM
545 1234 ...

Similar Threads

  1. Pictures taken with your Lumia 900 post em here
    By Dave Blake in forum Nokia Lumia 900
    Replies: 525
    Last Post: 12-28-2013, 07:30 PM
  2. Replies: 3
    Last Post: 11-27-2012, 10:36 AM
  3. How to bake cookies with your Lumia 900
    By HeyCori in forum Nokia Lumia 900
    Replies: 2
    Last Post: 09-26-2012, 06:58 PM
  4. How to take better photos with your Lumia 900
    By FrankieA in forum Nokia Lumia 900
    Replies: 29
    Last Post: 05-17-2012, 01:44 PM
  5. Replies: 8
    Last Post: 04-14-2012, 08:07 PM
LINK TO POST COPIED TO CLIPBOARD