10-14-2015 08:39 PM
545 ... 34567 ...
tools
  1. JONA1970's Avatar
    When did you recieve this firmware update? I have still older one, mobile is from Germany.

    Attachment 38099
    It was available to my phone. I used NSU to update, I had to install everything again, but now I'm quite happy with my phone. No more heating, extended battery live and good call quality.
    I believe that it'll be available soon usimg OTA.

    Please see my post:
    http://forums.windowscentral.com/nok...23-3004-a.html
    07-25-2013 03:39 AM
  2. Troyseph's Avatar
    did you get a 925 without this issue?
    Yes, the 2nd one is issue free.
    07-25-2013 08:10 AM
  3. diegosalinas's Avatar
    Love the build and look of the 925. But will probably be returning it and just sticking with my 920.

    Photos are great but nothing to my eyes shockingly different than my 920. The dust issue that plagues my 920 exists with my 925 under the front facing camera. Drives me nutty.

    And sporadically thru the day, most of screen will turn black and the section not blacked out shows whatever should be displayed
    .

    I've done the resets and even tried just leaving stock app and not downloading any other apps. Still happens.

    Argh. I really love this phone build over the 920.
    07-25-2013 01:32 PM
  4. ballanda's Avatar
    I don't know if it is a defect but the reception is noticeably poorer than the 920.
    Pume likes this.
    07-25-2013 03:05 PM
  5. Pume's Avatar
    I don't know if it is a defect but the reception is noticeably poorer than the 920.



    Im having some reception issues too...hopefully its not a hardware issue.
    07-25-2013 03:29 PM
  6. cashkennedy's Avatar
    I'm having issues where every 36-48 hours it stops connecting to any cellular signal, and refuses to "search" for cellular providers/signals. A restart of phone fixes it and without moving a foot I suddenly have full 5 bars of signal. I also can not get it to connect to LTE in areas where I know T-Mobile already has LTE. I believe these issues are related, hopefully replacing the SIM will fix them which im going to try tomorrow. The SIM was one I got at the T-Mobile store in febuary when I bought a Verizon htc 8x to tide me over until a new wp8 release on t-mobile. Although it maybe related to wifi calling which I tend to be on 50% of the day as both of my jobs have no cellular signal inside. I will also try the "airplane mode" fix, but if I have to do that every 2 days, I don't that much of a solution.

    I also had one instance of a sent picture message only transmiting half the image, might also be sim card related.

    Reception was pretty bad the first few days I had the phone, and has since improved significantly. I think what other people have mentioned , that it has multiple antennas which it can select (for each section of aluminum around the phone) is related to the problem, perhaps if you start a call one way and then change your grip? Although ive never had reception issues during a call.

    Other then that the build quality is excellent on mine , and phone runs great. Although once when I turned glance screen to "peek"
    mode I got the error where part of the screen is black and part is showing what you are expecting to get. So perhaps for the people with that issue they should turn glance off or to timed.
    07-25-2013 04:10 PM
  7. steve_w_7's Avatar
    I have had my 925 for 8 days and this afternoon it turned itself off and never recovered. I had just received a phone call and an appointment reminder popped up. I looked back at it a minute or so later and it looked like it was re-booting. It was at the T-Mobile screen and then it went black. I wasn't able to boot it back up.
    I took it to the T-Mobile store on the way home from work and they couldn't get it to boot up, so they gave me a new one.
    I'll just chalk it up to a faulty unit, but it still makes me a little nervous.
    07-25-2013 10:06 PM
  8. theroyboy44's Avatar
    Do you have auto-backup of photos turned on? Somewhere (can't find the source) I read the issue is caused by the JPEG file save API not deleting its temporary files.
    that's it my 2 day old has 2GB
    07-26-2013 11:55 AM
  9. theroyboy44's Avatar
    *SIGH*

    I returned the phone today at the store, had to wait an hour and a half which couldn't be helped since they were really busy, and swapped it out. The phone doesn't have the gap or the loose back but the power button is barely responsive. It looks de-pressed and lower than the volume rocker and the camera button. When you push it's basically already down. There's no click what-so-ever.

    Kinda disappointed in the build quality here and not sure I want to go back to the store again. Don't know what my options are.
    I know exactly what you are talking about. my up volume makes a clicking sound like a really loud clicking, like REALLY loud. And when I went to change it at T-Mobile I opened literally 3 different devices and they all had some sort of defect, on one the volume buttons felt to firm and no click, and the other two the power button was really depressed and in a few months would probably not work. So I kept the original one, but now I've noticed that there are finger prints like right where the front facing camera is. most of the time you can't notice is when I clean it but no amount of cleaning will get them off. Its almost like someone had some sort of super glue or adhesive on their fingers when they touched it there. cuz when I run my nail over it I can feel the groves and I know it isn't me cuz I haven't used any adhesives in the past two days when I got it. Its really frustrating I was reading that pertrolium jelly like Vaseline can work against super glue or things like nail polish remover. If anyone can chime in on how to remove it if you have had super glue on your screen that would be awesome. Otherwise I'm gonna go to T-Mobile and I don't care how many new 925 devices I have to open, I will until I get one where the build quality is good aka the side buttons are depressed where they are practically flush, I'm gonna make sure that they click well cuz I'm not gonna dish out close to 600 (after taxes) for a phone and deal with crappy build quality
    juststart likes this.
    07-26-2013 12:19 PM
  10. ramonq619's Avatar
    So I just noticed a problem. My T-Mobile Nokia Lumia 925 won't go to landscape mode when you can. Like pictures and the browser. Anyone else have this problem?
    07-26-2013 08:49 PM
  11. murrayalex's Avatar
    Sent mine back after a week as the back was all creaky, it was okay with the power off & felt really sold but when switched on the heat from the battery was obviously affecting it and you could then press down on the left hand corner and it would creak, the whole top bit felt like it was going to pop out.....quite annoying. In addition, looking at the screen from even a slight angle and there was a very noticeable blue tint. I really liked the phone bit it's gone back to Amazon and I will look at buying another one from another supplier in case they just have a bad batch
    07-27-2013 07:46 AM
  12. Ignacio Perez's Avatar
    I am on my second 925 in a week, it reboots itself! Second one doesn't do it as often as I my first one. my first one did it at least 10 times in 4 days, second one at least 5 times in the last 3 days. Is this a manufacturing issue??
    07-27-2013 02:13 PM
  13. theroyboy44's Avatar
    So has anyone else had the problem that when u try to use some of the preloaded backgrounds for the lock screen it wo let u. Like the one that comes pre loaded, I changed it for a while and when I went to change it back it just backs out to the lockscreen options page without giving me the check mark page. Its happened several times and I've had to turn of my phone for over a minute, a soft reset didn't work. Any solutions or at least people to let me know I not alone!?!
    07-27-2013 03:10 PM
  14. theroyboy44's Avatar
    Yup it just happened again and turning off ur phone for at least a minute lets u change to one of the pre installed backgrounds but I shouldn't have to do that!
    07-27-2013 03:12 PM
  15. Boris Hristov's Avatar
    @cashkennedy, have you found the root cause of your problem? I am facing the same...

    Anyone with the antenna problem found a solution already?
    07-27-2013 03:49 PM
  16. theroyboy44's Avatar
    5:20p 100%..............7:51p 42%
    07-27-2013 07:55 PM
  17. sdc1's Avatar
    I had a problem with my 925 this morning.

    I left it charging overnight and when I woke up it was dead, just a black screen. When I pressed the power button there appeared to be a tiny red just beside the camera (proximity sensor) and the top of the phone got very very hot.

    After messing about with various button combos if turned on, I seem to have soft reset it after reading about that on here.

    Worrying.
    07-28-2013 03:36 AM
  18. Snowy Nokia's Avatar
    Anyone notice that for music + video hub when ticking "connect with Xbox music" on it does nothing for my music files. It used to work on my Lumia 810.
    07-28-2013 06:16 AM
  19. luiislp's Avatar
    I got my lumia yesterday and the phone randomly retboot by itself and gets really hot . I changed my connection from lte to 4g and the problem stop. Do you guys think i can replace my phone ? (Tmobile America)
    07-28-2013 04:28 PM
  20. Eric Wu's Avatar
    My phone got really hot during its first charge. But I was also using it at the same time. Since I got it Friday and finally let it fully charge, it doesn't get hot anymore. Of course, now that it's all set up, I'm not using it as often while it's charging.
    Just got my phone this morning. and after half hour playing around, immediately noticed that it gets really hot on the side of the top right corner. I put the phone to my ear and it's hot, not burning hot, but hot and very uncomfortable. also, after the full charge, the phone says I have 9 hours left.

    anyone finds solution to this yet? I am going to hard reset and see that will solve the problem. I got nothing installed yet.
    07-28-2013 11:51 PM
  21. Wyn6's Avatar
    Just got my phone this morning. and after half hour playing around, immediately noticed that it gets really hot on the side of the top right corner. I put the phone to my ear and it's hot, not burning hot, but hot and very uncomfortable. also, after the full charge, the phone says I have 9 hours left.

    anyone finds solution to this yet? I am going to hard reset and see that will solve the problem. I got nothing installed yet.
    People are saying the phone gets really warm. Mine was doing it initially, but seems to heat up a lot less now. I haven't played any intensive games on it... well Ragdoll Run. But, I find it doesn't get too hot after having it almost two weeks.
    07-29-2013 01:44 AM
  22. Wyn6's Avatar
    Anyone notice that for music + video hub when ticking "connect with Xbox music" on it does nothing for my music files. It used to work on my Lumia 810.
    Not completely sure what you mean. But, it seems to work fine for me. All my music is sync'd across all devices (Phone, Surface, Desktop).
    Snowy Nokia likes this.
    07-29-2013 01:47 AM
  23. sdc1's Avatar
    Second morning in a row I've had to soft reset my 925. I left it on charge overnight and woke up to a black screen.

    Should I speak to the network about an exchange?
    07-29-2013 02:49 AM
  24. Snowy Nokia's Avatar
    Not completely sure what you mean. But, it seems to work fine for me. All my music is sync'd across all devices (Phone, Surface, Desktop).
    thanks for the reply.
    When you enter music + video hub go under settings and you will have the option "connect with Xbox music". This will enable pictures and metadata for your music files be shown, like on the lock screen an also artist info.

    It does work on my Lumia 925.
    07-29-2013 02:52 AM
  25. erike3198's Avatar
    I got black Lumia 925 unlocked from Vodafone Germany 32 GB... I noticed from the first moment that the brightness for the touch buttons is very very low compared to 920 and the light is not uniformly distributed over each button... also the color of the light look like yellow/orange/red combination, sorry its hard to describe the color precisely...
    I have a Lumia 920 also and it has much much better brightness even though my 920 button has the yellow tint problem... My 925 button are yellow to orange color... The brightness very very low...

    Another problem the right side of screen a little bit yellow compared to the left side when looking at the keyboard.. Also another issue which known for most Samsung AMOLED screens, if you go to completely dark room and open a black photo on the screen (you can use app called pixel doctor to check) you will notice black annoying dots darker than the rest of the screen... Mine has 7 main dots..

    Is this normal? How yours looks like? Just wondering how many people has these problems...

    UPDATE: I have another problem described below... Blurry text while scrolling....
    Noticed that my lumia 925 has a blurry text while scrolling, specially when scrolling white text over black background or black text over white background... also noticed some blurry when scrolling tiles on the home screen, this blurry occurred around the black horizontal lines separating the tiles.... compared the scrolling with the 920 and there is a huge difference...
    I read that some of the galaxy S4 units has this problem and that this problem related to Samsung AMOLED screens, and you know the lumia 925 has a Samsung AMOLED screen.
    Any one has these issues? let me know in comments please..
    I have a Lumia 1020 and I am experiencing the same issue with blurriness of text.
    07-30-2013 10:39 PM
545 ... 34567 ...

Similar Threads

  1. Pictures taken with your Lumia 900 post em here
    By Dave Blake in forum Nokia Lumia 900
    Replies: 525
    Last Post: 12-28-2013, 07:30 PM
  2. Replies: 3
    Last Post: 11-27-2012, 10:36 AM
  3. How to bake cookies with your Lumia 900
    By HeyCori in forum Nokia Lumia 900
    Replies: 2
    Last Post: 09-26-2012, 06:58 PM
  4. How to take better photos with your Lumia 900
    By FrankieA in forum Nokia Lumia 900
    Replies: 29
    Last Post: 05-17-2012, 01:44 PM
  5. Replies: 8
    Last Post: 04-14-2012, 08:07 PM
LINK TO POST COPIED TO CLIPBOARD