1. lwhitmarsh's Avatar
    I tested two Lumia 925s with two different Surfaces running Windows 8.1 RT and both surfaces were reporting driver problems with the 925s. The surfaces work perfectly with Windows Phone 8Xs and the Lumia 925s are fine on all other Windows 8 computers. Has anyone else run into this problem or know if it's specific to Windows 8.1 RT or both versions of 8.1??
    Thanks
    Last edited by lwhitmarsh; 07-23-2013 at 02:46 PM.
    07-23-2013 02:31 PM
  2. Narse77's Avatar
    If I had a 925 to test with I would. I know the last time I tried my 920 on my Surface RT with 8.1 it worked. It may be that a driver for the 925 has yet to made available for 8.1 on the RT.
    07-23-2013 02:59 PM
  3. lildrgn's Avatar
    Having the same problem. A refresh helped, then stopped. MTP USB error.
    07-24-2013 02:24 PM
  4. lwhitmarsh's Avatar
    Yeah that's the error I'm getting too... I'm assuming they'll have it ironed out by the time 8.1 officially launches, just making sure it wasn't a problem specific to me
    07-24-2013 08:18 PM

Similar Threads

  1. Audio Problem?
    By lolpoliticalparties in forum Nokia Lumia 521
    Replies: 3
    Last Post: 07-23-2013, 04:20 PM
  2. Anyway to play flash videos on the 928
    By flackberry in forum Nokia Lumia 928
    Replies: 4
    Last Post: 07-23-2013, 03:31 PM
  3. Replies: 2
    Last Post: 07-23-2013, 03:30 PM
  4. fixed my 920 battery problem
    By darth_furious in forum Nokia Lumia 920
    Replies: 2
    Last Post: 07-23-2013, 02:04 PM
  5. Replies: 1
    Last Post: 07-23-2013, 01:15 PM
LINK TO POST COPIED TO CLIPBOARD