1. jbailey77's Avatar
    I've been a Windows Phone user since the first Samsung Focus and love the OS. The email management is hands down the best. I've been using the Lumia 920 without issue for about a year now and before that had the 900. I shattered the screen on a recent camping trip so decided to check out what was available and ordered the 925 from ATT.

    At first I thought it would make a fine phone. It didn't strike me quite as much as the first time I opened my Lumia 900, but figured it would do. I got my stuff setup and left for a job. Now I work in some remote places, but the Lumia 920 never let me down - I had a signal anywhere I went except 20 miles offshore once, which is understandable. The first thing that struck me a blow with the 925 was when I neared the job the signal indicator indicated I didn't have any signal at all. WHAT? My coworkers that use blackberry and iPhone had plenty of 4G signal and minimum of one, but were able to make calls. We were working on a tanker that day and I could not get signal until I was up on the bridge wing about 150ft off the ground with a clear view of the sky. I've been in way more remote places than that and had full signal with internet. The next blow was when I relaxing in my master bedroom checking on some email - again zero signal. With my 900 and 920 I'd have 3-4 bars of LTE in the same place. The last straw is here in my office. The phone shows an LTE connect all upper case full signal. Then when I make a call it goes down to 1 bar, drops the call, and I get reports of robot voice. If I walk to my warehouse 50 feet away, again zero signal.

    Needless to say, this is the biggest disappointment from Nokia that I've seen. I'm returning it to ATT Premier and I'm considering going back to my broken 920 until GDR3 is available, I just don't know if I can wait that long and I hate to waste my "upgrade" on a Lumia 920... If I could an android device that could manage email like WP8 I would consider changing, but there isn't anything close.

    Here are some screen shots of my phone before and during a call. This never happened on the 920.
    Attached Thumbnails wp_ss_20130913_0005.jpg   full-signal.png  
    Last edited by jbailey77; 09-13-2013 at 01:56 PM.
    09-13-2013 01:12 PM
  2. jbailey77's Avatar
    I inserted the SIM card into my 920 which I"m going to continue using until I decide on a new phone. Here is a call sitting from the same place.
    Attached Thumbnails full-signal-920.png   during-call-920.jpg  
    09-13-2013 03:06 PM
  3. jbailey77's Avatar
    I had the opportunity to travel back to the same location with the 920 where the 925 was giving me problems. The 920 worked flawlessly the entire time.

    The 925 is a dudd.
    09-17-2013 03:16 PM
  4. jlangner's Avatar
    I would exchange the phone. If still have some result then it is 925 and not just your phone. I have not had any major issues but will say signal is not as good as the HTC 8x I came from.
    09-17-2013 04:22 PM
  5. Enzosurfer's Avatar
    I feel your pain, my experience is the same and my wife's 925 is no better so it's not a case of just getting a bad one.
    09-17-2013 05:04 PM
  6. jbailey77's Avatar
    I finally got some free time and took it to the ATT store. They gave me a replacement and waived the restocking fee since I got the same phone.

    It is working in my office now where the original 925 I received was not working at all. The signal from this location is just like the 920 was - it reports LTE before a call, then drops to 3 bars and fluctuates between 3-5 throughout the call.

    Next test is from my house. Unfortunately, I won't be able to test it from the ship - it sailed.
    09-20-2013 02:31 PM
  7. Jalis_lokong's Avatar
    has anyone gotten the official "bitter sweet shimmer update" it might address these signal issues. Coz I have the same exact problem, with 3G and 2G (No LTE here yet)
    12-02-2013 08:35 AM
  8. Hamberthm's Avatar
    I think it's not a phone problem. You have full LTE signal because a LTE radio station is near your location. But voice-over-LTE is not yet implemented in the US (you can read the LTE article in Wikipedia). When you place a call, the phone rolls back to 3G or even 2G to make it, and you may be having low signal of any of those bands. I would switch the SIM and try another operator (if the terminal is unlocked), or configure it 3G or 2G-only and make a test.

    Goodluck!
    12-02-2013 01:49 PM

Similar Threads

  1. Signal strength ?
    By RapidTurtle in forum Nokia Lumia 928
    Replies: 12
    Last Post: 09-15-2013, 10:49 PM
  2. What do the signal bars actually indicate?
    By awilliams1701 in forum Windows Phone 8
    Replies: 7
    Last Post: 09-13-2013, 01:31 PM
  3. Replies: 2
    Last Post: 09-03-2013, 03:51 PM
  4. Unlocked Ativ S not picking up signal :s
    By saamlee92 in forum Samsung ATIV S
    Replies: 2
    Last Post: 08-23-2013, 05:58 AM
  5. Frequent signal drops
    By Shad0wguy in forum Nokia Lumia 925
    Replies: 4
    Last Post: 08-21-2013, 04:45 PM
LINK TO POST COPIED TO CLIPBOARD