1. Pinchscape's Avatar
    My new 925 is great but ive noticed in the light theme while scrolling the tiles up and down there is a very noticeable blurring or smudging on the edge of the tiles, as if the pixels are not changing colour quick enough.
    Do I have a faulty phone ? Or is it a quirk if the 925 ?

    Thanks
    11-20-2013 09:12 AM
  2. PxuLL's Avatar
    I just tried this on my 820 but I dont have this issue, I suggest taking it into a Nokia Care store near you and show them they will tell ya ;)
    11-20-2013 02:34 PM
  3. Pinchscape's Avatar
    Yes my 625 has no problems.
    I took a trip to carphone warehouse at canary wharf and they had a 925 on display and it had the very same problem.
    It must be a quirk of the phone - rather disappointing
    11-20-2013 02:42 PM
  4. Will6371's Avatar
    Just checked my 925 and nothing. As said above I'd go to a Nokia outlet or try a reset maybe.
    11-21-2013 05:48 PM
  5. Pinchscape's Avatar
    Did you try the light theme with crimson tiles ? maybe its that combination ?
    Thanks for your help :)
    11-23-2013 01:17 PM
  6. Pinchscape's Avatar
    OK the plot thickens

    Ive sent the phone back to Nokia, but they say the display is working normally.
    I went to a mobile phone shop and had a look at the 925 and the 1020 they had.
    I put them both on the light theme with crimson tiles and they both had the same problem - i.e. when scrolling on the start screen quickly the colour of the edges of the tile 'bleed' onto the white background, presumably because the pixels cant react fast enough to the colour change - almost like the tiles are trying to join together.

    To me it looks quite bad, and not a theme configuration I would want to show the phone off with.

    My 625 and my 520 are fine, but then again they have a lower density screen based on a different technology (as far as Im aware).

    This really suprises me, and it suprises me that I cant find any other mention of this issue on google. Perhaps the light theme isnt very popular for general use, and no-one has seen the issue. It's made me a little dissapointed in the phone, and Im going to have a proper look at the 1520 in the flesh befor I buy it, and if it has the same problem I might wait to have a look at the 1320.

    Does anyone have any experience of this issue. Ultimately I could be completely mad and ready for the loony farm - I havent totally ruled that out as a possibility.
    11-28-2013 06:53 AM
  7. Will6371's Avatar
    Okay I might have to change what I said previously about this, I have now tried it with the crimson colour and a few others and there is a bit if you move the tiles up and down at speed but it's not with any other colours except for a small bit with orange.

    On a plus point for me as least is that I can't stand either the light theme or crimson.
    11-28-2013 07:09 PM
  8. Pinchscape's Avatar
    Ahhhhhh, thank you very much for confirming what im seeing. No wonder Nokia found no fault with the phone - its obviously a known issue with the display. Unfortunately i have a minor problem with my sight which means the very bright screens work well for me (light theme - high brightness level), and crimson is the colour with the best contrasts.
    Oh well, i guess ill just have to live with it. - thanks again
    11-29-2013 12:47 AM

Similar Threads

  1. Cool Tiles app needs more icons
    By des920 in forum Applications
    Replies: 2
    Last Post: 02-10-2014, 04:46 AM
  2. Numpad flicker when typing password in Lock screen
    By Pitchayatak Ponrod in forum Windows Phone 8
    Replies: 1
    Last Post: 12-23-2013, 12:33 PM
  3. Replies: 10
    Last Post: 12-17-2013, 10:01 PM
  4. Replies: 1
    Last Post: 11-19-2013, 10:10 PM
  5. Great tip to show more tiles/apps on the Surface 2 screen
    By BaritoneGuy in forum Microsoft Surface 2
    Replies: 3
    Last Post: 11-19-2013, 05:17 PM
LINK TO POST COPIED TO CLIPBOARD