1. Peter Sketch's Avatar
    Hi

    I wonder if anyone can help me. I'm trying to debrand my O2 925. I've downloaded the firmware no problems, load up NCS, go into recovery mode, press Start, wait for the "press the buttons" message, put the phone into (I think) the right mode (with a cog and a lightning bolt), plug it into the USB (which gives me a windrv usb device), hit retry, and nothing happens - i.e. it just fails to see the phone - no errors, just behaves the same as if no phone was plugged in. I can keep hitting retry, but no joy.

    Anyone got any ideas. First question would be - does the process work in Win 64 - I've tried Win7 and Win 8.1, but both 64 bit. Any other pointers gratefully received so I can get 4G going.

    ta

    pete S
    01-18-2014 02:36 PM
  2. Nabkawe5's Avatar
    My advice is to use a different USB port or another PC all together.
    01-18-2014 04:01 PM

Similar Threads

  1. Can someone help me find apps?
    By maclancer in forum Windows Phone 8
    Replies: 28
    Last Post: 01-31-2014, 10:52 PM
  2. How do you connect Storyteller to the Lumia 1020?
    By Campater in forum Nokia Lumia 2520
    Replies: 5
    Last Post: 01-26-2014, 10:45 AM
  3. cant logon to facebook on app or explore
    By SimonWurtz in forum Microsoft Surface for Windows RT
    Replies: 10
    Last Post: 01-19-2014, 11:51 AM
  4. Virtual wallet service, Mobikwik updated to allow cash payment
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-18-2014, 02:10 PM
  5. Replies: 2
    Last Post: 01-18-2014, 02:09 PM
LINK TO POST COPIED TO CLIPBOARD