1. Wayne Rock's Avatar
    Hi Community,

    Some background:

    I got my Nokia Lumia 925 from AT&T, but I live in Trinidad. While the phone was in the US, it connected to wifi, installed updates etc. When the phone was brought to Trinidad, it no longer discovers wifi networks. It just says "searching" and stays there.

    I've tried in multiple areas and made adjustments to my modem and router but nothing seems to work. When I switch on the wifi and it begins "searching" no available networks show up and I can't even switch the wifi off. It's like the slide is stuck.

    Can anyone assist with this or give some suggestions on what to do?

    Regards,

    Wayne
    04-03-2014 10:12 AM
  2. N_LaRUE's Avatar
    Have you changed the region of your phone to Trinidad?

    Settings -> language + region
    04-03-2014 10:15 AM
  3. Wayne Rock's Avatar
    Yes I have. I've actually tried several things so far. I did a factory reset, I tried using mobile data (this doesn't work either). Otherwise the phone works normally.
    04-03-2014 10:20 AM
  4. Wayne Rock's Avatar
    Bump
    04-03-2014 03:14 PM
  5. doubleyewpee's Avatar
    Same exact issue except I'm in the US with a phone bought brand new from the carrier store.

    My phones stays on the Wi-fi searching status forever with blue dots going across the top of the screen. I tried:

    1) hard reset multiple times
    2) soft reset multiple times
    3) toggling airplane mode
    4) toggling this and that etc

    I saw other threads of people experiencing the same issue yet nobody was ever able to provide an actual solution. I find it ironic I am forced to download phone updates over wi-fi yet I can't connect to wifi. About to just get rid of this phone, had it up to here between the constant battery issues (16% discharge per hour LOL), phone overheating, and now this.
    04-20-2014 08:32 PM
  6. tonmo's Avatar
    I have the same exact problem. I left the country on vacation, like the original poster. I never had issues with wifi, and it worked fine there for a while. Somewhere along the way, it stopped working.

    I'm back in the US now, and have been troubleshooting all day. Did a factory reset, and on a Developer's account so I could try to update to 8.1, to see if that would help.

    No wifi, no bluetooth. I'm more interested in getting wifi going. The 5 blue dots just stream on the page but I never see available networks and the wifi icon never appears across the top.

    I have rebooted about 20 or more times today... on 2 occasions I got wifi to work for a bit.

    Of course, I can only update so far, because the 8.1 update can only be installed when your phone is connected to wifi.
    06-29-2014 06:53 PM
  7. Jose Velasquez2's Avatar
    Ok i been having same problem and this is what i did to fix it. i went and turned off the wifi on my phone, turned off location and turned off wifi sense...i then i went to settings/language and changed it to any other English language .. then i changed it back to English USA.. at the bottom it says restart... i restarted the phone. turned on location, wifi and there they were both my 5GHz and my 2.4GHz... i went in and put my password on both and switched back to 2.4 and its been working all day so far.. will see if it still working tomorrow. hope this helps.
    02-28-2015 03:48 PM
  8. unco's Avatar
    Hi All,

    I just bought lumia 925 and installed all updates. I connected wifi and installed all app. Now when I'm using shared wifi from another lumia I can able to connect whatsapp or skype but other apps (facebook, iexplorer, google.com ) can't connect to internet. Can anybody help?
    03-24-2015 06:31 PM
  9. Azlan Tahir's Avatar
    I have a problem with my Lumia 925, i've had it for a couple of years now and have used it in europe, us and china with no problems. As of last week, my phones wifi has been unable to detect my office wifi. All other wifi's are detected except my office's, none of my co-workers have this issue. Also I have no issues to connect with my other favourite wifi's. I have tried multiple soft resets, changing regions..etc..please assist.
    04-05-2015 10:36 PM

Similar Threads

  1. Lumia 630 Specifications
    By hopmedic in forum Nokia Lumia 630
    Replies: 14
    Last Post: 05-30-2015, 06:19 PM
  2. Opinions-Is Nokia 930 a worthy successor to the Lumia 920
    By Sayyid Shoaib in forum Nokia Lumia 920
    Replies: 30
    Last Post: 04-05-2014, 05:21 AM
  3. Type cover 2 not working with Surface RT
    By bills pies in forum Microsoft Surface for Windows RT
    Replies: 3
    Last Post: 04-03-2014, 02:17 PM
  4. is lumia 930 coming to att?
    By surfacedude in forum Nokia Lumia 930
    Replies: 4
    Last Post: 04-03-2014, 01:52 PM
  5. New to Lumia 625
    By hooded claw in forum Nokia Lumia 625
    Replies: 6
    Last Post: 04-03-2014, 06:47 AM
LINK TO POST COPIED TO CLIPBOARD