1. Naveed Siddiqui's Avatar
    Hi,

    i just got a lumia 925 last week and still trying to get a hang of it (after quite a fair bit of android use). a problem i noticed is that HERE Maps is not showing my correct location. two days back when i pressed the green location finder dot, it threw me a good 5 miles away from my current location. yesterday it brought me to about 0.2 miles from where i was. this is not only happening at home but also at work - i can see myself two building away from where i am suppose to be.

    my wife has a 720 and i never had this problem on that phone. but i just checked the maps on that device and surprisingly it has the same issue ( i swear it worked great a while back) so now i am thinking of whats common between the two devices: the Black update. i updated my phone two days back (hadnt checked maps before that) and hers was updated about a month back (havent used maps on it for a while)

    some of the stuff i did to try to resolve the issue:
    > restarted (no joy)
    > reinstalled maps (at startup, it suddenly showed the correct location, but then after a few taps on the green dot it lost its bearings again. closing the app and reopening it didnt help either. its still showing me a few buildings away. used to be super accurate)

    i wonder if someone else has faced this issue as well? i dont want to do any factory hard/soft resets (i just got the phone last saturday !!) and i can figure its not a hardware issue cus both phones are exhibiting the same behaviour. so...what could it be? any ideas?

    thanks
    04-10-2014 04:51 AM
  2. Himanshu Chowdhary's Avatar
    It looks like your area had a bad signal reception , try using the same in an open area , not inside a building (since walls interrupt GPS signals )
    04-10-2014 05:29 AM
  3. N_LaRUE's Avatar
    If your phone is connected to WiFi and are indoors you may not get an accurate location as the phone defaults to A-GPS setting. Also any interference can cause issues as well.

    If you're on mobile data then that's a different story. You can also try turning off data and see what happens. Be sure to be in an outside open area. The GPS may take some time to find you.

    I would suggest the following options if you still have issues:

    1) When there is connectivity issues some people have found that turning on Airplane mode and restarting the phone and then switching off Airplane mode sometimes works.

    2) Remove the app, do a soft reset -> hold volume down and power together until phone vibrates. Phone will restart. No files are deleted. You may need to reset time and date. Install app and see if it still plays up.

    3) Do a hard reset. No idea why people get uptight about this. Ensure you backup beforehand and unless you racked up some major gaming I wouldn't worry too much. The reset works fine.

    If things go wrong with the hard reset you can always use this software: http://forums.windowscentral.com/win...very-tool.html
    Naveed Siddiqui likes this.
    04-10-2014 05:32 AM
  4. Naveed Siddiqui's Avatar
    Hi Himanshu,

    thanks for the advice. i dont think its a reception issue (i might have at home cus there is renovation happening in the apartment building so there might be interferences, but my office is the SIM provider's HQ where everyone's maps are working absolutely fine [at least on android and iphone])

    in any case, i hear what you and n_laRue are saying, will check the reception outdoors and then try to do a reset to see if it works or not.
    Himanshu Chowdhary likes this.
    04-10-2014 06:00 AM
  5. kingenu's Avatar
    how good is your network signal?
    is your location on?
    04-10-2014 06:37 AM
  6. Naveed Siddiqui's Avatar
    Hi,

    it seems the following steps have somewhat resolved the issue (will still keep an eye open for a few days)
    > turned off mobile data (as you suggested)
    > set highest available network setting to 3g (was 4g by default)
    > opened HERE map and it showed me the correct position. did this four times and each time the result was correct. the fourth time it went off but then jumped back after a few minutes (i stepped out into the balcony)

    like i said, im hoping this was all that was needed. but if it happens again then i'll follow all the other steps you mentioned N_Larue. thanks!

    If your phone is connected to WiFi and are indoors you may not get an accurate location as the phone defaults to A-GPS setting. Also any interference can cause issues as well.

    If you're on mobile data then that's a different story. You can also try turning off data and see what happens. Be sure to be in an outside open area. The GPS may take some time to find you.

    I would suggest the following options if you still have issues:

    1) When there is connectivity issues some people have found that turning on Airplane mode and restarting the phone and then switching off Airplane mode sometimes works.

    2) Remove the app, do a soft reset -> hold volume down and power together until phone vibrates. Phone will restart. No files are deleted. You may need to reset time and date. Install app and see if it still plays up.

    3) Do a hard reset. No idea why people get uptight about this. Ensure you backup beforehand and unless you racked up some major gaming I wouldn't worry too much. The reset works fine.

    If things go wrong with the hard reset you can always use this software: http://forums.windowscentral.com/win...very-tool.html
    04-10-2014 01:16 PM

Similar Threads

  1. Waze or here drive? Which is better?
    By Darth Plagueis in forum Applications
    Replies: 12
    Last Post: 04-15-2014, 05:53 AM
  2. Here city lens
    By kingenu in forum Applications
    Replies: 2
    Last Post: 04-10-2014, 03:43 AM
  3. Music in Windows Phone Store gone
    By AndrewL920 in forum Windows Phone 8
    Replies: 27
    Last Post: 04-09-2014, 07:51 PM
  4. Music in Windows Phone Store gone
    By AndrewL920 in forum Nokia Lumia 920
    Replies: 2
    Last Post: 04-09-2014, 05:40 PM
  5. Official ZEDGE doesn't work India? Here is a fix!
    By DBZo07 in forum The "Off Topic" Lounge
    Replies: 0
    Last Post: 04-09-2014, 12:06 AM
LINK TO POST COPIED TO CLIPBOARD