1. Inferati's Avatar
    Well, here is the thing; I have a Lumia 925 lately it's been giving me problems though the audio jack keeps "unplugging" it's not actually unplugged but my music keeps stopping as if it was unplugged and to actually get it going again I have to unplug it and plug it back in. The problem doesn't happen when I'm just moving a lot, it'll just randomly stop. Does this mean it's dying? Possibly covered under warranty? Anyone had any issues with this? If they fix it, how long does it take? It's my only phone so if it takes to long I'm just letting it go and dumping the phone as soon as I can get a better one as I don't feel like waiting a month for a phone I'm upgrading September.
    prebuss likes this.
    05-13-2014 07:43 AM
  2. someonecalledsukhjit's Avatar
    yes it is covered under warranty. I'd suggest you go to center asap if you are under warranty!
    05-14-2014 10:44 AM
  3. Inferati's Avatar
    Contacted Nokia and T Mobile, both will repair the phone for me. T-Mobile actually just said f*ck it, well exchange the phone. While Nokia told me that they'll check if it can be repaired first. So who should I go with? Straight with Nokia or let T-Mobile prove their worth? Anyone has done both? Could use some advice lol. Sadly neither said they could provide a loaner phone so I'd be stuck with no phone whatsoever.
    05-14-2014 06:38 PM
  4. metalchick719's Avatar
    Maybe you should grab a 521 as a backup until you get your 925 back?
    05-14-2014 07:03 PM
  5. itsall4tay's Avatar
    I replaced mine, not difficult at all. Cost $8. Working very well.
    05-14-2014 09:02 PM
  6. Inferati's Avatar
    I replaced mine, not difficult at all. Cost $8. Working very well.
    How lol? As for buying another phone, I'd really rather not. They're cheap but they still cost something lol
    05-14-2014 09:38 PM
  7. prebuss's Avatar
    Oh wow, I actually have the same problem with my 925. Been looking if anyone had this problem on google, couldn't find anything, and boom, with a such a coincidence found this thread.

    Actually I'm thinking my problem is slightly different. When I plug in any headphones it plays fine, but when I barely touch the jack I can feel a slight movement inside of the phone and I'm guessing the phone interprets that movement as a headset removal. And whenever I try to listen to music, I always end up by pressing play button over and over again.
    And the weirdest thing is that, I don't know if that was a coincidence too, but had exactly same problem on my Nokia N85 lol... So I'm guessing, I do not know how to keep it safe :(

    Anyway, I have contacted my local phone store and they said if it's the problem with an audio jack, it will cost me like up to $30 to replace it, and that's what I am really going to do since I really love my 925 :)
    05-16-2014 12:08 AM
  8. Inferati's Avatar
    Doesn't sound expensive at all. Pisses me off the this has happened either way considering that this phone is less than 4 months old.
    05-16-2014 05:49 PM
  9. Inferati's Avatar
    Well I went with Nokia Warranty, I'd rather get the problem fixed than get a refurbished with more problems and perhaps with scratches. My phone is basically perfect cosmetically and I'd rather not risk it. Will describe my experience after I send the phone.
    05-20-2014 07:02 PM
  10. prebuss's Avatar
    Well I went with Nokia Warranty, I'd rather get the problem fixed than get a refurbished with more problems and perhaps with scratches. My phone is basically perfect cosmetically and I'd rather not risk it. Will describe my experience after I send the phone.
    I'd love to hear how did it go as I am planning to go for the same reason to Nokia center soon!

    Thanks!
    05-21-2014 12:47 AM
  11. Shoubhik Banerjee's Avatar
    I encountered and unusual problem with my Lumia 925 after the 8.1 preview update. At times one side of my earphone just goes blank, usually the right side. Seems like a glitch that fails to deliver the audio to the right channel.. Because all i need to do is a restart and it starts working fine again.. Didn't happen earlier in win 8 version.. So i am guessing it's not a hardware issue for me..any suggestions?
    05-24-2014 04:15 PM
  12. Inferati's Avatar
    This happened to me a few times as well. All I did was restart as well. I'm guessing it should get fixed with the Nokia firmware update. Since I'm getting the audio jack fixed ill test it and let you know if it continues happening after I receive it. That should tell us if its a hardware issue or a software issue for sure.
    05-24-2014 04:22 PM
  13. lbp775's Avatar
    This same thing happened to my brother too with the initial update to 8.1. The issue went away after performing the latest update.
    05-25-2014 09:57 AM
  14. metalchick719's Avatar
    I have a question... Has anyone noticed the sound from one of their earphones on the 925 not working or not working when they're plugged fully in? This afternoon, I went out for a walk and planned on listening to Nokia MixRadio. I grabbed my still new Panasonic earphones, but sound was only coming out of the left side. I noticed that when I pulled them slightly out of the headphone jack, the sound came out of the right side. I ended up rebooting the phone and then the sound was 100% normal. That was quite odd as I never experienced this with ANY of my phones before.
    05-25-2014 09:12 PM
  15. cad1217's Avatar
    I also have this same problem since downloading 8.1. It occurs when I'm listening to music with headphones, I get a phone call, after the call the phone loses the right speaker. Sometimes it happens when I don't even take the call, when the phone is finished ringing goes to left ear only. Everytime when I plug my phone into my car or work vehicle, as soon as I get a phone call while listening to a podcast, when the call is done it goes to left speakers in the vehicle only. I have to restart my phone to fix it, very annoying. Happens almost daily, not good. Lumia 925.
    05-28-2014 06:29 PM
  16. metalchick719's Avatar
    I also have this same problem since downloading 8.1. It occurs when I'm listening to music with headphones, I get a phone call, after the call the phone loses the right speaker. Sometimes it happens when I don't even take the call, when the phone is finished ringing goes to left ear only. Everytime when I plug my phone into my car or work vehicle, as soon as I get a phone call while listening to a podcast, when the call is done it goes to left speakers in the vehicle only. I have to restart my phone to fix it, very annoying. Happens almost daily, not good. Lumia 925.
    Oddly, my issue happened when I was still running WP8 on my 925. I updated to 8.1 on Monday evening and haven't had the headphone jack problem so far.
    05-28-2014 06:50 PM
  17. Inferati's Avatar
    Here with a promised update. So its been 8 total days since I've shipped the phone. Yesterday, Nokia shipped it out through UPS Overnight Air. Keep in mind they say turnaround time is 7-10 business days so I'm happy they manage in 8 normal days or to be exact 5 business days. Once my phone arrives, I will inform you all of the repair which was done and if its any good.
    06-03-2014 06:30 AM
  18. Inferati's Avatar
    Phone arrived last night. They reverted my software back from 8.1 to 8 but that was easily fixed after 2 hours or so updating the phone. The audio jack is working tip top shape once again. They left my screen protector on and did not damage my phone in any way :) Overall really satisfied with it. Now with the sound going out on the right channel sometimes on 8.1 it still happens but I've noticed its when fast forwarding through videos. That sums up my experience with Nokia Warranty Service.
    06-04-2014 09:45 AM
  19. HungNe's Avatar
    I encountered and unusual problem with my Lumia 925 after the 8.1 preview update. At times one side of my earphone just goes blank, usually the right side. Seems like a glitch that fails to deliver the audio to the right channel.. Because all i need to do is a restart and it starts working fine again.. Didn't happen earlier in win 8 version.. So i am guessing it's not a hardware issue for me..any suggestions?
    It works nice. Seems this is os issue.
    06-04-2014 10:14 AM

Similar Threads

  1. Is the wait to long?
    By Fade_z in forum Nokia Lumia 930
    Replies: 30
    Last Post: 06-05-2014, 12:03 AM
  2. Replies: 5
    Last Post: 06-03-2014, 02:26 PM
  3. When is Green comin out?
    By nyjets12 in forum Nokia Lumia 1520
    Replies: 13
    Last Post: 05-23-2014, 10:42 AM
  4. What is a good Nokia Lumia Icon Screen Protector?
    By vepac in forum Nokia Lumia Icon
    Replies: 12
    Last Post: 05-23-2014, 07:41 AM
  5. Replies: 8
    Last Post: 05-13-2014, 01:28 PM
LINK TO POST COPIED TO CLIPBOARD