1. maggotbeer's Avatar
    Greetings to everyone!

    I just bought a new Lumia 925 and I'm extremely disappointed.

    After the initial setup I used the phone for 3-4 minutes and it started freezing.

    To cut a long story short, I did a hard reset, I downloaded Nokia Software Recovery Tool and installed all the updates but the phone either freezes or restarts while booting and then freezes.

    Does that mean that there is a hardware problem?

    I don't know if it helps but after installing the software version 3051.40000.1351.2004, Nokia Software Recovery Tool keeps asking me if I want to install the same software version again. It doesn't say that software is up to date or anything like that. I've already done that 3 times just in case there are minor differences in the software.

    Is there anything I can do before I return the phone?

    Thank you in advance!
    06-30-2014 10:03 AM
  2. Laura Knotek's Avatar
    It is not normal for a brand new device to crash immediately after setup.

    I would recommend returning it for a replacement.
    Guytronic and xandros9 like this.
    06-30-2014 10:10 AM
  3. oviedofreak82's Avatar
    Is your phone brand new our of the box or is it a refurbished phone? Very unusual to see that. I know when I bought my L925 back in April, it was brand new and I had to do several updates, such as upgrading to Lumia Black since mine was running on Amber.
    06-30-2014 10:18 AM
  4. maggotbeer's Avatar
    Is your phone brand new our of the box or is it a refurbished phone? Very unusual to see that. I know when I bought my L925 back in April, it was brand new and I had to do several updates, such as upgrading to Lumia Black since mine was running on Amber.
    It is a brand new phone. =(

    Is it normal that Nokia Software Recovery keeps telling me to install the same software version? Is that the latest one? Shouldn't it be telling me that the phone is up to date?

    I keep my hopes up that it might be a software problem because it never freezes during the updates, wouldn't that have happened at least once if it was a hardware problem?
    06-30-2014 10:24 AM
  5. maggotbeer's Avatar
    One more thing that I find strange is that in the beginning, when I completed the setup process and before it started crashing, I was able to sign in to twitter and use it normally but the phone couldn't search for software updates because "there was no network connection".
    06-30-2014 10:33 AM
  6. oviedofreak82's Avatar
    I know that this may sound off, but make sure your time and date settings are correct. I've seen in Surface tablets and some Windows phones that if the date of wrong, it can cause it to act strange.
    06-30-2014 11:25 AM
  7. maggotbeer's Avatar
    I know that this may sound off, but make sure your time and date settings are correct. I've seen in Surface tablets and some Windows phones that if the date of wrong, it can cause it to act strange.
    well you were right! I'm not sure what exactly happened but the phone seems to work OK for the last 15 minutes and I was able to go and check the time and date settings and they were completely wrong (I had to do the setup process quite a few times today and I must have messed up something along the way). That fixed the login errors!

    Now I'm waiting for the battery to fully discharge and charge it again before I do anything else. If it starts crashing again I will return the phone tomorrow. If it does not, I will update this thread in case someone else has the same problem.

    Thanks a lot!
    06-30-2014 11:43 AM
  8. amit_nb's Avatar
    Get a replacement immediately. I'd similar issues with mine (in India). Got it replaced. Now, it's running smooth.
    06-30-2014 12:51 PM
  9. maggotbeer's Avatar
    Get a replacement immediately. I'd similar issues with mine (in India). Got it replaced. Now, it's running smooth.
    yeah I believe that's what I'll do, I'll probably return it tomorrow.

    It's just the phone's strange behaviour that makes me curious as to what's wrong with it. I think it has a defective battery, from the moment that it went down to about 15% the phone started working perfectly. I let it completely discharge and now that it's more than 15% it starts crashing again!

    I'll try to completely discharge it and then fully charge it without using it in the meantime, but I doubt that it will have any effect.
    06-30-2014 01:17 PM
  10. Carl Erics's Avatar
    monday phone ;)
    got my 925 a week ago and its been working flawlessly, updated it to 8.1 immediately naturally, but no freezing's or hangups in anything
    maggotbeer likes this.
    07-04-2014 03:03 AM
  11. maggotbeer's Avatar
    I had my 925 replaced with a new one and it's working great so far!

    I'm really satisfied with this phone, apart from its battery which is mediocre but perhaps the 8.1 DP is to blame for that.

    I prefer my galaxy s4 as an overall experience but the 925 is a lot more fun to use!
    07-04-2014 07:36 AM

Similar Threads

  1. Nokia Lumia 920 crashed-Microsoft Account not working
    By karlkelvinarcilla in forum Nokia Lumia 920
    Replies: 9
    Last Post: 07-01-2014, 07:50 PM
  2. New rumors of Windows 9 "Threshold" could please desktop PC users
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-30-2014, 10:00 AM
  3. Lumia 930 delayed in Russian until July 7, app voucher offered
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-30-2014, 09:30 AM
  4. Barclays continues to show Windows Phone support with official Pingit app
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-30-2014, 09:00 AM
LINK TO POST COPIED TO CLIPBOARD