1. benny142's Avatar
    Hi all.. Anyone facing this issue... I am having this issue since 2 weeks... all of a sudden.. my L925 loses its network... No service is displayed.. and it fails to detect the network until restart... tried soft restart.. Issue is still there post cyan update...!
    07-17-2014 12:39 PM
  2. Aniket Mhatre's Avatar
    Yea even i am facing this issue
    Sent from Lumia 925 India using tapatalk
    07-17-2014 12:40 PM
  3. benny142's Avatar
    ur carrier?? r u using BSNL??? lot of service complaints against BSNL lately.. I was hoping it got something to do with carrier network..
    07-17-2014 12:43 PM
  4. Aniket Mhatre's Avatar
    I am using Vodafone
    Sent from Lumia 925 India using tapatalk
    07-17-2014 12:56 PM
  5. benny142's Avatar
    so carrier can be ruled out... Will have to try hard rest then..... Did you try a hard reset after this issue? Since when you started facing this? its since the last 2 weeks for me... strange..!
    07-17-2014 01:00 PM
  6. Darth Lumia's Avatar
    I have the same issue here in the states using a L925 on T-Mobile

    Posted via Windows Phone Central App
    07-17-2014 07:46 PM
  7. Aniket Mhatre's Avatar
    so carrier can be ruled out... Will have to try hard rest then..... Did you try a hard reset after this issue? Since when you started facing this? its since the last 2 weeks for me... strange..!

    Hard reset didn't solve it. Facing it from more then 2-3 weeks
    07-18-2014 01:58 AM
  8. eryvile's Avatar
    Hi all.. Anyone facing this issue... I am having this issue since 2 weeks... all of a sudden.. my L925 loses its network... No service is displayed.. and it fails to detect the network until restart... tried soft restart.. Issue is still there post cyan update...!
    Same here, Lumia 925 on Congstar (= T-Mobile Germany). Hope, they fix it soon, as missing calls without knowing it is not a feature I'm longing for :(
    07-19-2014 03:04 AM
  9. benny142's Avatar
    this issue started all of a sudden.. DP have been working flawlessly for me... and just before 3 weeks.. n/w connection started to cut off.. I'm sure.. there was no updates 3 weeks before.. neither any of the settings.. nor OS related updates.. no idea.. what started causing this issue.. :(
    07-19-2014 09:13 AM
  10. Microsoftjunkie's Avatar
    I had the same problem with my 1520. My 925 hasn't done it yet. I believe it has to do with wifi-sense. What worked for me was to switch air plane mode on and off, then connect.
    07-19-2014 09:18 AM
  11. benny142's Avatar
    i had tried airplane mode on/off couple of times.. but it didnt help.. Not sure about wifi-sense though.. i havent used that feature yet.. so got no idea about it...! the isuue is pretty annoying.. since i'm completly cut off at work now.. acts like a n/w jammer is installed near my workstation.. :p
    07-19-2014 12:25 PM

Similar Threads

  1. Unable to download any Apps on my Surface RT...
    By SoullessOnyx in forum Microsoft Surface for Windows RT
    Replies: 6
    Last Post: 07-19-2014, 11:00 AM
  2. No internet connection
    By vishnujithas in forum Windows Phone 8.1
    Replies: 4
    Last Post: 07-18-2014, 02:28 PM
  3. No internet connection
    By vishnujithas in forum Nokia Lumia 925
    Replies: 13
    Last Post: 07-18-2014, 09:14 AM
  4. OneDrive users with grandfathered 25GB of free space get to keep it
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-17-2014, 11:11 AM
  5. not able to record voice in watsapp
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 07-17-2014, 10:47 AM
LINK TO POST COPIED TO CLIPBOARD