1. 10curtains's Avatar
    Please what have I done? My 925 updated today with o2 in uk. It's up to date. I have no sound, when I call someone speaker comes on and won't go off. No one can hear me and I can't hear them.
    I can't get music as app won't open.

    I have reset phone several times still no joy.

    Help.
    07-18-2014 10:50 AM
  2. Ashish Gupta888's Avatar
    You probably need a hard reset.
    10curtains likes this.
    07-18-2014 11:04 AM
  3. 10curtains's Avatar
    That was next step had to put sim in lumia 800.
    Need to wait until later.
    Thanks
    07-18-2014 01:50 PM
  4. Conan143's Avatar
    Please what have I done? My 925 updated today with o2 in uk. It's up to date. I have no sound, when I call someone speaker comes on and won't go off. No one can hear me and I can't hear them.
    I can't get music as app won't open.

    I have reset phone several times still no joy.

    Help.
    Try soft reset and if the problem still persists do hard reset..Here is how u can do soft reset and hard reset (if u know how to do then ignore this message)
    Soft reset is pretty simple, all you need to do is to press and hold the volume down button and the home button, together for almost 10 sec. After some time, you might see your phone vibrating and see the booting screen once again.It doesnt need any backup to be done...

    Hard reset is handy if the phone is completely unresponsive.It needs backup if u want to restore your phone and doesn't want to start afresh..
    You can also do hard reset by opening the Settings-> About-> Reset your phone (or)
    You can perform this by pressing the volume down + power + camera buttons together until the phone vibrates, then release the power button only and hold the other buttons down for another five seconds or so, then release all the buttons.

    Hope this solves your problem...
    10curtains likes this.
    07-18-2014 11:10 PM
  5. 10curtains's Avatar
    I put sim back in phone when I got home. Phone working as it should . I can't believe it, I had done a couple of soft resets and still had no sound or mic. I switched phone off removed sim to put in Lumia 800 , switched phone back on tried music and the app opened this time and allowed me to play music.
    Put sim back in, fingers crossed still working. Now to play with the new features.
    07-19-2014 01:19 AM
  6. Conan143's Avatar
    I put sim back in phone when I got home. Phone working as it should . I can't believe it, I had done a couple of soft resets and still had no sound or mic. I switched phone off removed sim to put in Lumia 800 , switched phone back on tried music and the app opened this time and allowed me to play music.
    Put sim back in, fingers crossed still working. Now to play with the new features.
    That's good to hear...
    07-19-2014 01:22 AM

Similar Threads

  1. Are you going to go back to WP8 to get the Cyan update?
    By Anastazja Michniewicz in forum Windows Phone 8.1
    Replies: 32
    Last Post: 07-22-2014, 07:01 PM
  2. Replies: 3
    Last Post: 07-22-2014, 08:53 AM
  3. Can't access phone from PC. Help!
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 07-19-2014, 05:39 AM
  4. Can't forward Emails in W7?
    By Plimbob in forum Nokia Lumia 900
    Replies: 0
    Last Post: 07-18-2014, 10:25 AM
  5. Xbox One update 1408 preview starts rolling out with cool new features
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-18-2014, 09:00 AM
LINK TO POST COPIED TO CLIPBOARD