1. rstar66's Avatar
    Hey all, this might be long, but bear with me! IF you have a lumia 925 and are experiencing/have experienced battery issues, please read!

    Just bought a new lumia 925 earlier this month. Everything seems alright except that the battery charges REALLY REALLY slow. I am not sure if this is normal but its around 16-18% per hour (according to the Battery App By Arthur Semenov).

    It charges at this rate whether i use a wall charger or a USB. This is my first windows phone and my latest nokia. I thought it was bad enough, but whats worse is that with the 8.1 update if i charge the phone while using it (say, whatsapp and wifi), the phone doesn't even increase any charge. In fact, it loses. I came home yesterday back from work and charged my phone from 0, since the battery had died on the way. Funny thing is, past the LONG wait of the flashing windows icon, and the battery symbol that took at least ten minutes, the phone had barely 5% charge. I used it at the 5% to reply to a few whatsapp texts, and the phone dies on me WHILE STILL CONNECTED TO THE CHARGER! i had to endure another ten minutes wait for it to restart and charge to about 10% before commencing using.

    IS THIS NORMAL. I haven't come across a phone that dies on you WHILE connected to a wall socket!

    I can post screenshots if interested.

    any help?
    07-19-2014 02:56 PM
  2. David P2's Avatar
    Entirely possible if the cable is a load of ****. Are you using the original cable? If you are then it's possible there's possibly a break somewhere inside the cable which would cause the issue.
    rstar66 likes this.
    07-19-2014 03:35 PM
  3. rstar66's Avatar
    Thanks for your reply.. I'm using the same one that came in the box. It's a 3 pin with USB. I used to use a USB extension but even without that it seems to be the same.
    I located my old nokia charger that I used for my previous phone that's also a 3 pin (but no USB slot, jst a direct micro USB instead), and am charging now. Just saw it charge from 69%-85% in about 15-20 minutes. I just uninstalled and reinstated the battery app and also installed a second one to check.

    This charger seems to be much much faster.
    07-20-2014 05:05 AM
  4. David P2's Avatar
    Try charging the phone with your USB cable from a PC. If that works fine then it's the original power adapter at fault. But personally I would keep that older charger (the non USB cable type one but still has micro-USB) plugged in at home, then you can just take the USB cable for charging when attached to PCs or something. Providing it still works of course.

    Ultimately though, if the other charger works fine then just keep using that - no need to fork out for a new adapter.
    07-20-2014 05:36 AM

Similar Threads

  1. No Lumia 930 on Nokia's India page!!
    By Deepak in forum Ask a Question
    Replies: 5
    Last Post: 10-02-2014, 08:02 AM
  2. Twitter not showing on contacts cards after hard reset.
    By Darren Kent 79 in forum Windows Phone 8.1 Preview for Developers
    Replies: 7
    Last Post: 08-25-2014, 01:58 AM
  3. Nokia lumia 1520 (1520.3) on AT&T hotspot not working
    By Tkukucka in forum Nokia Lumia 1520
    Replies: 7
    Last Post: 07-19-2014, 06:59 PM
  4. nokia lumia 520
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 07-19-2014, 04:11 PM
  5. Lumia 720
    By gobi2510 in forum Nokia Lumia 720
    Replies: 1
    Last Post: 07-19-2014, 02:39 PM
LINK TO POST COPIED TO CLIPBOARD