1. kmmcdonald's Avatar
    Previously, on my T-Mobile Lumia 925 with 8.0, I still had at least 50% charge remaining at the end of a typical day. Today, after having loaded 8.1 yesterday, my phone was down to less than 25% by noon, and after charging it to 50%, it is now down to 22% after about 7 hours.

    In examining the Battery Saver app, I discovered that Internet Explorer is using many times the power as any other app. Even though I have background operation for IE turned off, the Battery Saver "app in background" bar is still at about 50%. My wife's phone, which is identical to mine, who upgraded to 8.1 at the same time, indicates that IE is using a very small amount of power, about the same as each of the other apps. Although in her case, background operation for IE is enabled.

    Therefore, I have concluded that, for some reason, the IE app is draining my battery power, even though it is not in use, and background operation is disabled.

    Any suggestions?

    thanks

    Keith
    10-30-2014 01:31 AM
  2. Yazen's Avatar
    Same here... IE has taken over 60% of my battery lol
    10-30-2014 01:53 AM
  3. Raviraj Halarnekar's Avatar
    Facing similar issue with my Lumia 620 ever since i upgraded to Cyan.I am getting around 4-5 hrs backup once fully charged.The funny thing is battery saver is showing that "battery saver" itself is utilizing most of the battery.
    Apart from this i am unable to connect my phone to my PC,tried every possible solution i could find in this forum but still no luck.
    10-30-2014 02:25 AM
  4. Shad0wguy's Avatar
    Sometimes this can happen. You may need to factory reset the device to remove any odd glitches like this.
    xandros9 likes this.
    10-30-2014 09:32 AM
  5. Paul Verizzo's Avatar
    Battery issues have always been a problem with WP 8+. However, what you are describing is off of the charts. I've had crude 8.0 Amber and now official 8.1 Denim. To say nothing of PforD. You should find that normal use is about 1-4% of use per hour. OTOH, WP still sometimes runs crazy with two or three times that!

    Keep poking around, I know from other threads that Facebook and always on email have been huge drainers. Good luck.
    10-30-2014 06:53 PM
  6. kmmcdonald's Avatar
    The problem seems to have fixed itself with no intervention on my part. Battery Saver indicates that IE is using about the same power as any other apps, and a single charge easily lasts a day. I have no idea what was happening for the first two days under 8.1.
    Guytronic likes this.
    11-01-2014 07:24 PM
  7. Yazen's Avatar
    The problem seems to have fixed itself with no intervention on my part. Battery Saver indicates that IE is using about the same power as any other apps, and a single charge easily lasts a day. I have no idea what was happening for the first two days under 8.1.
    Did you by chance close out all of your tabs?
    11-01-2014 08:12 PM
  8. Paul Verizzo's Avatar
    Having gone through numerous updates and battery issues on both 810's and 925's, having seen .3%/hr to 30%/hr discharge rates, I have been comforted by the observation that sometimes just let it do its nasties for a few days and then it seems to (mostly) even out. Oh, yes, you'll still get those inexplicable, nothing to do with apps giant discharges, but overall, it improves.

    It's like explorer.exe in Windows. The graphical interface, not Windows or Internet Explorer. I run a Dell computer with Intel chips and motherboard. Should be well behaved and stable on old Windows 7, no? No. A couple of times a week the box starts sucking CPU cycles to 100% or close to it, minute after minute. No program is sucking this, but if I kill explorer.exe, suddenly the GUI makes itself over and all is well again.

    It's really, really hard to understand how this can be the case, but it is. I think the same thing goes on with WP and the batter. No reasonable explanation. Just ****ty coding and management.
    11-05-2014 07:47 PM

Similar Threads

  1. Can anyone help me with some questions about the Microsoft band?
    By onysi in forum Microsoft Band & Band 2
    Replies: 18
    Last Post: 10-31-2014, 06:45 PM
  2. How to turn off lighted keys?
    By crisdiaz01 in forum Nokia Lumia 925
    Replies: 2
    Last Post: 10-31-2014, 05:55 PM
  3. Why have my contacts duplicated after the software update?
    By mahavir parsad gupta in forum Windows Phone 8
    Replies: 1
    Last Post: 10-30-2014, 01:10 AM
  4. Why is Lumia Denim written on my Nokia Lumia 630 after a hard reset?
    By Hariharan Purohit in forum Nokia Lumia 630
    Replies: 1
    Last Post: 10-30-2014, 12:32 AM
LINK TO POST COPIED TO CLIPBOARD