1. misterpentax's Avatar
    Hi,

    I have a T-Mobile Nokia 925 running 8.1. My power button does not work most of the time. It doesn't appear to be a physical issue since it will work if I do a factory reset of the phone. It'll work for a few days after the factory reset and then it'll stop working again. It's frustrating because in order for me to use the phone, I have to hit the camera button to go into the camera and then push the home button to go to the main screen.

    I've had this issue since 8.0 and was hoping it was a software issue that 8.1 would correct.

    Does anyone have any suggestions on what I can do? Is this a common issue? Am I missing something stupid? I already tried to reset the phone by holding the volume down + power, and doing a factory reset as well. Currently, volume down + power doesn't work at all.

    Thank you
    11-09-2014 11:43 AM
  2. lugies's Avatar
    My wife's 925 is having the exact same issue. It was actually so bad that we called T-Mobile to get it replaced under warranty. Now, a few months later it is happening again with the replacement! Factory reset didn't help it the first time either. I've been doing some searching but can't seem to find much except there do seem to be a lot of power/volume switch flex cables for sell...
    11-13-2014 01:44 PM
  3. Paul Verizzo's Avatar
    Well, that certainly sucks. I've owned many, many phones over the years, including the original, actual, honest to God car phone way back. Almost all of my PCS phones have been Nokia. I've never had so many problems with one model - and two phones - as I've had with the 925's. I keep sending them in for repair - connectivity issues - they come back maybe fixed, or not, back to the shop.

    I suggest seeing if your phone is under warranty. If hard resets don't fix your problem, permanently, that's about your only option. I presume you are running latest and greatest updates.
    11-13-2014 02:32 PM
  4. metalchick719's Avatar
    Never, ever have this problem with my 925. However, tap to wake isn't quite as responsive on it as it is on my 920, for some reason.
    11-13-2014 02:51 PM
  5. Paul Verizzo's Avatar
    Never, ever have this problem with my 925. However, tap to wake isn't quite as responsive on it as it is on my 920, for some reason.
    Double tap is worthless on my 810, much better on one of my 925's, not as good on another. Huge variability. Easier to just hit the power button, it always works.

    I wish they would just make the Start button active to unlock. I had a Cyanogen Mod'ed Android and that was pretty sweet. Touch that front "button," and it opened to your last desktop. No lockscreen to work past. Sweet.
    11-14-2014 08:13 PM

Similar Threads

  1. Camera OIS issue
    By michaelcly in forum Nokia Lumia 830
    Replies: 17
    Last Post: 07-09-2015, 10:01 PM
  2. What's your next upgrade after the 920?
    By Estep16 in forum Nokia Lumia 920
    Replies: 49
    Last Post: 12-30-2014, 09:51 AM
  3. Does the white 930 get dirty
    By bozza72 in forum Nokia Lumia 930
    Replies: 7
    Last Post: 11-11-2014, 10:34 AM
  4. Canadian WIND subscribers: T-Mobile's model will work
    By Matthew Becker1 in forum HTC One (M8) for Windows
    Replies: 6
    Last Post: 11-10-2014, 08:51 AM
  5. The reason why I switch to Android then Windows Phone again
    By omer620 in forum Windows Phone 8.1
    Replies: 6
    Last Post: 11-09-2014, 03:40 PM
LINK TO POST COPIED TO CLIPBOARD