The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. GoNokindow's Avatar
    Hey, my Lumia 925 is at cyan, OS: 8.10.14219.341 (preview for developers) Is it just me or is anyone else's 925 starting to show signs of lagging in resuming apps, and/or switching apps? Is your just the fact that it's an old hardware running a new OS?
    02-08-2015 05:45 AM
  2. Athull's Avatar
    If ur talking about resuming screen then its something that infected pretty much every Lumia(even 1520) so its mostly the OS part that is no longer so smooth as it used to be.
    Guytronic likes this.
    02-08-2015 05:58 AM
  3. Harrie-S's Avatar
    No problems here with same phone and OS.
    Guytronic likes this.
    02-08-2015 05:58 AM
  4. GoNokindow's Avatar
    Sometimes when I pull down the notification, the action tiles are blank. Takes about 1-3 seconds before the icons reappear. Weird. And look, I'm ok with waiting a few seconds. Not like I'm gonna lose an arm or something. But I'm just trying to see if the general lag is something common cause if its simply the case of an old hardware having problem keeping up with a new OS, I may just skip updating to windows10 to avoid additional lagging. You know, keep it at its current OS which runs smooth enough, ya not as smooth as Windows phone 8. But hey... Progress... no? Looking forward to what Microsoft will bring to a larger screen phone (split screen please!!!) I may just upgrade to a larger screen, with a newer specs and keep my good old 925 as a backup phone.
    02-08-2015 06:28 AM
  5. Harrie-S's Avatar
    The hardware is not the problem. What will help is a hard reset or even better to use the lumia software recovery tool.
    http://forums.windowscentral.com/e?l...token=deBI-LPi

    I would suggest to wait till the denim update is available for your phone and update to denim with the lsrt and not use the OTA.
    Guytronic likes this.
    02-08-2015 06:45 AM
  6. MAHER_Central's Avatar
    I don't know. I have the 925 but it's really smooth. Maybe it's not as fluid as it used to be. Perhaps its because of the 16 GB of storage. I'm really excited to install windows 10 but now I'm afraid. Will it slow my Lumia ??
    Guytronic likes this.
    02-08-2015 05:38 PM
  7. pratok69's Avatar
    It may be coincidental, but I reinstalled Facebook about 2 weeks ago and began to notice laggy buggy performance. As I read the OP, I uninstalled Facebook. Did a restart, and performance seems noticeably better. I'm just sayin'...
    Guytronic likes this.
    02-08-2015 08:14 PM
  8. untitled007's Avatar
    I just want to share my experience, btw i have a 620, and experiencing that kind of lag. And almost **** off, and hearing the w10 will be available in few days, i decided to remove some apps in my phone memory, and decided to uninstall the News app. And boom, i was amaze how smooth my phone again, hitting the win button is smooth, not showing the resume thing again, and its just fast, i dont know, but i think the News apps is kinda heavy. Try to uninstall it.
    Harrie-S and Guytronic like this.
    02-08-2015 08:42 PM
  9. ryancut's Avatar
    I just want to share my experience, btw i have a 620, and experiencing that kind of lag. And almost **** off, and hearing the w10 will be available in few days, i decided to remove some apps in my phone memory, and decided to uninstall the News app. And boom, i was amaze how smooth my phone again, hitting the win button is smooth, not showing the resume thing again, and its just fast, i dont know, but i think the News apps is kinda heavy. Try to uninstall it.
    I uninstalled the news app along with the sports app and it does seem like my phone is much smoother now.
    Guytronic likes this.
    02-09-2015 02:31 AM
  10. GoNokindow's Avatar
    My here drive app also seems to be crashing a lot lately. Like alot! Maybe I'll try uninstalling some apps. See how that works out.
    02-09-2015 10:15 AM
  11. mikosoft's Avatar
    If you install many apps some of them may have background tasks running. Check in Battery Saver if there are any that you don't need and disable them.

    I also experience ocassional hiccups and action button blackouts. It was much worse while on 620 with Dev Prev but I was hoping it will completely disappear with 925. Didn't happen sadly :/ I'm holding on for Denim to see if anything improves but I'm not really having any high hopes ad Denim is only a minor update.
    02-11-2015 09:13 AM
  12. wpfanboy17's Avatar
    Sometimes when I pull down the notification, the action tiles are blank. Takes about 1-3 seconds before the icons reappear. Weird. And look, I'm ok with waiting a few seconds. Not like I'm gonna lose an arm or something. But I'm just trying to see if the general lag is something common cause if its simply the case of an old hardware having problem keeping up with a new OS, I may just skip updating to windows10 to avoid additional lagging. You know, keep it at its current OS which runs smooth enough, ya not as smooth as Windows phone 8. But hey... Progress... no? Looking forward to what Microsoft will bring to a larger screen phone (split screen please!!!) I may just upgrade to a larger screen, with a newer specs and keep my good old 925 as a backup phone.
    Yes, even my 925 has the blank tiles problem. It takes a long time to load all icons on the start screen and action menu. One way to get rid of the problem temporarily is to lock and unlock the phone a couple of times.

    One more major problem (most hateful one) is apps crashing a lot . I believe its happening more when I make a new connection to bluetooth device or switch automatically from wifi->celluar. Anybody with this problem????
    02-11-2015 09:28 AM
  13. metalchick719's Avatar
    I've had my 925 for nearly a year now. No lag whatsoever and it runs just as smoothly as it did when I got it. How much free storage do you have?? Maybe that could be an issue?
    02-11-2015 10:21 AM
  14. Michael Kozak's Avatar
    Ditto for me .... Have had my 925 about a year and a half now and it's running like new, without lags. Running Cyan 8.1. Stopped using PfD, unpinned and closed all interests in Cortana.

    And I really only have about 20 apps I use consistently.

    Took a few factory resets to get things running smooth again, after all the updates (amber > black > cyan). Then sorting out which apps were a must for me. But have ample room now for 10. And this pretty little phone .... is running like day one.
    Last edited by Michael Kozak; 02-11-2015 at 10:51 AM.
    02-11-2015 10:41 AM
  15. wpfanboy17's Avatar
    I've had my 925 for nearly a year now. No lag whatsoever and it runs just as smoothly as it did when I got it. How much free storage do you have?? Maybe that could be an issue?
    I have 347MB unused storage now. I would say that's pretty sufficient for opening apps such as twitter, xbox music.
    02-11-2015 10:51 AM
  16. GoNokindow's Avatar
    I got about 2G remaining. Hm.. Could be that Cortana is engaged in all the interest features. And it's not the apps running in the background thing. I always close them and most are not active in the battery saver settings. But thanks to those who shared their own exp. Helps me get a better feel of the general performance of my model.
    02-17-2015 01:16 AM

Similar Threads

  1. Replies: 3
    Last Post: 06-01-2015, 05:00 AM
  2. Replies: 4
    Last Post: 03-22-2015, 03:57 PM
  3. Replies: 1
    Last Post: 02-08-2015, 05:10 AM
  4. before proper setting i have switch off my lumia 520
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 02-08-2015, 04:55 AM
  5. Replies: 6
    Last Post: 02-08-2015, 04:49 AM
LINK TO POST COPIED TO CLIPBOARD